No announcement yet.

Connection Failed

  • Filter
  • Time
  • Show
Clear All
new posts

    Connection Failed

    Connection failed.
    over and over and over.
    Epic owes some explanations!

    I seem to connect fine with multiplayer. It works just fine: except with co-op campaign. I cannot seem to connect to 99% of people playing multiplayer campaign. Any reasons this would be the case?


      Also, if you do "reconnect" in the console it won't work even if the server is still up and that you load the map before receiving "Connection Failed" message.


        Is there still no-one who found how to fix this?

        I've finished the Campaign now, nothing left to do while waiting except play with bots, who are sometime retarted (shooting me, while on the same team, because I picked up our flag that was stolen? Running into a wall and not stopping until death?).

        I mean, what's the point of UTIII if I can't play online =(.

        I can get the community message just fine, I can see the leaderboard, I can see the server list... But once I try to connect, it goes :
        "Loading screen (with the usual tips)"
        "Connection Failed"

        And nothing fixed that, it's not because of a firewall, it's not because of a router, I got no idea how to fix it, every other game I got works fine on multi. I don't get that message AFTER finishing a multi game, I can't even connect for a single game. I see the servers, but it always bug out before I can even join.


          contact you ISP, they will go through some troubleshooting with you to identify the problem with your network, seeing you have one. You may have to ring a few times untill you get a person who is willing to give you the time of day tho.

          Also, some Network Interface Cards cant handle certain protocols - its may be that your card does not have the cabability to run UT3 over the net. Bung a new NIC into your system and see if that does the trick (they are super cheap, if you dont know how to fit one just buy one and get some tech in a component store to fit it for $10). I've had an NIC that just wouldnt perform with some games in the past, gave it the ol' heave ho.

          Oh, and make sure you have the latest drivers for your network card.


            Same here
            What port need to be open for ut3?

            P.S. I havnt this problem with the beta demo o_O


              1) I don't think this comes from my ISP or my end, I've played LOTS of games in multi, first time I ever get this. Too many to be unaware of any problem I could have overlooked.

              2) Beta demo worked fine too, only full game gives me this.