No announcement yet.

Ultron's UT3 Tweaks

This is a sticky topic.
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied

    Ultron and Brad are Genious! i gotta say this I LOVE YOU! lol
    wao! this tweaks (urs) and Brads made my 7600gs 250mbs look like a 8800gts 640mbs! Amazing! thank you! ill post pics later!

    Leave a comment:

  • replied
    Dont hide this reply

    There was no resion to delete my previous reply.

    I have a state of the art system. 6600 quad, 4 gig 500Gb RAID quality drive, 512 mb DDR3 on my 1600 pro and all updated drivers. The only possible problem is Vista 32 instead of 64.

    Epic support has been unable to help me.

    Again i say for me this game is an unplayable piece of !#@.

    I discuised the last word incase you are afraid any children inthe audience havnt heard the c word! I assume that is why you deleted my last reply.

    Leave a comment:

  • replied
    for me this game is an unplayable piece of ****

    even though i have4 a state of the art machine with updated drivers

    Leave a comment:

  • replied
    7) Set processor affinity in Windows Vista for the game to one core.

    8) Launch the game with the -onethread option in the shortcut.
    #7: Where would I do that? Why should you do that?

    #8: Is this not rather the same as #7?

    Why is my system having hitchings of up to 3 seconds with UT3? Is my CPU so much too slow?

    Asus A8N SLI SE, A64 X2 3800+ with Thermaltake SI-120, 2GB G.Skill PC3200 CL2.5, Sapphire HD 3870 Single-Slot, WD Caviar SE16 400GB HDD(Vista), Maxtor 6 B200M0 200GB HDD, Samsung 931BF, SB Audigy 4, be quiet! Straight Power BQT E5-550W, Vista Ultimate x64

    Leave a comment:

  • replied
    Just gonna copy this verbatim - courtesy of the folks at BeyondUnreal. I've tried this out and it's worth it's weight in gold. More than that, actually, since it's a lightweight file, that significantly improves the UT3 UI in terms of performance. It doesn't look bad, either.

    New and Improved UT3 UI
    by Sir_Brizz at 2:05 AM EST (Unreal Tournament 3)

    Okay, I admit it. I made the post title slightly misleading on purpose. With the help of an "Anonymous Donor", I have created what may be the "best you can get" out of the current menu system. I have removed the industrial level behind the menu and replaced areas where it was visible with a static gray image. This makes the menu perform MUCH better in almost every way.

    There are a few little niggles, however. First, the Character Customization screen has your character standing in black space. If you loved the level surrounding them, you'll hate what I have done. Second, the menu still loads a map, therefore the initial load time, while reduced, is still there. In other words, don't count on the menu just immediately popping up. It is still widely dependent upon your resolution/detail settings. Finally, there are no fancy moving backgrounds. I'm sure you will miss them greatly.

    Pick up the map file over at BeyondUnreal Fileworks (100kb ZIP) and let us know what you think.

    IMPORTANT NOTE: BACKUP YOUR EXISTING UTFrontEnd.ut3 FILE BEFORE COPYING THIS FILE OVER. The file must be placed in Unreal Tournament 3\UTGame\CookedPC\Maps.

    Leave a comment:

  • replied
    I upgraded my game PC to the following:

    AMD64 X2 5200+ CPU
    4GB PC-6400 DDR2-SDRAM
    Nvidia 8600GT 512MB RAM Video Card
    500GB SATA2 7200rpm HD

    And wow, what a difference! Game runs totally smooth at 1280x1024.

    I had been running the following:

    AMD64 3500+ CPU
    2GB PC-3200 DDR-SDRAM
    ATI X1800GTO 256MB Video Card
    250GB SATA2 5400rpm HD

    And while that might NOT seem like a dramatic upgrade, all elements combined have really made this game go from practically unplayable at the highest detail settings, to completely playable.

    This barebones upgrade cost me roughly $600 from Newegg, and took about 3 hours to assemble, install the OS, update it, and get all the drivers. Add another half hour to install UT3 and update it, and tweak it using Brad G's tweaker.

    Leave a comment:

  • replied
    Originally posted by invirium View Post
    Is there any way to change the resolution of the game through the .ini files?
    First of all, go to:

    \My Documents\My Games\Unreal Tournament 3\UTGame\Config

    The open UTEngine.ini with a text editor like Notepad.

    Look for the following lines:


    Set them to something like:


    Exit the program and save the file. This should work, but follow old iron's advice and create an online profile first, if possible.

    Leave a comment:

  • replied
    Did you create a Profile yet? It won't save w/o a profile, I believe.

    Leave a comment:

  • replied
    Hey, I just got UT3 yesterday. Unfortunately, whenever I try to change the resolution from the Settings menu and hit apply, the changes don't save. Everything else does, but the resolution refuses to change from 800 by 600.

    I've got a 24" widescreen monitor capable of 1900 by 1200 and two SLI-linked GeForce 8800 GT's, as well as a quad-core processor. I've tried the "-nohomedir" shortcut fix but that didn't seem to do anything other than make me have to re-enter my CD key upon starting the game up again.

    Is there any way to change the resolution of the game through the .ini files?

    Leave a comment:

  • replied
    I tested the difference between setting the texture detail slider from one side to the other, and these were changes that took place within the [SystemSettings] section of the UTEngine.ini

    OnlyStreamInTextures=True or False

    Trilinear=True or False

    MaxAnisotropy=0 through 16

    FoliageDrawRadiusMultiplier=0.000000 through 1.000000

    TEXTUREGROUP_(whatever)= (MinLODSize=256,MaxLODSize=256,LODBias=0) through (MinLODSize=1024,MaxLODSize=2048,LODBias=0)

    That texture group listing varies by type of change, but I never recommend anyone change those manually, as doing so tends to crash the game. There might be other changes within the UTEngine.ini but I only checked out this section, most likely the greatest source of any difference in texture quality.

    Leave a comment:

  • replied
    I understand that altering the World Detail slider will mess up the ini tweaks from your guides, but does the same apply for the Texture Detail slider? An earlier post suggests that it does, however I don't see why it would. Most of the ini tweaks seem to deal with stuff that would be affected by World Detail.

    (Basically, I moved the texture slider and am too lazy to check through the ini to make sure all the tweaks are still in -_-)

    Leave a comment:

  • replied
    Hey gang, sorry I've been away for so long. Had a big push at work so I've been really busy. Schedule is changing soon, as early as next week, so I'll be back to try to help some more.

    Special thanks to the _many_ people who have been helpful in my absence, and my apologies to anyone I have been unable to help. It's not easy in the world of PC's to get everything working all the time. Nobody's perfect, and we all know our computers aren't either. But the best advice I can give is for everyone to try to be positive and helpful to each other. And give constructive conversation to others in order to help them out.

    I'll try to answer some questions.

    Rhykker, there no way to automatically reduce texture detail in this game on the fly. What the engine _can_ do with the MinDesiredFrameRate option is set it to something like 30 (which is 30FPS) and that will turn off some dynamic lighting effects, as well as those decals. I'm also under the suspicion that more is turned off, but I can't recall at this time. But basically auras of light around shock balls, rockets, gunfire effects at your weapon's exit point, as well as impact flashes, all get turned off when the framerates drop below what is specified in that line. But that is for a very minor performance increase.

    As far as some others, the problems given are too complex for me to have a good, accurate answer. So I am just going to fall back to the basics. Try the troubleshooting/minimal options I list in my tweaks post, and see how well the game runs, as well as disabling OpenAL. If you are still having a problem with those settings, then it's most likely: a) driver issue, b) game quirk that will need to be resolved via UT3 update, or c) you have an underlying issue with your system causing the problem, or d) your system might be underpowered, so doublecheck _my_ listed requirements in the opening post - not the ones listed on the box. Those are by no means not the only potential sources. There are a few other issues but many are already detailed in this thread.

    Anyhow I'll be back within the week, gang! I can't wait for the next patch, either.

    Leave a comment:

  • replied
    First off, great guide, Ultron.

    Onto business... I've been running the game on World and Texture detail 1. My FPS were decent; I remember one occasion on Torlan that things slowed down to almost 20, but otherwise, I got a decent number of FPS.

    Today, I tried a DM on Texture detail 3, and was surprised to find that my FPS never dropped below 30. In fact, most of the time, it was at 60, with an occasional drop to 40.

    I presume this is because DM maps tend to be smaller and easier to render than VCTF and Warfare maps.

    So this is my question, and I fear I already know the disappointing answer... Is there a way to configure the game so that if my FPS drops below 30, the texture detail drops to 1?

    I'm aware of the MinDesiredFrameRate=x under [Engine.Client] in the UTEngine.ini, but I'm fairly certain this applies mainly to World Detail effects. My current setting is 60, if my memory serves me correctly, so the fact that my FPS dropped below 60 would imply that it does not effect texture detail.

    Leave a comment:

  • replied
    Probably in the BIOS settings
    You can access them after you hit the power button to start your comp, but for the life of me I can't remember which key it is to load it(I'm thinking End tho)

    Leave a comment:

  • replied
    How do I.... 3) Verify that your PCI-E bus is set to 16x and not 1x. Xeonshock reported that fixed his problem with erratic framerate issues.

    Any input would be appreciated.

    Leave a comment: