Announcement

Collapse
No announcement yet.

Ultron's UT3 Tweaks

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Sorry if this has already been answered, can't find any thing though the search

    I have the STEAM install of UT3, and would like to turn off the start-up intro screens (Yes, I know you can click through them, just wonna turn them off completely)

    I have done the script out in the UTEngine.ini file,

    [FullScreenMovie]
    ;+StartupMovies=Copyright_PC
    ;+StartupMovies=EpicLogo
    ;+StartupMovies=MidwayLogo
    ;+StartupMovies=UE3_logo
    ;+StartupMovies=Nvidia_PC
    ;+StartupMovies=Intel_Duo_Logo
    ;+StartupMovies=UT_loadmovie1

    The path for STEAM is:
    C:\Program Files\Steam\steamapps\common\unreal tournament 3\UTGame\Config. UTEngine.ini
    But they STILL appear Can they be turned off in STEAM? Which file do I need to find to do this?

    Many thanks
    Swifty

    Comment


      BUMP!!!.....Does ANYBODY know????
      Thanks

      Swifty

      Comment


        Ummm, if your INI lines have +'s in front of them you're looking at one of the default/include inis from the game dir.
        Have you tried
        My Documents/My Games/Unreal Tournament 3/UTGame/Config/UTEngine.ini ?

        Comment


          Originally posted by Star Weaver View Post
          Ummm, if your INI lines have +'s in front of them you're looking at one of the default/include inis from the game dir.
          Have you tried
          My Documents/My Games/Unreal Tournament 3/UTGame/Config/UTEngine.ini ?
          Thanks Star Weaver, should have checked that myself.. Got it to work now,

          Cheers m8 for your help....owe you a pint

          Swifty

          Comment


            I am having lots of issues with my UT3 on Vista 64bit with stutters near portals and bad fps in most maps with out bots.

            my fps on dm deck for example is 60 in most parts until I get to the redeemer portal then it stutters and drops to 20 and if I am in the room where the bio gun is looking out towards the redemeer window my fps drops to 40 and stutters but if there is any bots shooting at me it drops as low as 18.

            I currently use the following in my computer

            Main board: MSI P6n SLI Platinum
            Processor: 2.4Ghz Quad
            GPU: Nvidia XFX Geforce-285
            Sound: Sound blaster X-fi fatal1ty pro gamer edition
            Ram:OCZ Platinum ddr2 1066
            HD. 7200RPM 500gb western digital
            DVD drive: DVD Multi recorder rw dvd-r-dl

            any clues to what may cause this rediculeous slow down?

            I have tried a 8800gtx and sli 8800gtx as well but I think the fault of my slow fps even on minor detail is the motherboard. p6n sli is a piece of junk

            Comment


              Sorry....Run Winxp Pro....But if your only Comparing DM DECK, I think it's a problem we all have with this map, I know I do, and in exactly the same places, but system's not as good as yours Does this happen with other maps, either with stock or add-on maps?....DM Deck, I know to be quite bad in some places with FPS slow downs

              Swifty

              Comment


                hey Swiftyone, DM deck does have its poor fps spots like the bio gun room omg I get like 12 fps there for no reson at all.

                Heres a list of maps I try to avoid playing due to poor fps drops for no reson at all.

                Dm-Sanctuary
                DM-Turbine
                DM-Diesel
                DM-Arsenal
                DM-Defiance
                DM-Koos Barge
                DM-Deimos
                DM-Eden INC

                Thats most of the dm maps and all but 1 CTF map works flawlessly with my rig.
                morbias lol only ctf map that works great the rest have fps drops of 30-18 and lower and I get screen freeze like jitters or something its a little odd.

                I do think its my mobo or maybe its cause I run vista 64bit ultimate.
                I have read that vista 64bit has lots of issues in terms of stability.

                is there a way to get a boost of performance by shutting windows vista features off?

                Comment


                  Sorry, as much as I'd like to help I don't know about Vista, running XP ..Maybe a techy person can help....Could also be wise to open a new thread too...As not many peeps would notice your problems in the "Ultron's UT3 Tweak"....people who "Could" help, may miss......Best of luck, hope you find an answer

                  Swifty

                  Comment


                    I'd like to share something that's usual in competitive gaming, and that's bringing your textures to minimum...

                    In UTEngine.ini, [SystemSettings] you have some TextureGroups. You can change texture LOD for every texture group. Note that the game will crash on many settings, test it out a bit. Use "round" numbers (that's 1,2,4,8,16,... 2^n)

                    These are settings if you push texture slider to 5 ingame, which is max UT3 has:

                    Code:
                    TEXTUREGROUP_World=(MinLODSize=256,MaxLODSize=1024,LODBias=0)
                    TEXTUREGROUP_WorldNormalMap=(MinLODSize=512,MaxLODSize=1024,LODBias=1)
                    TEXTUREGROUP_WorldSpecular=(MinLODSize=256,MaxLODSize=1024,LODBias=1)
                    TEXTUREGROUP_Character=(MinLODSize=512,MaxLODSize=1024,LODBias=0)
                    TEXTUREGROUP_CharacterNormalMap=(MinLODSize=512,MaxLODSize=1024,LODBias=0)
                    TEXTUREGROUP_CharacterSpecular=(MinLODSize=512,MaxLODSize=1024,LODBias=0)
                    TEXTUREGROUP_Weapon=(MinLODSize=512,MaxLODSize=1024,LODBias=0)
                    TEXTUREGROUP_WeaponNormalMap=(MinLODSize=1024,MaxLODSize=1024,LODBias=0)
                    TEXTUREGROUP_WeaponSpecular=(MinLODSize=512,MaxLODSize=1024,LODBias=0)
                    TEXTUREGROUP_Vehicle=(MinLODSize=1024,MaxLODSize=2048,LODBias=0)
                    TEXTUREGROUP_VehicleNormalMap=(MinLODSize=1024,MaxLODSize=2048,LODBias=1)
                    TEXTUREGROUP_VehicleSpecular=(MinLODSize=1024,MaxLODSize=2048,LODBias=1)
                    TEXTUREGROUP_Effects=(MinLODSize=256,MaxLODSize=1024,LODBias=0)
                    TEXTUREGROUP_Skybox=(MinLODSize=512,MaxLODSize=2048,LODBias=0)
                    TEXTUREGROUP_UI=(MinLODSize=1024,MaxLODSize=4096,LODBias=0)
                    TEXTUREGROUP_LightAndShadowMap=(MinLODSize=512,MaxLODSize=4096,LODBias=0)
                    TEXTUREGROUP_RenderTarget=(MinLODSize=1,MaxLODSize=4096,LODBias=0)
                    I like to minimize World textures, which increases visibility and everything looks much clearer. I leave other textures on maximum, as I like the characters/weaponw/vehicles/etc show in high resolution.

                    So, you simply have to change MinLODSize and MaxLODSize for Texturegroup World to 1.

                    Code:
                    TEXTUREGROUP_World=(MinLODSize=1,MaxLODSize=1,LODBias=0)
                    TEXTUREGROUP_WorldNormalMap=(MinLODSize=1,MaxLODSize=1,LODBias=1)
                    TEXTUREGROUP_WorldSpecular=(MinLODSize=1,MaxLODSize=1,LODBias=1)
                    TEXTUREGROUP_Character=(MinLODSize=512,MaxLODSize=1024,LODBias=0)
                    TEXTUREGROUP_CharacterNormalMap=(MinLODSize=512,MaxLODSize=1024,LODBias=0)
                    TEXTUREGROUP_CharacterSpecular=(MinLODSize=512,MaxLODSize=1024,LODBias=0)
                    TEXTUREGROUP_Weapon=(MinLODSize=512,MaxLODSize=1024,LODBias=0)
                    TEXTUREGROUP_WeaponNormalMap=(MinLODSize=1024,MaxLODSize=1024,LODBias=0)
                    TEXTUREGROUP_WeaponSpecular=(MinLODSize=512,MaxLODSize=1024,LODBias=0)
                    TEXTUREGROUP_Vehicle=(MinLODSize=1024,MaxLODSize=2048,LODBias=0)
                    TEXTUREGROUP_VehicleNormalMap=(MinLODSize=1024,MaxLODSize=2048,LODBias=1)
                    TEXTUREGROUP_VehicleSpecular=(MinLODSize=1024,MaxLODSize=2048,LODBias=1)
                    TEXTUREGROUP_Effects=(MinLODSize=256,MaxLODSize=1024,LODBias=0)
                    TEXTUREGROUP_Skybox=(MinLODSize=512,MaxLODSize=2048,LODBias=0)
                    TEXTUREGROUP_UI=(MinLODSize=1024,MaxLODSize=4096,LODBias=0)
                    TEXTUREGROUP_LightAndShadowMap=(MinLODSize=512,MaxLODSize=4096,LODBias=0)
                    TEXTUREGROUP_RenderTarget=(MinLODSize=1,MaxLODSize=4096,LODBias=0)
                    I'm not all that sure how LODBias affects image quality. I haven't noticed any difference with it set to 1/0.

                    Remember, it's not a good idea to set everything to 1. It can get strange and confusing.

                    The result is something like this:

                    Comment


                      This may be usual in competitive gaming, but I didn't spend $1300 on video cards to have Deck look like that.

                      Comment


                        I don't play because of graphics (I have UDK for that )

                        Comment


                          I am on WinXP.
                          I was experiencing constant hitching, I tried all the ini tweaks and everything but to no avail.

                          THEN I tried changing the compatibility to run UT3 in. Running in compatibility for win98 caused a crash but running it in compatibility mode for win2k completely fixed it!

                          I think this fix has not been posted before so I just made an account to post it incase it helps someone else

                          Comment


                            Originally posted by DscytheX View Post
                            This is from the UT3 guide on http://www.tweakguides.com/UT3_7.html under [Engine.GameEngine]:

                            "Note: When playing online, the engine is capped at 90FPS regardless of these settings, and can't be uncapped."

                            Hope that helps. =)
                            wrong



                            to uncap fps

                            set your utengine.ini like this

                            [Engine.GameEngine]
                            bSmoothFrameRate=TRUE
                            MinSmoothedFrameRate=0.000000
                            MaxSmoothedFrameRate=0.000000

                            Comment


                              Nice, much appreciated

                              Comment


                                Thank you for the sharing of your information........

                                Comment

                                Working...
                                X