Announcement

Collapse

The Infinity Blade Forums Have Moved

We've launched brand new Infinity Blade forums with improved features and revamped layout. We've also included a complete archive of the previous posts. Come check out the new Infinity Blade forums.
See more
See less

Ultron's UT3 Tweaks

Collapse
This is a sticky topic.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    Originally posted by Ultron View Post
    Ah sorry to hear that. If you have SLI, have you tried turning that off?



    Ah you are correct. I will change that.
    No SLI, have a 8800GTS 320

    I think the hitching is either a driver bug or we need an Epic update to fix it.

    Comment


      #17
      Bump! Great thread. Sticky maybe?

      Comment


        #18
        I am going to quote someone who used a combination of the following tweaks and this helped him greatly. These are all found in my opening post, but he writes it all down very well.

        Originally posted by Tassadaru View Post
        I had the freezing-forever part of the bugs too.

        Here's what I did, the tweaks.

        First is in UTEngine.ini

        Changed :
        From: PumpWindowMessagesWhenRenderThreadStalled=False
        Into: PumpWindowMessagesWhenRenderThreadStalled=True


        Second is in UTEngine.ini

        Changed:
        From: bInitializeShadersOnDemand=False
        Into: bInitializeShadersOnDemand=True


        Third is ingame (or ini-modifiable too I think)

        Changed: Enabled OpenAL audio (I think that's what's it called)

        Forth in UTEngine.ini

        Change

        From: UseMinimalNVIDIADriverShaderOptimization=False
        Into: UseMinimalNVIDIADriverShaderOptimization=True


        And installed patch 1.01 Beta

        The game works flawlessly.

        Hope it helps.
        Also, have in mind, I am using drivers version 169.09 from nVidia (beta), and onboard audio. Here are my specs: http://utforums.epicgames.com/showpo...&postcount=254

        Comment


          #19
          Originally posted by Ultron View Post
          I am going to quote someone who used a combination of the following tweaks and this helped him greatly. These are all found in my opening post, but he writes it all down very well.
          I'm tempted to try it, but I'm against d/ling the beta patch at least for now.
          My concern is that it is not final and that epic may change it fixing this (hitching)
          and other issues, which is what I prefer.

          Comment


            #20
            Thanks for all the suggestions.

            Comment


              #21
              I ... for some reason ... don't have the [UTGame.UTPlayerController] option in my ini

              I can just add it in and there should be no harm right?

              Comment


                #22
                Originally posted by strikeratt View Post
                I ... for some reason ... don't have the [UTGame.UTPlayerController] option in my ini

                I can just add it in and there should be no harm right?
                Are you sure you're on the right ini?

                Comment


                  #23
                  I think this is important enough to add to this thread. Given the time and effort this person spent in finding out a way of enabling and disabling postprocessing in the game with the press of a button.

                  Originally posted by dickbird View Post
                  Strange thing I ran across this morning:

                  Noticed a few days ago the game's graphics on my pc seemed a little drab and dreary, flat looking, compared to some of the screen shots I was seeing from others.

                  Anyway, found these two lines in the input ini files:

                  Bindings=(Name="F7",Command="set D3DRenderDevice bUsePostProcessEffects False",Control=False,Shift=False,Alt=False)
                  Bindings=(Name="F8",Command="set D3DRenderDevice bUsePostProcessEffects True",Control=False,Shift=False,Alt=False)

                  and just for grins tried flipping that setting back and forth in game using those assigned keys. It had no effect.

                  Went back to the ini files, and discovered there was no reference to busepostprocesseffects, or d3drenderdevice, anywhere at all, other than in those two lines above.

                  Furthermore, using get commands on the references from those lines in the console would just get me the unknown class error message.

                  Applying a little guesswork, I discovered that substituting "engine.engine" for "d3drenderdevice" would make the commands actually work, and furthermore that the busepostprocesseffects setting had apparently been set to false on my pc for some time. I set it to true and... good golly, so that's what those post process effects look like...

                  I added busepostprocesseffects to the engine.engine section of the utengine.ini file, where it apparently belongs, and now I can flip it there whenever I want to.

                  I suppose this could be a 'bug,' but I'm sure it's probably just something I managed to get messed up myself, some time after installing the game. I don't know if you could call the difference subtle exactly, but I'm not sure whether or not they were ever enabled or not. Anyway, thought it might be useful to somebody.

                  Comment


                    #24
                    Adding this to the thread, since a lot of people have been complaining about lockups, and have been presuming it's an issue with the video card, when in fact it's been an OpenAL issue.

                    Originally posted by Jakey2.0 View Post
                    I have found (thanks to this thread) that just renaming the wrap_oal.dll within the UT3\bin directory gains a similar result - 5.1 surround sound without crashes.

                    Digging further, it seems that wrap_oal.dll can work standalone when renamed to openal32.dll, but this will cause the game to enumerate available sound devices slightly differently. Basically, the custom features of the X-Fi are no longer exposed.

                    Anyway, there is does seem to be a minor loss of sound quality with the workaround - it doesn't sound quite as "rich". I suspect it's down to the AL_RENDERER being Software based - but at least there's 5.1 sound, and a stable game. A step in the right direction, and acceptable until the issue is hopefully resolved by either Creative or Epic...
                    This file can be found here:

                    C:\Program Files\Unreal Tournament 3\Binaries

                    -

                    Originally posted by flikflak View Post
                    I run an unpatched UT3 under WinXP with a X-Fi Elite Pro and just fixed this annoying OpenAL problem!

                    Here's what to do:

                    Copy both OpenAL32.dll and wrap_oal.dll from Windows\system32\ to UT3\Binaries\ replacing Epic's outdated files... And voilĂ ! Switch OpenAL back on in UT3 and restart the game.

                    2 rounds WF and 2 DM maps later in OpenAL bliss, not a single crash/freeze!
                    Shame on Epic for the old buggy files, but I'm glad it was that simple actually!
                    Keep in mind that, in the event the UT3 files are newer than the ones you are trying to replace them with, keep the newest versions where they are in the UT3 Binaries folder.

                    -

                    Originally posted by OverToad View Post
                    So far tonight, I've now played for three hours straight with numerous games on Deck, and haven't locked up. My personal fix?

                    UNCHECK OPENAL IN THE IN-GAME MENU SETTINGS.

                    Will it work for you? I can't say that, but it did work for me. Goodluck, and thanks to those that offered constructive help!

                    Comment


                      #25
                      Partial success with these settings

                      Originally posted by Ultron View Post
                      msny have you tried this:

                      [Engine.ISVHacks]
                      UseMinimalNVIDIADriverShaderOptimization=True
                      bInitializeShadersOnDemand=True


                      That might help.
                      Ultron/all

                      After some expermentation I've set my UTEngine.ini to your section 2 settings for high quality.

                      I also added the above settings and disabled the hardware sound openAI driver in game.

                      My results now seem very good after playing some DM this morning. I saw no hitching to speak of, maybe some very slight pausing which is livable.

                      So I have some questions now

                      1) Your tweak sets vsync to true or on.
                      Does that follow the resolution ingame only or the desktop resolution going ingame? Mine are both different from each other.

                      My Dell 24" LCD is capable of 75mzh at certain settings, 60mzh at all the others. I have mine set 1152 x 864 75mzh
                      for the desktop.

                      The idea is to have my LCD set higher to 75mzh but the game at 60mzh.

                      2) Do these settings work with vsync set to false or off?
                      What changes would be made to keep high quality then?

                      My system
                      Intel 6600 duo
                      8800GTS 320mb
                      2 gigs Corsair memory
                      24" Dell LCD

                      Great work thanks so much!

                      Comment


                        #26
                        Originally posted by msny View Post
                        1) Your tweak sets vsync to true or on.
                        Does that follow the resolution ingame only or the desktop resolution going ingame? Mine are both different from each other. My Dell 24" LCD is capable of 75mzh at certain settings, 60mzh at all the others. I have mine set 1152 x 864 75mzh for the desktop. The idea is to have my LCD set higher to 75mzh but the game at 60mzh.
                        I believe it uses the refresh rate you are currently using at your desktop, though it could drop lower if the resolution you try to use is higher than your desktop resolution, and the max refresh rate there is lower. I'm no expert here, this is just guesswork.

                        Also, a lot of games tend to drop down to 60FPS when vsync is enabled, anyways.

                        Originally posted by msny View Post
                        2) Do these settings work with vsync set to false or off? What changes would be made to keep high quality then?
                        Yeah the game will look identical. You only risk some screen tearing if you disable Vsync.

                        Comment


                          #27
                          I love you man! I have been looking for these tweak for days!

                          Comment


                            #28
                            Originally posted by clark kent View Post
                            I love you man! I have been looking for these tweak for days!
                            No problem. I am here to help.

                            Comment


                              #29
                              Originally posted by Ultron View Post
                              I believe it uses the refresh rate you are currently using at your desktop, though it could drop lower if the resolution you try to use is higher than your desktop resolution, and the max refresh rate there is lower. I'm no expert here, this is just guesswork.

                              Also, a lot of games tend to drop down to 60FPS when vsync is enabled, anyways.



                              Yeah the game will look identical. You only risk some screen tearing if you disable Vsync.
                              Thanks so much, your help was much appreciated!

                              Comment


                                #30
                                will the lower graphic changes help me with my sh*tty graphics card? my log file says i didnt support shader model 2.0. could this help me get around that?

                                Comment

                                Working...
                                X