I never got to play the beta because after the spash screen loaded the game just halted and the process died. I figured it would be fixed by final release but I was mistaken. It appears Epic is learning bad habits from EA (not to mention the promised Linux client not on the dvd). Anyways.

1: Run the game with the "-nosound" option. This is temporary.

2: Hopefully your game loads. I have an Nvidia card with the latest drivers (for Crysis/Timeshift) and an Audigy 2 ZS. The game loaded fine without sound.

3: Go through the menus until you get to the sound options. Turn on OpenAL sound system. This is what I use for Linux and it sounds great, 5.1 and all.

4: Exit the game, download the latest OpenAL at http://www.openal.org/downloads.html and install. No reboot necessary.

5: Remove the -nosound parameter and you should be good to go!

I hope this helps others as I searched but was unable to find a solution. This will keep me playing occasionally on windows until the Linux client is released.