Announcement

Collapse
No announcement yet.

UT3 Crash after ~5 min of play - msvcr80.dll

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    UT3 Crash after ~5 min of play - msvcr80.dll

    So here's the story...

    UT3 launches, I log in, I can navigate the menu system, configure things like screen res & audio settings, etc. No matter what mode of play I try to launch; campaign, online death-match, etc... I play for ~ 5 min or so then the game halts, goes to black screen and I get a popup asking me if I want to report the crash to MS. I can ctrl-alt-del task manager up and kill the UT3.exe process and continue using the machine.

    Clicking on the more info about this error link gives me the following:

    "
    AppName: ut3.exe AppVer: 0.0.0.0 ModName: msvcr80.dll
    ModVer: 8.0.50727.762 Offset: 00017440
    "
    ...along with a bunch of crud about what information MS collects, what they don't and what they can do with it. (hehe)


    There is also an event posted in the application event log as follows:

    "
    Source: Application Error
    Event ID:1000

    Faulting application ut3.exe, version 0.0.0.0, faulting module msvcr80.dll, version 8.0.50727.762, fault address 0x00017440.
    "

    System Specs:

    Asus P5B-Delux Wi-Fi, BIOS:1216
    Core2Duo 2.4G
    2G Corsair XMS DDR2-6400
    SB X-FI Fatality gamer - current driver installed.
    EVGA 8800 Ultra - Forceware 163.69
    Windows XP SP2
    Not presently overclocked...


    I should probably also mention that I have no problem running Crysis which I believe uses the same base engine. Same with BioShock, BF2142, FEAR, Quake4, TF2, etc... only UT3 blows up and only after it teases me.

    I've tried turning off OpenAL sound as I saw that mentioned in the only other post with msvcr80.dll found by the search engine but that didn't help.

    Anyone else run into this? (and fixed it?)


    Thanks,

    ViperSD

    #2
    Hi, I had the same problem as you. Everytime I tried to play multi-player UT3 would just stop working. I noticed in event viewer the same error as you mention. After trying everything I could think of I found that turning off the Hardware Open Al seems to have fixed the problem. I played over a hour of UT3 with no issues. Why this is I dont know, but it seems to have worked.

    Sorry, I read where you had already tried this.

    Comment


      #3
      ok, I know I said it didn't work but in fact it did.

      The first time I tried turning off OpenAL acceleration in the audio settings I didn't restart the game, primarily because it didn't ask me to as it has with other changes I've made. Thus, the game crashed when I started playing after the first attempt and I believed this hadn't worked.

      After turning this off, exit and restart the game and your in business.

      Thanks Kilroy for sending me back to try it again!

      Comment


        #4
        Alot of people are having this problem at the moment it seems. I can't say if its Creative's fault though. I've done a fair amount of testing of other games that use OpenAL or some type of hardware acceleration in Audio and I get zero crashes. No sudden crash out into windows.

        Comment


          #5
          I have been experiencing the exact same issue since the beta demo was released. And as the OP stated, I am having no audio issues with other games. I have tried changing the MaxChannels under [ALAudio.ALAudioDevice] to 8, 16, 64 and 128 (default is 64), with no change to the issue. The only way I can finish a map is to disable Hardware OpenAL.

          Comment


            #6
            Originally posted by ViperSD View Post
            ok, I know I said it didn't work but in fact it did.

            The first time I tried turning off OpenAL acceleration in the audio settings I didn't restart the game, primarily because it didn't ask me to as it has with other changes I've made. Thus, the game crashed when I started playing after the first attempt and I believed this hadn't worked.

            After turning this off, exit and restart the game and your in business.

            Thanks Kilroy for sending me back to try it again!
            Your welcome Viper, Im glad it did actually work for you.
            As far as why this error happens I have no clue. I have a XFI Fatality with the latest set of drivers. I even updated my Open AL to see if that took care of the problem with no luck. I disabled AVG, I uninstalled and reinstalled my XFI and Video drivers. This fix was the only thing that worked. every other game I have runs fine, COD4, Bioshock, HL2 EP2 and so on. It seems like it is a bug with the game IMO.
            My system specs:
            Gigabyte GA-P35-DS3L
            Intel Q6600@2.8
            4GB Crucial Ballistx
            EVGA 8800GTS 163.75 WHQL
            Creative XFI Fatality 2.15.0004
            2 Seagate Barracuda SATA 300 HD's
            Corsair 620 Watt PSU

            Comment


              #7
              The only issue I have is that when I disable Hardware AL for my XFI Fatl1ty, I lose my 5.1 and I'm back to gaming in stereo. Not really a big deal I suppose, but the sound isn't 'big' or quite as resonant anymore. Is there a way to get 5.1 without having OpenAL checked?

              Comment


                #8
                unfortunately no, as far as I remember reading the only way to get 5.1 sound is to enable the OpenAL. Lame I know, as enabling this causes the game to crash. I too have had to disable this option and am not impressed by it.

                Comment

                Working...
                X