Announcement

Collapse
No announcement yet.

UT3 Freezes

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    Originally posted by moosa View Post
    Like many others, I've installed UT3 and have not been able to play it because it freezes up on me (video and sound freezes). My computer has the following configuration:

    XP Pro SP2 with the latest updates
    Intel Core2Duo 6700 2.66
    4 gig of RAM (although Windows only sees 3.25)
    NVIDIA GeForce 8800 GTS (version 6.14.11.6375 dated 10/4/2007)
    Sound Blaster X-Fi Xtreme Audio (version 5.12.1.620 dated 9/25/2007)
    ZoneAlarm Firewall, Anti-virus, Anti-spam, etc.

    If anyone has experienced the same problems and figured out how to fix it, please let me know what you did.
    If you wait for the menu screen to load, and just move your mouse cursor around does it stall/freeze on you there? If so there is no point to trying to play the game as it will just continue to lock up in the same manner.

    Do yourself a favor right now and change your .ini file to disable all those cinematics. They quickly get old when you're waiting to see whether the game is even going to run for you. If you're not sure just do a search here for "cinematic" and it'll be in the top results.

    Next, try removing a stick of memory, booting and loading the game. Did that work? No? You could try swapping the memory stick and booting from the other (just a single one each time) while saying to yourself "there's no memory test like my memory test." If you're lucky the game will run fine and you have just isolated your problem to a faulty stick of memory.

    If the game still stalls then it's not a problem with the memory modules themselves. Try this. If, like me, you have 2*2gb sticks of ram, you likely have them in slots 1+2 and your computer may even say something like "4 GB RAM Single Channel" when booting. In most cases this is fine BUT it turns out slots 1+2 share power. You may try moving the second stick to slot 3, so you are using 1+3. When you boot you will see something like "4 GB RAM Dual Channel Interleaved" -- and with luck that will do it for you.

    Lastly (assuming you've read through the other threads about stalling/freezing and tried those solutions) I would remove your X-Fi card and try running the game. It probably has nothing to do with your soundcard but it's never a bad thing to try to isolate the problem by removing removeable components.

    Also, please make sure you're running Driver Cleaner or Driver Sweeper or both (repeatedly in subsequent safe mode reboots) between uninstalls/version changes of video or sound card drivers.

    Good luck!

    Stallinggame

    Comment


      #17
      Originally posted by moosa View Post
      Actually, according to the vendor websites, they are the latest. If I'm mistaken, please let me know what version I should try.

      Thanks.
      Nvidia (and ATI/AMD for that matter) release official WHQL certified (Windows Quality Hardware Labs) drivers for the general public. In the face of newly-released software however, things tend to need tweaking. Thus, Beta Drivers are released and are quickly snapped up by enthusiasts who benchmark their latest games and seek every advantage possible.

      The release Crysis was one of note that had several revisions released to specifically address shortcomings on performance. I get most of my geek news from www.Guru3d.com and have for years used betas from both Nvidia and ATI depending on what system was my "gaming" computer at the time.

      UT3 seems terribly sensitive to overclocking and driver garbage and I spent days searching and testing tweaks to cure my random crashes, and not so random ones (every campaign audio briefing used to cause some sort of crash.) Note that I never posted a question on these forums, only suggested help when I discovered a fix for my system.

      So, naturally I thought at first it was an audio issue but what solved it for me was a tool called Driver Sweeper which I've been pimping on this forum like I'm expecting a cut from Guru3d (with whom I'm in no way associated other than as a frequent reader). I used it to wipe my drivers and every remnant of previous versions from my hard drive. I've never had to make that extra uninstall step for any other game, but I'm a determined UT fan.

      So give this little tool a chance to work its magic. Boot in safe mode and run the tool then install the latest betas. I'm on 169.13 and there have been a couple newer ones released since but at this point UT3 is working perfectly and I'm on the "if it ain't broke, don't fix it" bandwagon. And please, post back your results.

      http://www.guru3d.com/index.php?page=driversweeper

      Comment


        #18
        Here are some options you might try:

        Edit the UTEngine.ini which can be found in My Documents\MyGames\Unreal Tournament 3\UTGame\Config.

        For older NVIDIA cards:
        [Engine.ISVHacks]
        UseMinimalNVIDIADriverShaderOptimization=True
        bInitializeShadersOnDemand=True
        PumpWindowMessagesWhenRenderThreadStalled=True


        ...and then...

        [SystemSettings]
        OnlyStreamInTextures=True


        Let us know if that works.

        Also, if you still have problems, try the other tweaks in my thread, listed in my sig below.

        Comment

        Working...
        X