Announcement

Collapse

The Infinity Blade Forums Have Moved

We've launched brand new Infinity Blade forums with improved features and revamped layout. We've also included a complete archive of the previous posts. Come check out the new Infinity Blade forums.
See more
See less

HA20X2K.SYS blue screen

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • HA20X2K.SYS blue screen

    Blue screen with an error in HA20X2K.SYS. It's a Creative file (I have an X-FI XtremeGamer) and I'm pretty sure it has something to do with OpenAL. I have the hardware OpenAL checkbox checked in the Audio section. Anyone else seen one of these?

  • #2
    Yes, I'm getting this frequently. Creative X-Fi XtremeGamer also.

    I'm going to try disabling the hardware OpenAL option - have you had any luck?

    Comment


    • #3
      Yes, disabling that option seems to eliminate the crashing.

      TBH, I'm not sure if this is an Epic problem or a Creative problem. I'm hoping it's Epic, since there will be an actual chance of a fix. Creative is a lost cause.

      Comment


      • #4
        oh good im not the only one then. ive done the same (only just mind)

        Comment


        • #5
          What OS are you running? XP/Vista? 32/64Bit? Did you install the latest drivers from our website? How much RAM?

          If possible can you try this:

          Go to My Computer->Properties->Advanced->Startup and Recovery->Settings
          Under System Failure, untick Automatically Restart
          Under Write Debugging Information, select Small Memory dump (64kB) and reboot

          Now run the game again with Hardware OpenAL enabled, and when it blue screens reboot the machine and send me the latest \windows\minidump\mini*.dmp file..

          That will allow us to see what caused the crash and hopefully take care of it.

          Comment


          • #6
            That's awesome!

            Comment


            • #7
              Any news on this? I'm having the same damn problem...

              Comment


              • #8
                FIXING ha20x2k.sys

                Yes, I was also having this problem and found it to be a compabitility issuse with window drivers (AKA service pack 3, direct x, ect.) and creative labs drivers. I tried uninstalling, reinstalling, changing pci slots, and nothing worked. The only way I thought of fixing this is issue was to do it manually through SAFE MODE in windows.

                Before doing this be sure you have downloaded and saved the latest drivers on to your hard drive.
                And you have the installtion CD.
                DO NOT INSTALL THE DRIVERS YET.

                Here is how I fixed the issue:

                Turn on your PC and log into SAFE MODE (press f8 before you hit the windows logo)

                It will bypass the BSOD (blue screen of death).

                Search the file: ha20x2k.sys
                or
                Go to C:\WINNT\system32\drivers
                Delete ha20x2k.sys

                Install from your CD - (may freeze up on the drivers part of the installation, ignore and reboot.)
                Restart normally

                It will load up and detect your sound card.
                (Possible error: Skip this if this doesn't happen to you.)
                Sometimes it may go back to BSOD because Windows likes to install new found hardware. If this happens, turn off your computer and remove your sound card from the pci slot. Restart normally. Check the C:\WINNT\system32\drivers folder and if ha20x2k.sys is there, delete again. Turn off, put the card back in the slot. Start in SAFE MODE and check to see that the sound card is disabled under device manager. It's disabled or if it's not listed, reboot normally.

                No BSOD! Yay!
                Now go to Windows Update and custom install the Creative Labs WDM driver. This will overwrite the ha20x2k.sys file with a Windows compatible file.

                Restart, you will hear a shutdown sound as you shutdown.
                No more BSOD and
                You can now install the lastest drivers if you like

                Comment


                • #9
                  Originally posted by Carlo@Creative View Post
                  What OS are you running? XP/Vista? 32/64Bit? Did you install the latest drivers from our website? How much RAM?

                  If possible can you try this:

                  Go to My Computer->Properties->Advanced->Startup and Recovery->Settings
                  Under System Failure, untick Automatically Restart
                  Under Write Debugging Information, select Small Memory dump (64kB) and reboot

                  Now run the game again with Hardware OpenAL enabled, and when it blue screens reboot the machine and send me the latest \windows\minidump\mini*.dmp file..

                  That will allow us to see what caused the crash and hopefully take care of it.
                  Have you found a fix for this yet? I also have a X-gamer card, Vista 64, i7 920, ...

                  Comment


                  • #10
                    any updates on this yet... still same crap on Vista 64

                    Comment


                    • #11
                      Still an ongoing problem, any fixes yet?

                      Comment


                      • #12
                        I used to get that with my creative x-fi elite pro card. Turns out the power connector was loose. It can also be driver related. First check the seating of your card and ensure that it is connect to your psu if it has a power connector on it. If that all appears to be correct try using the PAX drivers.

                        Hope that helps. If you can't fix it message me on xfire or steam and we can try some different openal versions and/or ini editing.

                        Comment


                        • #13
                          Thanks Random, we'll work on it later when I get home today

                          I thought I was having DRAM issues and bought 3 2x2 CL7 1.35v Eco kits... hope it's just the drivers. I tried turning off OpenAL last night and it didn't crash but it comes so intermittenly it's hard to say. Before it started crashing recently lately, it's been well over a few months since the last time it crashed so *shrugs shoulders* who knows.

                          Comment


                          • #14
                            I have the Xtreme Gamer card. I had to switch to it from a PCIe card due to some airflow config reasons. I've downloaded the PAX drivers. Have you ever used them before?

                            Comment


                            • #15
                              Still getting crashes. Have you tried the PAX drivers? I'm affraid to checkem out

                              Comment

                              Working...
                              X