Announcement

Collapse
No announcement yet.

UT3 Server doesn't work

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    UT3 Server doesn't work

    Hi everyone,

    I'm trying to reinstall my UT3 Server but I can't see it in LAN or Internet Game and I don't understand why.

    My configuration :
    - I have installed a Debian Chroot on my NAS Synology DS1513+ who is the system I used for installing UT Server.
    - I have already an UT2004 server who works perfectly (port used : 7777)
    - I want to use the port 7779 for UT3.

    For the installation, I used :
    - UT3-linux-server-12172007.bin (server files)
    - UT3-linux-server-04292009.bin (patch 5)
    - UT3TitanPack.exe (Titan Pack)
    - UT3WebAdmin-1.17_2009-09-13.zip (WebAdmin)
    - UT3Linux2.1_EpicMS.zip (patch 2.1 Epic)

    My command :

    Code:
    ./ut3 Server DM-HeatRay?Game=UTGame.UTDeatmatch?bShouldAdvertise=True?bIsDedicated=True?log=DedicatedServer.log?Adminpassword=mypassword -Login=mylogin -Password=mypassword -Port=7779 -QueryPort=6600 -nohomedir -unattended
    My Result :

    Code:
    Init: Version: 3808
    Init: Epic Internal: 0
    Init: Compiled: Apr 22 2009 04:27:51
    Init: Command line: Server DM-HeatRay?Game=UTGame.UTDeatmatch?bShouldAdvertise=True?bIsDedicated=True?log=DedicatedServer.log?Adminpassword=xxx -Login=xxx -Password=xxx -Port=7779 -QueryPort=6600 -nohomedir -unattended
    Init: Base directory: /home/UT3/Binaries/
    Init: Character set: Unicode
    Log: GConfig::LoadFile has loaded file:  ../UTGame/Config/UTEditor.ini
    Log: GConfig::LoadFile has loaded file:  ../UTGame/Config/UTEditorUserSettings.ini
    Log: GConfig::LoadFile has loaded file:  ../UTGame/Config/UTEngine.ini
    Log: GConfig::LoadFile has loaded file:  ../UTGame/Config/UTGame.ini
    Log: GConfig::LoadFile has loaded file:  ../UTGame/Config/UTInput.ini
    Log: GConfig::LoadFile has loaded file:  ../UTGame/Config/UTUI.ini
    Log: GConfig::LoadFile has loaded file:  ../UTGame/Config/UTMapLists.ini
    Log: GConfig::LoadFile has loaded file:  ../UTGame/Config/UTVote.ini
    Init: File handle limit is soft=(1024), hard=(4096).
    Init: Computer: unknown
    Init: User: root
    Init: BSD Sockets initialized
    Init: Presizing for 83221 objects not considered by GC, pre-allocating 0 bytes.
    Init: Object subsystem initialized
    Init: Startup System Settings:
    Init: System Settings:
    Init:   StaticDecals=true
    Init:   DynamicDecals=true
    Init:   DynamicLights=true
    Init:   DynamicShadows=true
    Init:   LightEnvironmentShadows=true
    Init:   CompositeDynamicLights=false
    Init:   DirectionalLightmaps=true
    Init:   MotionBlur=false
    Init:   DepthOfField=true
    Init:   Bloom=true
    Init:   QualityBloom=true
    Init:   Distortion=true
    Init:   DropParticleDistortion=false
    Init:   SpeedTreeLeaves=true
    Init:   SpeedTreeFronds=true
    Init:   OnlyStreamInTextures=false
    Init:   LensFlares=true
    Init:   FogVolumes=true
    Init:   FloatingPointRenderTargets=true
    Init:   Trilinear=false
    Init:   OneFrameThreadLag=true
    Init:   UseVsync=false
    Init:   UpscaleScreenPercentage=true
    Init:   Fullscreen=false
    Init:   AllowD3D10=true
    Init:   EnableHighPolyChars=false
    Init:   SkeletalMeshLODBias=0
    Init:   ParticleLODBias=0
    Init:   DetailMode=2
    Init:   ShadowFilterQualityBias=0
    Init:   MaxAnisotropy=4
    Init:   MaxMultisamples=1
    Init:   MinShadowResolution=32
    Init:   MaxShadowResolution=512
    Init:   ResX=800
    Init:   ResY=600
    Init:   ScreenPercentage=100.000
    Init:   SceneCaptureStreamingMultiplier=1.000
    Init:   FoliageDrawRadiusMultiplier=1.000
    Init:   ShadowTexelsPerPixel=2.000
    Log:    TEXTUREGROUP_World: (MinLODSize=   1,MaxLODSize=4096,LODBias=0)
    Log:    TEXTUREGROUP_WorldNormalMap: (MinLODSize=   1,MaxLODSize=4096,LODBias=0)
    Log:    TEXTUREGROUP_WorldSpecular: (MinLODSize=   1,MaxLODSize=4096,LODBias=0)
    Log:    TEXTUREGROUP_Character: (MinLODSize=   1,MaxLODSize=4096,LODBias=0)
    Log:    TEXTUREGROUP_CharacterNormalMap: (MinLODSize=   1,MaxLODSize=4096,LODBias=0)
    Log:    TEXTUREGROUP_CharacterSpecular: (MinLODSize=   1,MaxLODSize=4096,LODBias=0)
    Log:    TEXTUREGROUP_Weapon: (MinLODSize=   1,MaxLODSize=4096,LODBias=0)
    Log:    TEXTUREGROUP_WeaponNormalMap: (MinLODSize=   1,MaxLODSize=4096,LODBias=0)
    Log:    TEXTUREGROUP_WeaponSpecular: (MinLODSize=   1,MaxLODSize=4096,LODBias=0)
    Log:    TEXTUREGROUP_Vehicle: (MinLODSize=   1,MaxLODSize=4096,LODBias=0)
    Log:    TEXTUREGROUP_VehicleNormalMap: (MinLODSize=   1,MaxLODSize=4096,LODBias=0)
    Log:    TEXTUREGROUP_VehicleSpecular: (MinLODSize=   1,MaxLODSize=4096,LODBias=0)
    Log:    TEXTUREGROUP_Effects: (MinLODSize=   1,MaxLODSize=4096,LODBias=0)
    Log:    TEXTUREGROUP_Skybox: (MinLODSize=   1,MaxLODSize=4096,LODBias=0)
    Log:    TEXTUREGROUP_UI: (MinLODSize=   1,MaxLODSize=4096,LODBias=0)
    Log:    TEXTUREGROUP_LightAndShadowMap: (MinLODSize=   1,MaxLODSize=4096,LODBias=0)
    Log:    TEXTUREGROUP_RenderTarget: (MinLODSize=   1,MaxLODSize=4096,LODBias=0)
    Init: Friendly System Settings:
    Init:   TextureDetail=Level5
    Init:   WorldDetail=Level5
    Init:   bUseVSync=0
    Init:   bUseMSAA=0
    Init:   ScreenPercentage=100
    Init:   UpscaleScreenPercentage=1
    Init:   ResX= 800
    Init:   ResY= 600
    Init:   Fullscreen=0
    Init:   AllowMotionBlur=0
    Log: Initializing FaceFX...
    Log: FaceFX initialized:
    Log:     version  1.710000
    Log:     licensee Unreal Engine 3 Licensee
    Log:     project  Unreal Engine 3 Project
    Log: GConfig::Find has loaded file:  ..\Engine\Localization/int/Core.int
    Log: GConfig::Find has loaded file:  ..\Engine\Localization/int/Engine.int
    Log: Loaded shader cache RefShaderCache-PC-D3D-SM3.CacheObject: 27892 shaders(2 legacy, 0 redundant), 2950 materials
    Log: GConfig::Find has loaded file:  ..\Engine\Localization/int/UnrealScriptTest.int
    Log: GConfig::Find has loaded file:  ..\UTGame\Localization/int/UTGame.int
    Log: GConfig::LoadFile has loaded file:  ../UTGame/Config/UTWeapon.ini
    Log: GConfig::LoadFile has loaded file:  ../UTGame/Config/UTCustomChar.ini
    Log: GConfig::LoadFile associated file:  ../UTGame/Config/UTMap.ini
    Log: GConfig::LoadFile has loaded file:  ../UTGame/Config/UTWeb.ini
    Log: GConfig::Find has loaded file:  ..\Engine\Localization/int/OnlineSubsystemGameSpy.int
    Log: GConfig::Find has loaded file:  ..\UTGame\Localization/int/UTGameContent.int
    Init: Version: 3808
    Init: Epic Internal: 0
    Init: Compiled: Apr 22 2009 04:34:47
    Init: Command line:  DM-HeatRay?Game=UTGame.UTDeatmatch?bShouldAdvertise=True?bIsDedicated=True?log=DedicatedServer.log?Adminpassword=xxx -Login=xxx -Password=xxx -Port=7779 -QueryPort=6600 -nohomedir -unattended
    Init: Base directory: /home/UT3/Binaries/
    Init: Character set: Unicode
    Log: Executing Class Engine.ServerCommandlet
    Log: Initializing Game Engine...
    Init: UEngine initialized
    Log: Looking for DLC...
    Log: Object size..............: 60
    Log: Actor size...............: 436
    Log: ActorComponent size......: 88
    Log: PrimitiveComponent size..: 448
    Log: GConfig::Find has loaded file:  ../UTGame/Config/UTUIDataStore_Registry_0.ini
    Log: GConfig::Find has loaded file:  ../UTGame/Config/UTWebAdmin.ini
    Log: GConfig::Find has loaded file:  ../UTGame/Config/DLC_MapInfo.ini
    Log: GConfig::Find has loaded file:  ../UTGame/Config/gamespy.ini
    Log: GConfig::Find has loaded file:  ../UTGame/Config/TitanPack.ini
    Log: Performing DNS lookup for stunserver.org
    Log: Browse: DM-HeatRay?Name=Player?team=255?Game=UTGame.UTDeatmatch?bShouldAdvertise=True?bIsDedicated=True?log=DedicatedServer.log?Adminpassword=xxx 
    Log: Award progress has now been fully reenabled!
    Log: LoadMap: DM-HeatRay?Name=Player?team=255?Game=UTGame.UTDeatmatch?bShouldAdvertise=True?bIsDedicated=True?log=DedicatedServer.log?Adminpassword=xxx
    Log: Game class is 'UTDeathmatch'
    Init: Sockets: Socket queue 262142 / 262142
    Init: Sockets: I am NAS (169.254.46.111:0)
    Log: NetMode is now 1
    Log: Primary PhysX scene will be in software.
    Log: Creating Primary PhysX Scene.
    Log: Novodex Terrain Creation (Terrain_1): 14.130000 ms
    Log: Bringing World DM-HeatRay.TheWorld up for play (30) at 2014.10.15-10.25.04
    ScriptLog: Current map is not the maplist's active map, updating maplist
    UTVoting: Map voting is enabled
    ScriptLog: Web Server Created http://169.254.46.111:2007 Port: 2007 MaxCon 18 ExpirationSecs 86400 Enabled True
    Log: GConfig::Find has loaded file:  ..\UTGame\Localization/int/WebAdmin.int
    WebAdmin: Starting UT3 WebAdmin v1.17 - 2009-09-13 20:13:18 +0000
    WebAdmin: Creating IWebAdminAuth instance from: BasicWebAdminAuth
    WebAdmin: Creating ISessionHandler instance from: SessionHandler
    WebAdmin: Updating news...
    Log: Bringing up level for play took: 1.564361
    Log: ########### Finished loading level: 4.537790 seconds
    Init: Game engine initialized
    Log: Initializing Game Engine Completed
    Log: FHttpDownload resolved gamecontent.unrealtournament3.com (199.255.40.77)
    Log: FHttpDownload resolved gamecontent.unrealtournament3.com (199.255.40.77)
    Log: FSTUNClient resolved stunserver.org (132.177.123.6)
    Log: FSTUNClient starting test 1...
    ScriptLog: Cut down URL ?Name=Player?team=255?Game=UTGame.UTDeatmatch?bShouldAdvertise=True?bIsDedicated=True?log=DedicatedServer.log?Adminpassword=oit3ff7m
    ScriptLog: Cut down URL ?Name=Player?team=255?Game=UTGame.UTDeatmatch?bShouldAdvertise=True?bIsDedicated=True?log=DedicatedServer.log?Adminpassword=oit3ff7m
    ScriptLog: Cut down URL ?Name=Player?team=255?Game=UTGame.UTDeatmatch?bShouldAdvertise=True?bIsDedicated=True?log=DedicatedServer.log?Adminpassword=oit3ff7m
    Log: Performing DNS lookup for stun.xten.com
    Log: FSTUNClient resolved stun.xten.com (216.93.246.16)
    Log: FSTUNClient starting test 1...
    Log: FSTUNClient test timeout, NAT is strict.
    Result :
    - WebAdmin is OK.
    - No game found on LAN
    - No game found on Internet (even if I give my IP)

    I supposed my problem is here : Log: FSTUNClient test timeout, NAT is strict but i don't know how to resolve this.

    I have installed a Stun Server on my Debian with this tuto :
    http://mususumbra.blogspot.fr/2007/1...-solution.html

    Now I have :

    Code:
    Log: FSTUNClient resolved 192.168.0.50 (192.168.0.50)
    Log: FSTUNClient starting test 1...
    Log: FSTUNClient starting test 2...
    Log: FSTUNClient test complete, NAT is moderate.
    But it doesn't work.

    I have tried to install a new Debian on another PC with only UT3 Server on.
    I have configured Stun to my previous server, result :

    Code:
    Log: FSTUNClient resolved 192.168.0.50 (192.168.0.50)
    Log: FSTUNClient starting test 1...
    Log: FSTUNClient test complete, NAT is open.
    Despite this, it still doesn't work, even LAN.

    I don't really understand why that doesn't work, while my UT2004 works perfectly.

    If anybody can help me please...
    (Sorry for my english, I'm french).

    #2
    It's probably just firewall/router portforwarding. I think UT2004 has UPnP and UT3 does not, so you would have to manually open a range of ports (and of cource the specific ones).

    Comment


      #3
      Hi RattleSN4K3.

      Unfortunately, it doesn't a port issue. I have test to open all the ports (TCP and UDP), same problem. I have tried DMZ too, idem.

      Comment


        #4
        Are you running UT2004 and UT3 side by side when you're trying to get it working?
        Are you able to connect to the server locally (or through ip)?

        Comment


          #5
          Like I said :

          Result :
          - WebAdmin is OK.
          - No game found on LAN
          - No game found on Internet (even if I give my IP)

          Comment


            #6
            You did say what I was asking

            Does it work to use the open command (host should be replaced by the proper name; IP should be replaced with the proper IP inside the same network):
            Code:
            open SYNOLOGY_HOST:7779
            Code:
            open 192.168.1.2:7779

            Do you run UT2004 and then run UT3 simultaneously?

            Also not sure if the new master server queries different ports thann the default one 6500.

            Comment


              #7
              Are you sure for the "open" command ? For me, this command is to open a file on linux.

              Do you run UT2004 and then run UT3 simultaneously?
              My tests :
              UT2004 alone : ok
              UT2004 + UT3 : UT2004 ok, UT3 ko
              UT3 without UT2004 : ko
              UT3 on another server (new install of Debian with only UT3) : ko
              Ports 6500 for UT2004 and 6600 for UT3 : ko for UT3
              Open all ports on firewall : ko
              DMZ to my host : ko

              Comment


                #8
                Open is a console command which can be used ingame in UT3. Open the console (F10) and enter that command along with the IP/HOST you want to connect to.

                Comment


                  #9
                  Ah yes, I thought you were talking about linux command.

                  I've tried on game, and it works with open 192.168.0.50:7779 !
                  It's weird because the game didn't see the party on network.

                  It remains for me to test from the Internet now...

                  Thanks a lot anyway. (:

                  Comment


                    #10
                    I would guess that the client game is only querying on 7777 (the default port) and not others. So it will only get a response from the server which is running on 7777.

                    Comment


                      #11
                      I don't think the problem is about the port because I've tried the port 7777 while UT2004 was stopped, and it doesn't work anymore.
                      Similarly, when I installed UT3 on another server, I used port 7777 and that's not working too.

                      Comment


                        #12
                        http://unrealbyfusilade.wordpress.co...llation-guide/
                        see if any of that helps

                        Comment


                          #13
                          very good, thanks you

                          Comment

                          Working...
                          X