No announcement yet.

Dedicated UT3 Server Downloading Mutator Issue...

  • Filter
  • Time
  • Show
Clear All
new posts

    Dedicated UT3 Server Downloading Mutator Issue...

    Hey guys I have been hosting a dedicated Unreal Tournament 3 server and have a minor issue. I know Zunnie had asked what I fixed and thats fine, I apologize for deleting my thread and not responding to others who may have been having the same issue... my bad!

    Ok... first things first. I configured my server without any hassle, installed WebAdmin and tweaked everything else from that point forward. The issue I was having was in the "UTEngine.ini" file. What was going on in the beginning was that I uploaded the custom maps such as Coagulation, Timberland and Valhalla. If someone would click on my server the download speed was horrific, maybe 10kb per second. I did a ton of research and figured out I had to redirect the code in the UTEngine.ini file to say this...

    AllowDownloads=True <----- Set this to False to test your redirect below

    RedirectToURL=http://www.MYURLHERE.COM/UT3/ <----- alt server where the custom maps were uploaded

    Once I setup the redirect you could now click on my server and download any custom map I had available with in seconds. Now that I got that all setup the real issue I was having was with the Mutators. Since the custom maps were on an alt server for people to down faster I was thinking you had to do the same thing with mutators, right? Made sense to me, however... that wasn't so!

    I was constantly getting errors when trying to download MK3rdPersonMutator. I extracted the files and put them on my alt server in various ways. Such as no folders and just dumped the files in there along side the custom maps... didn't work. I used the same folder structure on my alt server... didn't work. I was doing a bunch of reseach and getting absolutely no where. So I was looking at the UTEngine.ini code and said hum... if "AllowDownloads=False" it makes sense so the redirect works, right? So I left it as False. What I realized was if I set it back to "True" the redirect still works and since the Mutator files are so small as it downloads off the dedicated server at 10kb its not a big deal because the Mutator is small in size.

    Quick Recap... I set AllowDownloads back to "True" and I found out the redirect still works which I was not aware of... I get to have the custom maps download at lightning speed while the dedicated server takes care of the small Mutator files. I guess it works out, I just wish I could have all the downloads in one place for my own reasons but this way works.

    Hope that re-explains what I deleted so for those of you who may have run into this problem can now understand. Thank you for your time!

    Attached Files

    Would be quite useful if you let others know WHAT fixed it


      Originally posted by zunnie View Post
      Would be quite useful if you let others know WHAT fixed it
      Hey zunnie... My apologies, I re-wrote my issue above and what I did to fix it. Hope that helps


        omg that actually makes sense! must go try this on my server.