Announcement

Collapse

The Infinity Blade Forums Have Moved

We've launched brand new Infinity Blade forums with improved features and revamped layout. We've also included a complete archive of the previous posts. Come check out the new Infinity Blade forums.
See more
See less

How to make custom content download faster?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • How to make custom content download faster?

    When I let the game download custom content, it takes bloody ages. If I manually download it via HTTP, it downloads literally 100 times faster.

    Is there a way to speed it up in game? I looked into redirection but there is a huge lack of documentation on how it should be done. The only thing I found is adding this to utengine.ini:

    Code:
    [IpDrv.HTTPDownload]
     RedirectToURL=http://ut3.uovalor.com
     UseCompression=True

    But what is the http folder structure suppose to be like? This is what I have, is this correct? http://ut3.uovalor.com Or do the files all have to be in the same folder?

  • #2
    be thankful for the technology you have available to you.

    - show some patience; - is it really so bad to spend a few minutes downloading?

    - the fact that people cant be bothered to wait this time is ridiculous

    - if you are a player- tough.

    - if you are a server provider you can compress your files alittle bit more.
    - using stuff like this

    http://www.gamefront.com/files/97510...and_Decompress
    http://www.fileplanet.com/187733/180...mpression-tool

    Comment


    • #3
      So there's no way to make it faster through the game? Just seems odd that it's so slow. It takes about a minute just to get 0.1%. I have 100mbps of bandwidth up/down to the server. If I download it manually through http then it's fine, but through the game it's very slow.

      Comment


      • #4
        The path to your redirect needs to point directly to any files. Meaning, you have to put all files into the root folder of your selected path => no subfolders.
        Every file should be located at http://ut3.uovalor.com/

        http://ut3.uovalor.com/CTF-GRD-Arsenal[UGM].ut3
        http://ut3.uovalor.com/CTF-GRD-Biohazard[UGM].ut3
        etc.

        In this case, you're sharing the raw files - u, upk and ut3 files. So the variable "UseCompression" needs to be false. By compressing them with the methods TKBS mentioned, you have to set this to true. All the maps, package and script will have a new extension UZ3. Remember: In any case, no subfolder.

        It looks like your sharing the files from the server. This can cause any lags on the client machines which are playing on that server. Files should be located on a different machine.

        PS: Try to search "ut3 setup redirect" on search engines to get more information.

        Comment


        • #5
          I have 100mbps to the server so it should be fine as far as bandwidth goes, cpu should be able to handle it too once I shut down my Ultima Online server (currently running in a VM on that box). Guess I will create a separate folder and just make sure to copy the files to it as well as to the server's proper path, or create symlinks. I'll play around with that and see how things go.

          Comment


          • #6
            I made a separate redirect folder under a different DNS hostname and put the files in the folder (testing with only one map right now) and it's still not working, anything else I need to do?

            This is the setting:

            Code:
            [IpDrv.HTTPDownload]
            RedirectToURL=http://redirect.ut3.uovalor.com/data/
            UseCompression=False
            I turned Allowdownloads off so I can rule out that it's downloading through redirection. If I turn it on it downloads but at the super slow rate.

            Also I noticed lot of other settings that may help speed things up:

            Code:
            [IpDrv.TcpNetDriver]
            AllowDownloads=False
            ConnectionTimeout=30.0
            InitialConnectTimeout=200.0
            AckTimeout=1.0
            KeepAliveTime=0.2
            MaxClientRate=15000
            MaxInternetClientRate=10000
            RelevantTimeout=5.0
            SpawnPrioritySeconds=1.0
            ServerTravelPause=4.0
            NetServerMaxTickRate=30
            LanServerMaxTickRate=35
            IdleServerTickRate=30
            DownloadManagers=IpDrv.HTTPDownload
            DownloadManagers=Engine.ChannelDownload
            NetConnectionClassName=IpDrv.TcpipConnection

            Is there any of those settings I can change?

            Oh another thing I noticed is the server log says this when a map loads:


            Code:
            Log: FHttpDownload resolved gamecontent.unrealtournament3.com (199.255.40.77)
            Log: FHttpDownload resolved gamecontent.unrealtournament3.com (199.255.40.77)
            Could it be that it's trying to redirect to that hostname? Or is that for something else?

            Also, I don't see anything in my web server logs, so it does not look like it's even trying. The problem is elsewhere. (perhaps what I just mentioned above)

            Comment


            • #7
              Hmm. I created a basic redirect on my PC and connected with another PC (LAN) to this server.
              I used the retail version of UT3 running as a dedicated server and the only thing i had to do is, adding the "[IpDrv.HTTPDownload]" block and set the AllowDownloads property to false. I used an Apache server for the redirect (basic XAMPP installation with allowing local IPs).
              I tried 3 different things and all of these were working as expected.

              1. No redirect. Allowdownloads to true. Client could donwnload the file.
              2. No redirect. Allowdownloads to false. Client aborted loading the map due to download failure.
              3. Set redirect. Allowdownloads to false. Client downloaded the file. The access log of apache has a new entry of that client.

              There is no additional server log in UT3 for having a redirect configured - on my side.

              Try to delete all config files and create the basic setup in order to test if it is running well with a minimal configured system.

              Comment


              • #8
                All config files? Wont that break everything? Everything IS stock, other than a few added maps, which are only addition of new files.

                Now what confuses me is that some of the files are in the server's folder, while some are in the home directory under a hidden file. Is this normal? The file I have to edit is in that home folder, and is not in the server's folder. The server is running under that user though, and editing the file does seem to have some kind of impact (the downloads=false/true option).

                Comment


                • #9
                  Oh and this is my startup string, could a flag in there have anything to do with why it's not working?

                  Code:
                  #!/bin/sh
                  
                  {
                  date
                  echo
                  ./ut3 Server VCTF-Necropolis?Game=UTGameContent.UTVehicleCTFGame_Content?GameMode=2?Numplay=4?MaxPlayers=64?NumPublicConnections=24?NumPrivateConnections=2?MinNetPlayers=1?bIsDedicated=true?bUsesStats=true?ForceRespawn=0?bShouldAdvertise=false?PureServer=1?bIsLanMatch=false?bAllowJoinInProgress=true?AdminName=********?AdminPassword=******** -Login=******** -Password=******** -Log=myserver.log -multihome=96.45.178.186 -unattended
                  } > server.log 2>&1

                  Comment


                  • #10
                    Ok I give up on redirection, everything I try is not working. I reverted all the stuff I did from file backup.

                    Is there not any settings I can change to just make the normal way faster? I see a bunch of settings under [IpDrv.TcpNetDriver] that seem to have to do with download rate. I just don't know what the units are (bytes, KB? MB?) and what each one does. There's tick rate etc...

                    Would increasing any of these help?

                    Is there a way to find out what version server I'm running? Maybe I need to apply a patch or something?

                    Comment


                    • #11
                      When you are downloading, does it move like 0.1, 0.2 and then 0.3 or is it jumping like 0.8, 1.6 and then 4.5?

                      Comment


                      • #12
                        The first lines of the generated log file of UT3 (under "UTGame\Logs") should name you the build version.

                        There are some settings to tweak in order to increase the download/upload speed. But i don't know these properties atm.

                        It looks like your adjusments are not recognized. If you set the downloads options to false, and you have a custom map loaded which the client does not have, the client should not able to join that server. Check that.
                        Furthermore, i looks like your system is using a profile folder. It's better to have files at one place. You can add "-nohomedir" into your command line which forces UT3 to only take the files in that installation directory.
                        If this is not working, the file structure is not the right one.

                        Redirected servers for downloadable files is the best method to allow custom downloads.

                        Comment


                        • #13
                          It downloads at 0.1, 0.2 etc... I did not really leave it further as it's more than a minute per iteration. If I leave it overnight it does eventually download.

                          If I set AllowDownloads to false then I get an error that the file is not found. Yet if I look at my apache logs, I see no attempt to even look for the file.


                          Here is a server log, maybe it will provide something that can help point at why it's not working:

                          Code:
                          [ut3user@shared2 Binaries]$ ./startserver.sh &
                          [1] 8241
                          [ut3user@shared2 Binaries]$ tail -f server.log
                          Fri May 25 00:05:37 EDT 2012
                          
                          Init: Version: 3808
                          Init: Epic Internal: 0
                          Init: Compiled: Apr 22 2009 04:27:51
                          Init: Command line: Server VCTF-Kargomod?Game=UTGameContent.UTVehicleCTFGame_Content?GameMode=2?Numplay=4?MaxPlayers=64?NumPublicConnections=24?NumPrivateConnections=2?MinNetPlayers=1?bIsDedicated=true?bUsesStats=true?ForceRespawn=0?bShouldAdvertise=false?PureServer=1?bIsLanMatch=false?bAllowJoinInProgress=true?AdminName=admin?AdminPassword=******** -Login=******** -Password=******** -Log=myserver.log -multihome=96.45.178.186 -unattended
                          Init: Base directory: /home/ut3user/ut3server/ut3-dedicated/Binaries/
                          Init: Character set: Unicode
                          Log: GConfig::LoadFile has loaded file:  ../UTGame/Config/UTEditor.ini
                          Log: GConfig::LoadFile has loaded file:  ../UTGame/Config/UTEditorUserSettings.ini
                          Log: GConfig::LoadFile has loaded file:  ../UTGame/Config/UTEngine.ini
                          Log: GConfig::LoadFile has loaded file:  ../UTGame/Config/UTGame.ini
                          Log: GConfig::LoadFile has loaded file:  ../UTGame/Config/UTInput.ini
                          Log: GConfig::LoadFile has loaded file:  ../UTGame/Config/UTUI.ini
                          Log: GConfig::LoadFile has loaded file:  ../UTGame/Config/UTMapLists.ini
                          Log: GConfig::LoadFile has loaded file:  ../UTGame/Config/UTVote.ini
                          Init: File handle limit is soft=(1024), hard=(1024).
                          Init: Computer: unknown
                          Init: User: ut3user
                          Init: BSD Sockets initialized
                          Init: Presizing for 83221 objects not considered by GC, pre-allocating 0 bytes.
                          Init: Object subsystem initialized
                          Init: Startup System Settings:
                          Init: System Settings:
                          Init:   StaticDecals=true
                          Init:   DynamicDecals=true
                          Init:   DynamicLights=true
                          Init:   DynamicShadows=true
                          Init:   LightEnvironmentShadows=true
                          Init:   CompositeDynamicLights=false
                          Init:   DirectionalLightmaps=true
                          Init:   MotionBlur=false
                          Init:   DepthOfField=true
                          Init:   Bloom=true
                          Init:   QualityBloom=true
                          Init:   Distortion=true
                          Init:   DropParticleDistortion=false
                          Init:   SpeedTreeLeaves=true
                          Init:   SpeedTreeFronds=true
                          Init:   OnlyStreamInTextures=false
                          Init:   LensFlares=true
                          Init:   FogVolumes=true
                          Init:   FloatingPointRenderTargets=true
                          Init:   Trilinear=false
                          Init:   OneFrameThreadLag=true
                          Init:   UseVsync=false
                          Init:   UpscaleScreenPercentage=true
                          Init:   Fullscreen=false
                          Init:   AllowD3D10=true
                          Init:   EnableHighPolyChars=false
                          Init:   SkeletalMeshLODBias=0
                          Init:   ParticleLODBias=0
                          Init:   DetailMode=2
                          Init:   ShadowFilterQualityBias=0
                          Init:   MaxAnisotropy=4
                          Init:   MaxMultisamples=1
                          Init:   MinShadowResolution=32
                          Init:   MaxShadowResolution=512
                          Init:   ResX=800
                          Init:   ResY=600
                          Init:   ScreenPercentage=100.000
                          Init:   SceneCaptureStreamingMultiplier=1.000
                          Init:   FoliageDrawRadiusMultiplier=1.000
                          Init:   ShadowTexelsPerPixel=2.000
                          Log:    TEXTUREGROUP_World: (MinLODSize=   1,MaxLODSize=4096,LODBias=0)
                          Log:    TEXTUREGROUP_WorldNormalMap: (MinLODSize=   1,MaxLODSize=4096,LODBias=0)
                          Log:    TEXTUREGROUP_WorldSpecular: (MinLODSize=   1,MaxLODSize=4096,LODBias=0)
                          Log:    TEXTUREGROUP_Character: (MinLODSize=   1,MaxLODSize=4096,LODBias=0)
                          Log:    TEXTUREGROUP_CharacterNormalMap: (MinLODSize=   1,MaxLODSize=4096,LODBias=0)
                          Log:    TEXTUREGROUP_CharacterSpecular: (MinLODSize=   1,MaxLODSize=4096,LODBias=0)
                          Log:    TEXTUREGROUP_Weapon: (MinLODSize=   1,MaxLODSize=4096,LODBias=0)
                          Log:    TEXTUREGROUP_WeaponNormalMap: (MinLODSize=   1,MaxLODSize=4096,LODBias=0)
                          Log:    TEXTUREGROUP_WeaponSpecular: (MinLODSize=   1,MaxLODSize=4096,LODBias=0)
                          Log:    TEXTUREGROUP_Vehicle: (MinLODSize=   1,MaxLODSize=4096,LODBias=0)
                          Log:    TEXTUREGROUP_VehicleNormalMap: (MinLODSize=   1,MaxLODSize=4096,LODBias=0)
                          Log:    TEXTUREGROUP_VehicleSpecular: (MinLODSize=   1,MaxLODSize=4096,LODBias=0)
                          Log:    TEXTUREGROUP_Effects: (MinLODSize=   1,MaxLODSize=4096,LODBias=0)
                          Log:    TEXTUREGROUP_Skybox: (MinLODSize=   1,MaxLODSize=4096,LODBias=0)
                          Log:    TEXTUREGROUP_UI: (MinLODSize=   1,MaxLODSize=4096,LODBias=0)
                          Log:    TEXTUREGROUP_LightAndShadowMap: (MinLODSize=   1,MaxLODSize=4096,LODBias=0)
                          Log:    TEXTUREGROUP_RenderTarget: (MinLODSize=   1,MaxLODSize=4096,LODBias=0)
                          Init: Friendly System Settings:
                          Init:   TextureDetail=Level5
                          Init:   WorldDetail=Level5
                          Init:   bUseVSync=0
                          Init:   bUseMSAA=0
                          Init:   ScreenPercentage=100
                          Init:   UpscaleScreenPercentage=1
                          Init:   ResX= 800
                          Init:   ResY= 600
                          Init:   Fullscreen=0
                          Init:   AllowMotionBlur=0
                          Log: Initializing FaceFX...
                          Log: FaceFX initialized:
                          Log:     version  1.710000
                          Log:     licensee Unreal Engine 3 Licensee
                          Log:     project  Unreal Engine 3 Project
                          Log: GConfig::Find has loaded file:  ..\Engine\Localization/int/Core.int
                          Log: GConfig::Find has loaded file:  ..\Engine\Localization/int/Engine.int
                          Log: Loaded shader cache RefShaderCache-PC-D3D-SM3.CacheObject: 27892 shaders(2 legacy, 0 redundant), 2950 materials
                          Log: GConfig::Find has loaded file:  ..\Engine\Localization/int/UnrealScriptTest.int
                          Log: GConfig::Find has loaded file:  ..\UTGame\Localization/int/UTGame.int
                          Log: GConfig::LoadFile has loaded file:  ../UTGame/Config/UTWeapon.ini
                          Log: GConfig::LoadFile has loaded file:  ../UTGame/Config/UTCustomChar.ini
                          Log: GConfig::LoadFile associated file:  ../UTGame/Config/UTMap.ini
                          Log: GConfig::LoadFile has loaded file:  ../UTGame/Config/UTWeb.ini
                          Log: GConfig::Find has loaded file:  ..\Engine\Localization/int/OnlineSubsystemGameSpy.int
                          Log: GConfig::Find has loaded file:  ..\UTGame\Localization/int/UTGameContent.int
                          Init: Version: 3808
                          Init: Epic Internal: 0
                          Init: Compiled: Apr 22 2009 04:34:47
                          Init: Command line:  VCTF-Kargomod?Game=UTGameContent.UTVehicleCTFGame_Content?GameMode=2?Numplay=4?MaxPlayers=64?NumPublicConnections=24?NumPrivateConnections=2?MinNetPlayers=1?bIsDedicated=true?bUsesStats=true?ForceRespawn=0?bShouldAdvertise=false?PureServer=1?bIsLanMatch=false?bAllowJoinInProgress=true?AdminName=admin?AdminPassword=******** -Login=******** -Password=******** -Log=myserver.log -multihome=96.45.178.186 -unattended
                          Init: Base directory: /home/ut3user/ut3server/ut3-dedicated/Binaries/
                          Init: Character set: Unicode
                          Log: Executing Class Engine.ServerCommandlet
                          Log: Initializing Game Engine...
                          Init: UEngine initialized
                          Log: Looking for DLC...
                          Log: Object size..............: 60
                          Log: Actor size...............: 436
                          Log: ActorComponent size......: 88
                          Log: PrimitiveComponent size..: 448
                          Log: GConfig::Find has loaded file:  ../UTGame/Config/UTUIDataStore_Registry_0.ini
                          Log: GConfig::Find has loaded file:  ../UTGame/Config/UTWebAdmin.ini
                          Log: GConfig::Find has loaded file:  ../UTGame/Config/CTF-GRD-Diesel[UGM].ini
                          Log: GConfig::Find has loaded file:  ../UTGame/Config/WAR-UGL-CrossF1re.ini
                          Log: GConfig::Find has loaded file:  ../UTGame/Config/VCTF-Alexandria.ini
                          Log: GConfig::Find has loaded file:  ../UTGame/Config/CTF-GRD-OceanRelic[UGM].ini
                          Log: GConfig::Find has loaded file:  ../UTGame/Config/CTF-GRD-Sentinel[UGM].ini
                          Log: GConfig::Find has loaded file:  ../UTGame/Config/VCTF-CBP3-TheDig.ini
                          Log: GConfig::Find has loaded file:  ../UTGame/Config/CTF-GRD-Gateway[UGM].ini
                          Log: GConfig::Find has loaded file:  ../UTGame/Config/UThPCM_Script_2009A05M25D.ini
                          Log: GConfig::Find has loaded file:  ../UTGame/Config/CTF-GRD-Arsenal[UGM].ini
                          Log: GConfig::Find has loaded file:  ../UTGame/Config/WAR-UGL-DryIce-Beta3.ini
                          Log: GConfig::Find has loaded file:  ../UTGame/Config/CTF-GRD-Deimos[UGM].ini
                          Log: GConfig::Find has loaded file:  ../UTGame/Config/CTF-GRD-Turbine[UGM].ini
                          Log: GConfig::Find has loaded file:  ../UTGame/Config/DM-WhiteRealm.ini
                          Log: GConfig::Find has loaded file:  ../UTGame/Config/CTF-GRD-Biohazard[UGM].ini
                          Log: GConfig::Find has loaded file:  ../UTGame/Config/VCTF-RocketForst.ini
                          Log: GConfig::Find has loaded file:  ../UTGame/Config/CTF-GRD-EdenInc[UGM].ini
                          Log: GConfig::Find has loaded file:  ../UTGame/Config/CTF-GRD-Darkmatch[UGM].ini
                          Log: GConfig::Find has loaded file:  ../UTGame/Config/CTF-GRD-Fearless[UGM].ini
                          Log: GConfig::Find has loaded file:  ../UTGame/Config/CTF-GRD-RisingSun[UGM].ini
                          Log: GConfig::Find has loaded file:  ../UTGame/Config/CTF-GRD-ShangriLa[UGM].ini
                          Log: GConfig::Find has loaded file:  ../UTGame/Config/VCTF-Kargomod.ini
                          Log: GConfig::Find has loaded file:  ../UTGame/Config/WAR-UGL-Dawn-Beta2.ini
                          Log: GConfig::Find has loaded file:  ../UTGame/Config/VCTF-Valhalla_2010.ini
                          Log: GConfig::Find has loaded file:  ../UTGame/Config/CTF-GRD-KBarge[UGM].ini
                          Log: GConfig::Find has loaded file:  ../UTGame/Config/CTF-GRD-CarbonFire[UGM].ini
                          Log: GConfig::Find has loaded file:  ../UTGame/Config/CTF-GRD-Sanctuary[UGM].ini
                          Log: GConfig::Find has loaded file:  ../UTGame/Config/WAR-Sentinels.ini
                          Log: GConfig::Find has loaded file:  ../UTGame/Config/UTNyan.ini
                          Log: GConfig::Find has loaded file:  ../UTGame/Config/CTF-GRD-Defiance[UGM].ini
                          Log: GConfig::Find has loaded file:  ../UTGame/Config/VCTF-Sidewinder.ini
                          Log: GConfig::Find has loaded file:  ../UTGame/Config/CTF-GRD-Deck[UGM].ini
                          Log: GConfig::Find has loaded file:  ../UTGame/Config/CTF-GRD-Morbias[UGM].ini
                          Log: GConfig::Find has loaded file:  ../UTGame/Config/CTF-GRD-HeatRay[UGM].ini
                          Log: Performing DNS lookup for stunserver.org
                          Log: Browse: VCTF-Kargomod?Name=Player?team=255?Game=UTGameContent.UTVehicleCTFGame_Content?GameMode=2?Numplay=4?MaxPlayers=64?NumPublicConnections=24?NumPrivateConnections=2?MinNetPlayers=1?bIsDedicated=true?bUsesStats=true?ForceRespawn=0?bShouldAdvertise=false?PureServer=1?bIsLanMatch=false?bAllowJoinInProgress=true?AdminName=admin?AdminPassword=********
                          Log: Award progress has now been fully reenabled!
                          Log: LoadMap: VCTF-Kargomod?Name=Player?team=255?Game=UTGameContent.UTVehicleCTFGame_Content?GameMode=2?Numplay=4?MaxPlayers=64?NumPublicConnections=24?NumPrivateConnections=2?MinNetPlayers=1?bIsDedicated=true?bUsesStats=true?ForceRespawn=0?bShouldAdvertise=false?PureServer=1?bIsLanMatch=false?bAllowJoinInProgress=true?AdminName=admin?AdminPassword=********
                          Log: Game class is 'UTVehicleCTFGame_Content'
                          Init: Sockets: Socket queue 262142 / 262142
                          Log: NetMode is now 1
                          Log: Primary PhysX scene will be in software.
                          Log: Creating Primary PhysX Scene.
                          *** WARNING - PATHS MAY NOT BE VALID ***
                          Log: Bringing World VCTF-Kargomod.TheWorld up for play (30) at 2012.05.25-00.06.53
                          ScriptLog: MinNetPlayers:  1
                          ScriptLog: Current map is not the maplist's active map, updating maplist
                          UTVoting: Game voting is enabled
                          UTVoting: Map voting is enabled
                          UTVoting: Kick voting is enabled
                          ScriptLog: Web Server Created http://96.45.178.186:7780 Port: 7780 MaxCon 18 ExpirationSecs 86400 Enabled True
                          Log: GConfig::Find has loaded file:  ..\UTGame\Localization/int/WebAdmin.int
                          WebAdmin: Starting UT3 WebAdmin v1.17 - 2009-09-13 20:13:18 +0000
                          WebAdmin: Creating IWebAdminAuth instance from: BasicWebAdminAuth
                          WebAdmin: Creating ISessionHandler instance from: SessionHandler
                          WebAdmin: Updating news...
                          Log: Bringing up level for play took: 16.287404
                          Log: ########### Finished loading level: 25.820315 seconds
                          Init: Game engine initialized
                          Log: Initializing Game Engine Completed
                          NetComeGo: Open TheWorld  208.101.85.148:4152
                          Log: FHttpDownload resolved gamecontent.unrealtournament3.com (199.255.40.77)
                          Log: FHttpDownload resolved gamecontent.unrealtournament3.com (199.255.40.77)
                          Log: FSTUNClient resolved stunserver.org (132.177.123.13)
                          Log: FSTUNClient starting test 1...
                          WebAdmin: Creating team chat proxies
                          Log: FSTUNClient test complete, NAT is open.
                          ScriptLog: Cut down URL ?Name=Player?team=255?Game=UTGameContent.UTVehicleCTFGame_Content?Numplay=4?MaxPlayers=64?NumPublicConnections=24?NumPrivateConnections=2?MinNetPlayers=1?bIsDedicated=true?bUsesStats=true?ForceRespawn=0?bShouldAdvertise=false?PureServer=1?bIsLanMatch=false?bAllowJoinInProgress=true?AdminName=admin?AdminPassword=********
                          ScriptLog: Cut down URL ?Name=Player?team=255?Game=UTGameContent.UTVehicleCTFGame_Content?Numplay=4?MaxPlayers=64?NumPublicConnections=24?NumPrivateConnections=2?MinNetPlayers=1?bIsDedicated=true?bUsesStats=true?ForceRespawn=0?bShouldAdvertise=false?PureServer=1?bIsLanMatch=false?bAllowJoinInProgress=true?AdminName=admin?AdminPassword=********
                          ScriptLog: Cut down URL ?Name=Player?team=255?Game=UTGameContent.UTVehicleCTFGame_Content?Numplay=4?MaxPlayers=64?NumPublicConnections=24?NumPrivateConnections=2?MinNetPlayers=1?bIsDedicated=true?bUsesStats=true?ForceRespawn=0?bShouldAdvertise=false?PureServer=1?bIsLanMatch=false?bAllowJoinInProgress=true?AdminName=admin?AdminPassword=********
                          NetComeGo: Close TcpipConnection_0 208.101.85.148:4152
                          
                          [ut3user@shared2 Binaries]$


                          Most notable is the entries:

                          Log: FHttpDownload resolved gamecontent.unrealtournament3.com (199.255.40.77)
                          Log: FHttpDownload resolved gamecontent.unrealtournament3.com (199.255.40.77)


                          Shouldn't that be saying my url?

                          Also this one:

                          *** WARNING - PATHS MAY NOT BE VALID ***

                          Which paths is it talking about?


                          My redirect is http://redirect.ut3.uovalor.com/redirect/. I read somewhere that it has to be in a folder called redirect so I did that, but still does not work. I also ensured to have the trailling slash in the ini file.

                          Comment


                          • #14
                            Just to make sure, you have done everything in the first post?
                            http://forums.epicgames.com/threads/...1#post25279830

                            Originally posted by Red Squirrel View Post
                            It downloads at 0.1, 0.2 etc...
                            Something is wrong with your redirect, the fact you are finding no entries in apache shows that. Try changing your redirect to http://www.uovalor.com/redirect/ or http://www.uovalor.com/redirect
                            It has been awhile since I setup redirect on a server but I remember UT3 having issues with the directory and the / at the end or not at the end (been awhile, I forget) when written in the UTEngine.ini file, maybe it having the redirect.ut3 is messing it up too. Till you know that the files are being transfered through redirect properly, leave AllowDownloads=False
                            When it downloads like 0.1 and 0.2, the redirect is not configured properly.

                            It doesn't need to be redirect, I had mine UT3 on my old server. You can change it to what you want.

                            Comment


                            • #15
                              I configured a redirect locally. It worked fine. So i change the redirect path to your server. It failed in downloading the file. So wikkid should be right, something's wrong with your redirect.

                              Comment

                              Working...
                              X