Announcement

Collapse
No announcement yet.

New to UT3, need help starting server

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    New to UT3, need help starting server

    I'm new to UT3 but not to server set-up, however I am having trouble setting up a dedicated server on my PC behind a firewall. First, I created a static ip then opened these ports on my router:

    27900 TCP/UDP
    13000 TCP/UDP
    6500 TCP/UDP
    7777 TCP/UDP
    7778 TCP/UDP
    7787 TCP/UDP

    I then downloaded and installed the Dedicated Server pack and created a batch file, here it is:

    Code:
    :one
    c:
    cd \Program Files (x86)\Unreal Tournament 3 (Dedicated)\Binaries
    ut3.exe server vCTF-Corruption?Game=UTGameContent.UTVehicleCTFGame_Content?GameMode=3?numplay=4?maxplayers=12?NumPublicConnections=12?NumPrivateConnections=0?NumOpenPublicConnections=12?NumOpenPrivateConnections=0?bShouldAdvertise=True?bIsDedicated=True?PureServer=1?timelimit=20?goalscore=5?botskill=3?AdminPassword=XXXX -log=server.log -login=XXXX -password=XXXX -nohomedir -configsubdir -unattended
    cd \Program Files (x86)\Unreal Tournament 3 (Dedicated)\UTGame\Logs
    copy server.log server.bak
    goto one
    I've also seen the tutorial here on the site and added these to the UTGame.ini and UTWeb.ini respectively. These are located at C:\Users\XXXX\Documents\My Games\Unreal Tournament 3\UTGame\Config

    Code:
    [Engine.AccessControl]
    AdminPassword=XXXX
    IPPolicies=ACCEPT;*
    [Engine.GameReplicationInfo]
    ServerName=Nazgul
    ShortName=Nazgul
    MessageOfTheDay=Welcome
    Code:
    ListenPort=7778
    bEnabled=true
    Here's some screenshots that might help. The second one shows what the server says after I try to connect manually via entering the ip which would be 74.195.200.48:7777. It says there is one player in the server but that's not true, it won't let me in.





    However, when the server launches, I'm not able to join the game. I have the game via Steam. I start up the server and then look for it on the Master List but it's not there. I've also tried to connect to the server directly by entering the ip which is 74.195.200.48. The port would be 7777, right? So 74.195.200.48:7777. But while I get the server to start up, it doesn't show up on the list, I can't join it and I don't know why, any help would be appreciated. Also, my last question is can a PS3 player join my server? I heard the game supports cross-over.

    #2
    Originally posted by OldNaz View Post
    Also, my last question is can a PS3 player join my server? I heard the game supports cross-over.
    They cannot. The closest to cross-platform UT3 gets is the PS3 version allowing player-created content.

    Comment


      #3
      Originally posted by Aldaron07 View Post
      They cannot. The closest to cross-platform UT3 gets is the PS3 version allowing player-created content.
      Are you sure? Because a quick google search tells me cross-platform will work. However, I realize the game has been out for a while and people have had time to figure that out.

      The main problem is still here though, how to get my server up.

      Comment


        #4
        Since when has there ever been cross platform support? If there is, it is unofficial, and that is one hell of a big job for an unofficial mod.

        As for your support, if you mean a PC server, sometimes you can be unlucky, even if you enter all the correct ports, it just doesn't work. Depends on luck and what router you have.

        I can't remember what it was exactly, but i heard there was something you cuold do with the STUN server when the server loads, fool it into letting you through or something.

        Comment


          #5
          The only reason I know of that it would not show up in the master list is that you didn't create a separate login profile for your server.

          Make sure when you launch UT3 to not be logged in as a player. Then create a new player login profile with a login name and new password. This is the login name and password that needs to go in your command line above.

          Comment


            #6
            Originally posted by Fijut View Post
            Since when has there ever been cross platform support?
            I just thought there was based on my google searches and apparently a deeper search reveals that there is not

            Originally posted by Fijut View Post
            Depends on luck and what router you have.
            I have a Linksys WRT54G wireless router. It's pretty standard and has worked for other games when I port forward. Have no idea why it's for Unreal and I wonder if it's the router or something else.

            Originally posted by Fijut View Post
            ...i heard there was something you cuold do with the STUN server when the server loads, fool it into letting you through or something.
            I used this tutorial to setup a STUN server but with no luck. My UTEngine.ini now looks like

            Code:
            StunServerAddress=(internal ip)
            StunServerAddress=
            Originally posted by Taffy View Post
            The only reason I know of that it would not show up in the master list is that you didn't create a separate login profile for your server.

            Make sure when you launch UT3 to not be logged in as a player. Then create a new player login profile with a login name and new password. This is the login name and password that needs to go in your command line above.
            I hadn't thought of that, I was using the same login for both the server and the player. So I did what you said, I made a new account and put the new info in the config so that it's separate from my player account and tried it but it still doesn't show up on the list. I've even turned DMZ on but still no luck so that makes me wonder if it has anything to do with the router/ports. The STUN server gives me no help either. It really blows my mind that the game has been out for how many years and there's not an easier way to start up a server if you're simply behind a router.
            Here's some screenshots that might help. The second one shows what the server says after I try to connect manually via entering the ip which would be 74.195.200.48:7777. It says there is one player in the server but that's not true, it won't let me in.


            Comment


              #7
              Look here for setting up a server :

              http://www.dcsautomatisering.nl/Unreal/UT3Server.aspx

              Your Enginenumber is 3487 it shoud be 3809 or 3810 if it is a dedicated server.

              Comment


                #8
                Did you manage to set up the server yet or not?

                Comment


                  #9
                  You should read THIS thread. The short version is: you need a "full cone" router. As far as I know, LinkSys does not make a consumer full cone router...I don't think Netgear does either. The link, above, has a link to a (German) site that lists various router types; that link appears to be broken, although it was active several years ago and it was where I got the info about LinkSys routers.

                  Comment

                  Working...
                  X