Announcement

Collapse
No announcement yet.

Ut3 Win Server mutator loading problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Ut3 Win Server mutator loading problem

    Hi Allz!

    I have problem with mutator downloading. I have started my server with:

    ut3.exe Server DM-Biohazard?Game=UTGame.UTDeathmatch?mutator=RBTTNew s.MutNews,UTOrbFix.UTMutator_OrbFix,ColorControl.U TMutator_ColorControl,utcomp3v4b2.UTMutator_utcomp 3v4b2?MaxPlayers=12?numplay=1?NumPublicConnections =6?NumPrivateConnections=0?MinNetPlayers=0?TimeLim it=15?GoalScore=25?BotSkill=4?bIsDedicated=true?bU sesStats=true?ForceRespawn=0?bShouldAdvertise=true ?PureServer=1?bIsLanMatch=false?bAllowJoinInProgre ss=true?Adminpassword=XXXX -login=XXX -password=XXXXX -Log=myservernew.log -nohomedir -unattended

    I dont have any problem with start, but i added some mutator on the vote list, weapon replace, hacker weapon etc. Forced mutators: color control, orb fix,...

    My problem is, the server mutators loading not before map loaded, after map loaded. I see after start on the map, my chat messages: receive package...10%...15%... The client loading the mutator online in the game, not before map. Sometimes after 100% the ut3 client make crash.

    Any parameter to force mutator fully loaded before map loading?

    Another version my problem, any way put ,,XX elite mashines'' mutator on the votable list (gametype)? I have same problem with this mutator, after voting i get the map, but the mutator downloading is not ended. Or this is a only forced mutator?

    thx

    #2
    erm i found out today that this mutator soemtiems crashes my server utcomp3v4b2.UTMutator_utcomp 3v4b2 but its very difficult to confirm that because it could be a second oen thats interfering and maby both crash but looked at ur command i think its way to long ,shorten commandline in and look for typo"s and make sure u test not more than 2 mods at the same time and save logs of combination each day, furthermore its hard to tell if this will sort ur problems,

    good luck!

    Comment


      #3
      I also have this problem.

      At first I was really happy that they did away with the 'serverpackages=' system of Unreal 2004, now, not so much. I just want to force all the mutators on my server to the client when they first join, which would avoid this problem.

      This is also an issue if you use weapon replacers, and the weapon is not on all maps. So the client joins the map without the weapons, then when the map changes it will send the weapons as the player is already in the map meaning they can't see the weapons until they rejoin.

      If anyone has any ideas how to stop this please please let us know!

      Comment

      Working...
      X