Announcement

Collapse
No announcement yet.

Mutators drops on server

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Mutators drops on server

    Hi!

    My problem is that when hosting a dedicated UT3 server, the mutators will drop after new match. I have put tree mutators to run_server.bat file. Like this:

    <click>?Mutator=UTGame.UTMutator_FriendlyFire,UTGa me.UTMutator_Hero,UTGame.UTMutator_BigHead<click>

    = friendly fire scale 80 %
    = Titan and
    = big head

    There are right lines on UTMaplists.ini too:

    GameProfiles=(GameClass="UTGameContent.UTOnslaught Game_Content",GameName="Warfare",MapListName="WARM apList",Options=,Mutators=,ExcludedMuts="UTGame.UT Mutator_BigHead,UTGame.UTMutator_FriendlyFire,UTGa me.UTMutator_Hero",bIsTeamGame=True)

    But when brosing UT3's built-in browser my server is standard again and no mutators there. Titan, friendly fire and big head have left. By admin web interface there is same situtation. No mutators left.

    Why they do not stay there? Do I need to add elsewhere this same mutators line, like on every WAR map? Am I using wrong syntax, I mean no need to add command linen URL - only UTMaplists.ini is enough.


    Other story is when I tryed to host to different gametype: WAR and vCTF (they are much similar and I am interesting host both). But if I let people vote gametype then maplist is empty. I have removed other gametypes maps away from web admin interface, so player can choose only with this two: WAR or vCTF. But now I am not enabling this while I have this mutator problem.

    #2
    Try changing the gameprofile to this:

    Code:
    GameProfiles=(GameClass="UTGameContent.UTOnslaught Game_Content",GameName="Warfare",MapListName="WARM apList",Options=,Mutators="UTGame.UTMutator_FriendlyFire,UTGa me.UTMutator_Hero,UTGame.UTMutator_BigHead",ExcludedMuts,bIsTeamGame=True)
    You had the mutators that you wish to use in the excluded mutators section of the gameprofile.

    Comment


      #3
      Problem solved!

      Originally posted by JD8 View Post
      Try changing the gameprofile to this:

      Code:
      GameProfiles=(GameClass="UTGameContent.UTOnslaught Game_Content",GameName="Warfare",MapListName="WARM apList",Options=,Mutators="UTGame.UTMutator_FriendlyFire,UTGa me.UTMutator_Hero,UTGame.UTMutator_BigHead",ExcludedMuts,bIsTeamGame=True)
      You had the mutators that you wish to use in the excluded mutators section of the gameprofile.
      Thank you! This was the magic change.

      I erased all what says something on voting on UTGame.ini and now vote system works, too. Very very nice!

      Comment

      Working...
      X