No announcement yet.

Custom Mutator Issue W/ 2.0?

  • Filter
  • Time
  • Show
Clear All
new posts

    Custom Mutator Issue W/ 2.0?

    We re set up our UT3 server upon the 2.0 release. We added a couple custom mutators. The mutators are showing in the vote window in game / on server as well as in web admin. however our issue is that they show but once activated through vote they do not appear to be working.

    EX: Quad jump voted in but doesn't work

    I looked for similar threads but no luck on my end... Does anyone have info on this or can someone be kind enough to direct me w some links to fix's or threads on this forum that I may have missed?

    Current mutators showing but not working are:
    Dodge jump
    Quad jump

    Are these mutators even compatible w/ 2.0?
    If not any resources?

    Thanks GX

    There is an issue with the mutator Voting - if the mutators are excluded in the game profile - bottom off picture

    they still show up at voting time - but Voting for them does nothing.

    So make sure you have the mutators boxes 'UNticked' in the 'excluded mutators' section for the game profiles'

    Do they show in the 'Current game' off webadmin as loaded ?

    if you want them to load as default best to use 'MutatorLoader' by Shambler esp if the server disappears in the UT3 browser and you can join it by IP address.


      Ok here is the set up
      As you can see its set up as you recommended. But still no luck.
      Could I be installing the server mutators incorrectly or placing the mutator .ini files improper?

      mutator files go: UTGame/Cooked PC ?
      .ini files go: UTGame/Config ?


        Mutator files go where the author says they should go. It might be UTGame/CookedPC but it also might not. Could be UTGame/Published/CookedPC/Script or some other folder structure the author used.

        Yes, the .ini files go in UTGame/Config. That is, unless the server runs with a -configsubdir= parameter in which case it would be UTGame/Config/<configsubdirname>.


          far as i know dodgejump works with does on my server at least.

          are we talking about THIS dodgejump: (the one i use) or another one? ...i think there's been a couple made.


            Ok that helped! I downloaded the posted version and that was one of the issues. Removed the old version from the instructed install location and reinstalled this one above and BINK! all good.

            (Placed the mut dodge jump in script folder was fix.)

            Ill go ahead and follow this process if I run into any more issues.

            Thanks |oGc|GO@XX


              I have this issue too. I've added the ini and .u files where the author said they go, but when I add them to UTVote (which I may be doing incorrectly), they show up for voting, but once the map changes, it still says that they are off. Sounds like we have the same problem, and I have no idea how to fix it.

              As an example (in case I'm adding these wrong, so someone can help me out), the boost dodge Mut I'm trying to add. The INI file is called "UTMutMultiDodgeJump". Here are screens of the Mut ini file, and my UT vote file.

              So I'm assuming I did this correctly. The line I added to the UTVote was:
              VotableMutators=(mutClass="UTMutMultiDodgeJump.Mut MultiDodgeJump",mutname="Boost Dodge")

              The first part being "UTMutMultiDodgeJump" the name of the INI, and the second part being "MutMultiDodgeJump" the info for the mutator within the INI. Is this correct, or did I do it totally wrong?


                For the MUt dodge jump i just added to start up command line and it forced it however im still debugging some of these issues on our server.