Announcement

Collapse
No announcement yet.

Weapon Bug, anyone?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Weapon Bug, anyone?

    Due to new server installation and upgrade to v2 i'm having this bug.
    Basically the players see a weapon but while they're trying to pick it up it just disappears. TDM server with patch 4 and Titan pack, weapon stay off. Sometimes a gun is there and you're unable to take it. Also sometimes the gun is not there but you can take it.
    Seems a kind of packetloss, but it's not.

    By checking the log files i've got this errors:

    Error: Objects MaterialExpressionRotator WP_BioRifle.Materials.M_Bio_Blob_02_Rim2_Fallback: MaterialExpressionRotator_8 and MaterialExpressionOneMinus WP_BioRifle.Materials.M_Bio_Blob_02:MaterialExpres sionOneMinus_5 have duplicate NetIndex 2396
    Error: Objects MaterialExpressionTextureSample WP_BioRifle.Materials.M_Bio_Blob_02_Rim2_Fallback: MaterialExpressionTextureSample_45 and MaterialExpressionTextureCoordinate WP_BioRifle.Materials.M_Bio_Blob_02:MaterialExpres sionTextureCoordinate_11 have duplicate NetIndex 2552

    Error: Objects MaterialExpressionMultiply WP_Stinger.Materials.M_Stinger_Elect_01:MaterialEx pressionMultiply_0 and MaterialExpressionConstant WP_Stinger.Materials.M_Stinger_Spark_Burst:Materia lExpressionConstant_8 have duplicate NetIndex 1413

    etc...

    Any clue?

    #2
    Its happening on our server too. Once one person takes a weapon from a pickup base its gone for EVERYONE! Its only supposed to disappear for the person that picked it up. The weapon pickup bases worked fine before, so I dont know why Epic decided to break them. Maybe we can get a quick fix for this issue???

    Comment


      #3
      I have not seen this on our servers. Try this please.

      Remove all mutators.
      Test the server to see if it is still doing it.
      If no, add the mutators back one at a time to see where the conflict is.

      If yes, please let me know.

      Comment


        #4
        In WebAdmin, if you check none on weapons respawn and change the map everything works fine for that match. After the next map loads it defaults back to the weapons not respawning and you can only pick up weapons from pickup bases that no one else has touched.

        Comment


          #5
          Originally posted by Flak View Post
          I have not seen this on our servers. Try this please.

          Remove all mutators.
          Test the server to see if it is still doing it.
          If no, add the mutators back one at a time to see where the conflict is.

          If yes, please let me know.
          Hi there Flak,

          I solved this matter.
          Basically was related to utcomp. A new version which is available solves the problem, here's the fixlist:

          - utcomp scoreboards now compatible with ut3 v2.0
          - fixed incorrect weapon visibility with weaponstay off.
          - added compatibility with epic's clientside demorec.


          Hope it helps

          Comment

          Working...
          X