No announcement yet.

Negative Delta Time + Linux Xen Problem SOLVED

  • Filter
  • Time
  • Show
Clear All
new posts

    Negative Delta Time + Linux Xen Problem SOLVED

    If you're on a liinux VPS, chances are your Negative Delta time error could be solved with this. If your VPS is not Xen-based (most are), then it won't help you, I'm sorry.

    I tried everything that was mentioned here on the forums and harassed my hosting company for a week. Finally I changed my clocksource and the errors went away. I also had to decouple my wallclock before I could do this.

    Decoupling the wallclock:
    echo 1 > /proc/sys/xen/independent_wallclock
    (Try running the ut3 server at this point, if it works, don't bother with the rest)

    Displaying current clocksource:
    cat /sys/devices/system/clocksource/clocksource0/current_clocksource
    (mine showed "jiffies")

    Listing available clocksources:
    cat /sys/devices/system/clocksource/clocksource0/available_clocksource
    (I got "xen" and "jiffies" from this list, so I decided to try switching)

    Changing the clocksource:
    echo "xen" > /sys/devices/system/clocksource/clocksource0/current_clocksource

    Try running the server again, if the Negative Delta time errors are gone you should have the wallclock decoupled and change the clocksource. You can do that by editing the "/etc/sysctl.conf" file and adding the following lines:
    # decouple clock from host
    xen.independent_wallclock = 1
    # set clocksource to xen
    devices.system.clocksource.clocksource0.current_clocksource = "xen"

    (I'm still not able to get my server to show up in the server browser, I still need to figure that bit out )