No announcement yet.

WebAdmin v1.5 - 2008-08-08 (requires UT3 patch 1.3)

  • Filter
  • Time
  • Show
Clear All
new posts

    WebAdmin v1.5 - 2008-08-08 (requires UT3 patch 1.3)

    WebAdmin version 1.5 for UT3 with patch 1.3 has been released and can be downloaded here:

    Bug reports are still welcome here:

    Change log:
    v1.5 - 2008-08-08
    - Upgraded to jQuery 1.2.6 and jQuery UI 1.5.2
    - playercontrollers created for the webadmin users are now shared between admins
    using the same name. This is a resource optimization fix
    - some UI tweaks

    v1.4 - 2008-06-03
    - demorec player no longer shows up in the player lists
    - added config option for "No Custom Characters" (Settings/General/Players)
    - added settings for map voting (Settings/General/Map Voting)

    (because these version required UT3 patch 1.3 they were not announced here when they were done)

    thanx for the update muerte i have a question about the Server Region setting does it matter on what we put it on like if we choose Uk Region will the server only appear there????


      The server region stuff isn't really used for anything as far as I know, it never has been. Ping times are usually more reliable than a server provided region. But gamespy still processes the data.


        k what about multy gametype voting like in ut2004 is it possible yet


          just curious if I need to have 1.3/4 in prior to adding 1.5 or if 1.5 is stand alone?

          awesome job BTW with the webadmin end of it, absolutely outstanding work!


            Thanks Elmuerte!


              DOH... nevermind, always a good idea to read the read me. Clearly states needs v1.3 meaning version 1.3 of the webadmin not official patch 1.3.

              again great job man!



                Originally posted by dave neun View Post
                just curious if I need to have 1.3/4 in prior to adding 1.5 or if 1.5 is stand alone?
                As indicated in the title of this thread: WebAdmin v1.5 - 2008-08-08 (requires UT3 patch 1.3)

                Each version of WebAdmin released by elmuerte is always a full install - You do not need a previous version of WebAdmin installed in order to install the latest.


                  Thanks, El Muerte for your continued work on Web Admin and the fine job you are doing. I was excited to see that Mid-Map Vote was available and installed both the Patch 3 and this latest Web Admin. However, I am having difficulting getting Mapvote to Work Properly.

                  All seems to be OK with mid-map voting. I have only been able to test it methodically with 3 players on, but we three were able to successfully vote 2 to 1 for a map mid-map. The trouble showed up at the end of maps. We would vote 2 to 1 for a map (just as we had done for mid-map voting) and the countdown would begin, but when it reached zero, nothing happened. The game stayed on the current map and didn't change to either the map voted for or the next map in rotation. Let me add that the same situation occurred when it was just I, alone, on the server.

                  Here are my settings:

                  Allow Map Voting: yes
                  Allow Mid-Game Voting: yes
                  Mid-Game Vote Delay: 25
                  Minimal Votes: 1
                  Vote Duration: 30
                  Vote Percentage to Change Map: 66

                  I'm wondering if I have a conflict between the countdown and some other setting, but I haven't seen it and may be looking in the wrong places.


                    hey CL
                    change Vote Percentage to Change Map: 66
                    Vote Percentage to Change Map: 50
                    and try again with 2 to 1


                      Originally posted by unrealloco View Post
                      hey CL
                      change Vote Percentage to Change Map: 66
                      Vote Percentage to Change Map: 50
                      and try again with 2 to 1
                      Thanks for the suggestion, Loco. However, it proves out that I posted this thread prematurely and I apologize profusely for that.

                      I had been testing mapvote on the gametype we had been running on our event server, which was BR. When we switched to CTF tonight as we did further testing, we were able to vote successfully both atmid-map and end of map - same with DM. I understand that the version of BR we are running is not made for Patch 3. It had worked so well in spite of that that I forgot about it when I was puzzling about the mapvote issue. Again, my apologies to everyone.


                        Hi all,
                        I've got a problem with the WebAdmin release 1.5 and my Linux Dedicated Serveur 1.3.
                        I've got some errors occurs when is clic on SETTINGS in the webadmin interface.
                        Here is the log :
                        Warning, Missing BoolProperty UTGame.UTGame:bMidGameMapVoting referenced by package 'WebAdmin'
                        Warning, Missing IntProperty UTGame.UTGame:MapVotePercentage referenced by package 'WebAdmin'
                        Warning, Missing IntProperty UTGame.UTGame:MinMapVotes referenced by package 'WebAdmin'
                        Warning, Missing IntProperty UTGame.UTGame:InitialVoteDelay referenced by package 'WebAdmin'
                        When is see the errors, i decide to put this options on my UTGame.ini in the original folder and the hidden folder.
                        Here is my new UTGame.ini.
                        I've tried to put those arguments directly in the command line.

                        So, all of this modifications don't works and the server crash with always that **** errors

                        Can someone help me ?

                        PS : Sorry for my bad english.


                          Are you sure you updated to UT3 patch 1.3?
                          Because those settings are only available in 1.3, it's not a configuration file issue, it's literally missing functionality in the game instance. Check the "about" link in the webadmin to make sure you have UT3 version 1.3 (engine version 3601)


                            Thank you ElMuerte


                              Here you can see the server version
                              Engine Version
                              So ... i'm a poor noob because i have downloaded the last server from icculus but this is the 1.2 release from 02022008 ....

                              Really sorry guys

                              EDIT :
                              So, after server update all works fine but i must set listenport to 8080 to make it bindable ... don't know because it can't use 80 but i haven't any other webserver on my gameserver.

                              All works fine