Announcement

Collapse

The Infinity Blade Forums Have Moved

We've launched brand new Infinity Blade forums with improved features and revamped layout. We've also included a complete archive of the previous posts. Come check out the new Infinity Blade forums.
See more
See less

Dedicated Server - Restricted Cone NAT Router

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Dedicated Server - Restricted Cone NAT Router




    Ok, seems we are having no assistance from Epic to modify the ability for Dedicated Servers through a router with NAT.

    Couple posts on alternate sites have some guidance but not enough for my liking as I have not been successful.

    http://mususumbra.blogspot.com/2007/...-solution.html
    http://www.lanpartyguide.com/ut3.html

    I downloaded the "STUNserver" - WinStunSetup-0-96.msi
    Now this has no config, no Read Me, only a few dll files in the directory.
    Below is the GUI but I have no idea what is to be put into it.






    Then both sites state using a CMD prompt C:\ with the following command:
    server -h YOURIPADDRESS -a 127.0.0.1 -v

    Assuming YOURIPADDRESS = 192.168.1.108 = UT3 Server

    But this command brings no results that replicate from web blog




    Anyone have success with this STUN server on a Vista OS.

  • #2
    STUN is not needed. The "network incompatible" message is because your router doesn't preserve the source port on outgoing connections (or possibly because the game port isn't correctly forwarded but lets assume it is in this case). This of course is something you can't really control, the solution is to get in Epics face and let them know about it.

    I've run a test server with absolutely no STUN traffic allowed in or out the firewall and it works just fine.

    Comment


    • #3
      Thanks for the reply NakedApe, but what was your solution to overcome the router issue of NAT?

      Comment


      • #4
        I'm fortunate enough to use a router that is configurable enough to overcome the issue. Since I use OpenBSD on a PC as router I could tell it to preserve the source port (using "static-port") and that makes it work.

        Unfortunately there is no such easy fix for those behind SOHO routers and many (most probably) will be reluctant or downright refuse to run an extra PC for this purpose even though you can manage with very limited hardware.

        Comment


        • #5
          So you have any other suggestions of a router that is proven to work?

          I am currently using a Linksys WRT54GL that does not allow configuration to allow UT3 server access to Internet.

          Sorry I dont have time to learn OpenBSD.

          Comment


          • #6
            for your specific WRT54GL router try the following from the portfoward.com site. It does require that you set a static internal ip (192.168.1.xxx) on the server.

            ex.
            I would set it to something easy
            ip = 192.168.1.100
            sub = 255.255.255.0
            gateway = 192.168.1.1

            look at the routers current status page and use the dns ip's found there to static assign the dns servers if desired.

            http://www.portforward.com/english/r...urnament_3.htm


            I have one of my ut3 servers running behind a sonicwall hardware firewall on which the lan is nat'd and it works perfectly, the other I had to resort to using the windows firewall and a static (routable) ip on the windows box.

            Comment


            • #7
              also I found a utility that's supposed to test your router and report if it can do "full-cone" nat which is the type of NAT ut3 requires (according to the faq here http://utforums.epicgames.com/showthread.php?t=584654 on the 3rd from bottom question).

              nat test utility
              http://forum.emule-project.net/lofiv...p/t130035.html

              I googled full cone nat routers and found the following that say they are full cone nat capable:
              DLINK DIR-301
              Netgear WGT624 v2
              Netgear DG834GT
              D-Link DI-604 H/W:B1 w/SPI off

              Comment


              • #8
                Havok,

                Well I used the Emule tool and came with the unpleasant results that I am behind a Restricted Cone NAT Router.



                So next is to fix a static IP address on the server and find a new router with Full Cone NAT.

                Shame EPIC hasn't over the years tried to assist the peeps that have made it the FPG Icon!

                *** Shame Shame EPIC ***

                Comment


                • #9
                  Well I ran the test on my server thats behind a Sonicwall Pro firewall, and that server runs fine and is accessible from the Internet. It did report I am using PAT, and Restricted CONE NAT, so I guess thats good enough as it works.

                  Here are the results:
                  - Your router/firewall is using Port Address Translation (PAT)
                  - It seems you are behind a Restricted Cone NAT Firewall or Router. From eMule's
                  Point of View (for LowID Users) this is ok however eMule is currently assuming
                  this from LowIDs already so there is not that much room for improvement for such
                  cases

                  Comment


                  • #10
                    If you forward a port in your router that port will assume full cone characteristics.

                    Silica, unfortunately I can't make any recommendations on router choice. The downside to finding a solution that fits all your problems is that you don't spend time researching the alternatives.

                    Comment


                    • #11
                      sounds logical to me...

                      still imo it should be made easier for people to run their own servers. Even Unreal 1 was easily able to run servers regardless of routers. You forward the appropriate ports and no issues. U1, UT, UT2k4, etc.. all very easy to setup. UT3 however is a different beast for some reason....

                      Comment


                      • #12
                        UT2k4 was broken with regards to PAT. It seems the bug has been fixed in UT3 and it most likely would work just fine but Epic chose to include a test to prevent it from even trying.

                        If one were prone to conspiracy theories one might think that they were doing it intentionally. After all, there are companies making money from game server hosting and match making systems...

                        Comment


                        • #13
                          Thanks to both of you for your input assisting me and the forum, to determine I was not going crazy with double cross checking my config.

                          As to Epic it is obvious this issue could and should of been resolved during the demo release.

                          The massses wanting this game as a dedicated server for sure lost patience and fallen to the clutches of the corporate game server hosting market.....

                          Only the few with our determination strive forward to overcome, to reach the ultimate goal of fragin' with a 1ms ping.

                          Comment

                          Working...
                          X