No announcement yet.

freebsd server setup?

  • Filter
  • Time
  • Show
Clear All
new posts

    freebsd server setup?

    I've got a freebsd server with linux compatibility enabled and can't seem to get a UT3 server up and running. I setup a account to run the game under and installed the game to its home directory. I went into my binaries folder and tried ./ut3 and keep getting that its not found to start the server. I can't really figure it out, I've tried reinstalling the server binaries and have had no luck. Anyone else have any trouble getting this running under freebsd?

    I've actually gotten UT3 to run, even inside a jail, but first, to make sure the linux compatibility is working here's the commands I've used (If you've completed a step, just skip it, but these are the steps that worked for me):

    Worked for FreeBSD 6.x and 7.x

    (Some parts taken from Chapter 10 FreeBSD handbook)

    1. # kldload linux

    2. % kldstat
    Id Refs Address Size Name
    1 2 0xc0100000 16bdb8 kernel
    7 1 0xc24db000 d000 linux.ko

    (Make sure it shows the linux.ko loaded)

    3. Edit the /etc/rc.conf and add linux_enable="YES"

    4. Install the linux_base-fc4 in /usr/ports/emulators (do the make install distclean)

    5. mount_linprocfs /proc /proc (If it complains, check the FreeBSD handbook for proper syntax and you may have to add it to /etc/rc.local to enable at startup)

    Again, these steps worked for me, but that was a while back. Double check the handbook, and you can also try Kinko's guide from the steam forums:

    Shows a little more on some FreeBSD linux compatibility, (obviously exclude the hlds stuff)

    Now, keep in mind, this just gets the server up, no guarantees it will be stable and that you actually get to connect. I've been frustrated with the server showing up, but never can connect. (linux, FreeBSD, Solaris etc...)

    That's afaik, good luck.


      Well I know my linux compatibility is working as I've run TFC/TF2 servers on this box for quite a while now. I quit playing both and decided to switch it over to UT3. I'll look it over anyways though to make sure I didn't miss something there. But if you have anymore suggestions let me know.


        If you can get those hlds servers up then I'm pretty sure the linux compatibility isn't your issue. (Pretty sure :P but don't hold me to it)

        That's strange that it can't find the binary. I've had to redownload the linux-dedicated files quite a few times to make sure I get the whole thing. Sometimes during extraction, there can be an error. Check permissions and stuff like that. Modify the startup command line.

        Here's my startup command line that's worked on Ubuntu linux and Windows, that was a HUGE problem for me for a long time just trying to run it. (Still can't connect in *nix though, just Windows)

        ./ut3 Server WAR-OnyxCoast?bIsLanMatch=True?MaxPlayers=12?NumPlay=6 ?BotSkill=0?GoalScore=2?TimeLimit=20?AdminPassword =**** -login=**** -password=**** -unattended -nohomedir

        If I think of anything else I'll post it.


          Hrm, I'll redownload the server files and reinstall them. Perhaps I just didn't get everything installed the first time. Still thanks for the suggestions so far.


            edit: all fixed


              Never mind, problem solved!


                How about posting your solution so that you may help future users with the same problem?