Announcement

Collapse
No announcement yet.

ut3 linux server startup problems

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    ut3 linux server startup problems

    hi, i am having some problems getting my UT3 server up and running, im on Ubuntu 8.04, i followed the directions in the linux how-to accept for the host file thing, being slightly new to this server thing im not sure what exactaly to edit in the hosts file to get what i need in there. I can do "./ut3 Server" and it runs fine, then when i try my command line;

    slightly edited to protect my un/pw's the IP is real though



    "./ut3 Server WAR-Serenity?Game=UTGameContent.UTOnslaughtGame_Conten t?GameMode=2?Numplay=8?MaxPlayers=24?NumPublicConn ections=24?NumPrivateConnections=0?MinNetPlayers=1 ?TimeLimit=30?GoalScore=3?BotSkill=4?bIsDedicated= true?bUsesStats=true?ForceRespawn=0?bShouldAdverti se=true?PureServer=1?bIsLanMatch=false?bAllowJoinI nProgress=true?AdminName=myadmn?AdminPassword=pass word -Login=myusername -Password=mypw -Log=myserver.log -multihome=216.237.71.218 -unattended"
    THER ARE NO SPACES IN MY COMMAND LINE besides " -Login=myusername -Password=mypw -Log=myserver.log -multihome=216.237.71.218 -unattended", this forum is displaying it weird

    i get this :

    Init: Version: 3542
    Init: Epic Internal: 0
    Init: Compiled: Feb 20 2008 00:44:51
    Init: Command line: Server WAR-Serenity?Game=UTGameContent.UTOnslaughtGame_Conten t?GameMode=2?Numplay=8?MaxPlayers=24?NumPublicConn ections=24?NumPrivateConnections=0?MinNetPlayers=1 ?TimeLimit=30?GoalScore=3?BotSkill=4?bIsDedicated= true?bUsesStats=true?ForceRespawn=0?bShouldAdverti se=true?PureServer=1?bIsLanMatch=false?bAllowJoinI nProgress=true?AdminName=Skrag?AdminPassword=66666 6 -Login=Captaintoke -Password=666666 -Log=myserver.log -multihome=216.237.71.218 -unattended
    Init: Base directory: /home/skargath/ut3-dedicated/Binaries/
    Init: Character set: Unicode
    Log: GConfig::LoadFile has loaded file: ../UTGame/Config/UTEditor.ini
    Log: GConfig::LoadFile has loaded file: ../UTGame/Config/UTEditorUserSettings.ini
    Log: GConfig::LoadFile has loaded file: ../UTGame/Config/UTEngine.ini
    Log: GConfig::LoadFile has loaded file: ../UTGame/Config/UTGame.ini
    Log: GConfig::LoadFile has loaded file: ../UTGame/Config/UTInput.ini
    Log: GConfig::LoadFile has loaded file: ../UTGame/Config/UTUI.ini
    Init: File handle limit is soft=(1024), hard=(1024).
    Init: Computer: unknown
    Init: User: skargath
    Init: BSD Sockets initialized
    Init: Presizing for 83221 objects not considered by GC, pre-allocating 0 bytes.
    Init: Object subsystem initialized
    Init: Startup System Settings:
    Init: System Settings:
    Init: StaticDecals=true
    Init: DynamicDecals=true
    Init: DynamicLights=true
    Init: DynamicShadows=true
    Init: LightEnvironmentShadows=true
    Init: CompositeDynamicLights=false
    Init: DirectionalLightmaps=true
    Init: MotionBlur=true
    Init: DepthOfField=true
    Init: Bloom=true
    Init: QualityBloom=true
    Init: Distortion=true
    Init: DropParticleDistortion=false
    Init: SpeedTreeLeaves=true
    Init: SpeedTreeFronds=true
    Init: OnlyStreamInTextures=false
    Init: LensFlares=true
    Init: FogVolumes=true
    Init: FloatingPointRenderTargets=true
    Init: Trilinear=false
    Init: OneFrameThreadLag=true
    Init: UseVsync=false
    Init: UpscaleScreenPercentage=true
    Init: Fullscreen=false
    Init: AllowD3D10=true
    Init: EnableHighPolyChars=false
    Init: SkeletalMeshLODBias=0
    Init: ParticleLODBias=0
    Init: DetailMode=2
    Init: ShadowFilterQualityBias=0
    Init: MaxAnisotropy=4
    Init: MaxMultisamples=1
    Init: MinShadowResolution=32
    Init: MaxShadowResolution=512
    Init: ResX=800
    Init: ResY=600
    Init: ScreenPercentage=100.000
    Init: SceneCaptureStreamingMultiplier=1.000
    Init: FoliageDrawRadiusMultiplier=1.000
    Init: ShadowTexelsPerPixel=2.000
    Log: TEXTUREGROUP_World: (MinLODSize= 1,MaxLODSize=4096,LODBias=0)
    Log: TEXTUREGROUP_WorldNormalMap: (MinLODSize= 1,MaxLODSize=4096,LODBias=0)
    Log: TEXTUREGROUP_WorldSpecular: (MinLODSize= 1,MaxLODSize=4096,LODBias=0)
    Log: TEXTUREGROUP_Character: (MinLODSize= 1,MaxLODSize=4096,LODBias=0)
    Log: TEXTUREGROUP_CharacterNormalMap: (MinLODSize= 1,MaxLODSize=4096,LODBias=0)
    Log: TEXTUREGROUP_CharacterSpecular: (MinLODSize= 1,MaxLODSize=4096,LODBias=0)
    Log: TEXTUREGROUP_Weapon: (MinLODSize= 1,MaxLODSize=4096,LODBias=0)
    Log: TEXTUREGROUP_WeaponNormalMap: (MinLODSize= 1,MaxLODSize=4096,LODBias=0)
    Log: TEXTUREGROUP_WeaponSpecular: (MinLODSize= 1,MaxLODSize=4096,LODBias=0)
    Log: TEXTUREGROUP_Vehicle: (MinLODSize= 1,MaxLODSize=4096,LODBias=0)
    Log: TEXTUREGROUP_VehicleNormalMap: (MinLODSize= 1,MaxLODSize=4096,LODBias=0)
    Log: TEXTUREGROUP_VehicleSpecular: (MinLODSize= 1,MaxLODSize=4096,LODBias=0)
    Log: TEXTUREGROUP_Effects: (MinLODSize= 1,MaxLODSize=4096,LODBias=0)
    Log: TEXTUREGROUP_Skybox: (MinLODSize= 1,MaxLODSize=4096,LODBias=0)
    Log: TEXTUREGROUP_UI: (MinLODSize= 1,MaxLODSize=4096,LODBias=0)
    Log: TEXTUREGROUP_LightAndShadowMap: (MinLODSize= 1,MaxLODSize=4096,LODBias=0)
    Log: TEXTUREGROUP_RenderTarget: (MinLODSize= 1,MaxLODSize=4096,LODBias=0)
    Init: Friendly System Settings:
    Init: TextureDetail=Level5
    Init: WorldDetail=Level5
    Init: bUseVSync=0
    Init: bUseMSAA=0
    Init: ScreenPercentage=100
    Init: UpscaleScreenPercentage=1
    Init: ResX= 800
    Init: ResY= 600
    Init: Fullscreen=0
    Log: Initializing FaceFX...
    Log: FaceFX initialized:
    Log: version 1.710000
    Log: licensee Unreal Engine 3 Licensee
    Log: project Unreal Engine 3 Project
    Log: GConfig::Find has loaded file: ..\Engine\Localization/int/Core.int
    Log: GConfig::Find has loaded file: ..\Engine\Localization/int/Engine.int
    Log: Loaded shader cache RefShaderCache-PC-D3D-SM3.CacheObject: 24748 shaders(5 legacy, 0 redundant), 2548 materials
    Log: GConfig::Find has loaded file: ..\Engine\Localization/int/UnrealScriptTest.int
    Log: GConfig::Find has loaded file: ..\UTGame\Localization/int/UTGame.int
    Log: GConfig::LoadFile has loaded file: ../UTGame/Config/UTWeapon.ini
    Log: GConfig::LoadFile has loaded file: ../UTGame/Config/UTCustomChar.ini
    Log: GConfig::LoadFile associated file: ../UTGame/Config/UTMap.ini
    Log: GConfig::LoadFile has loaded file: ../UTGame/Config/UTWeb.ini
    Log: GConfig::Find has loaded file: ..\Engine\Localization/int/OnlineSubsystemGameSpy.int
    Init: Version: 3542
    Init: Epic Internal: 0
    Init: Compiled: Feb 20 2008 00:51:27
    Init: Command line: WAR-Serenity?Game=UTGameContent.UTOnslaughtGame_Conten t?GameMode=2?Numplay=8?MaxPlayers=24?NumPublicConn ections=24?NumPrivateConnections=0?MinNetPlayers=1 ?TimeLimit=30?GoalScore=3?BotSkill=4?bIsDedicated= true?bUsesStats=true?ForceRespawn=0?bShouldAdverti se=true?PureServer=1?bIsLanMatch=false?bAllowJoinI nProgress=true?AdminName=Skrag?AdminPassword=66666 6 -Login=Captaintoke -Password=666666 -Log=myserver.log -multihome=216.237.71.218 -unattended
    Init: Base directory: /home/skargath/ut3-dedicated/Binaries/
    Init: Character set: Unicode
    Log: Executing Class Engine.ServerCommandlet
    Log: Initializing Game Engine...
    Init: UEngine initialized
    Log: Looking for DLC...
    Log: Object size..............: 60
    Log: Actor size...............: 436
    Log: ActorComponent size......: 88
    Log: PrimitiveComponent size..: 448
    Log: GConfig::Find has loaded file: ../UTGame/Config/UTUIDataStore_Registry_0.ini
    Log: Performing DNS lookup for stunserver.org
    Log: Browse: WAR-Serenity?Name=Player?team=255?Game=UTGameContent.U TOnslaughtGame_Content?GameMode=2?Numplay=8?MaxPla yers=24?NumPublicConnections=24?NumPrivateConnecti ons=0?MinNetPlayers=1?TimeLimit=30?GoalScore=3?Bot Skill=4?bIsDedicated=true?bUsesStats=true?ForceRes pawn=0?bShouldAdvertise=true?PureServer=1?bIsLanMa tch=false?bAllowJoinInProgress=true?AdminName=Skra g?AdminPassword=666666
    Log: LoadMap: WAR-Serenity?Name=Player?team=255?Game=UTGameContent.U TOnslaughtGame_Content?GameMode=2?Numplay=8?MaxPla yers=24?NumPublicConnections=24?NumPrivateConnecti ons=0?MinNetPlayers=1?TimeLimit=30?GoalScore=3?Bot Skill=4?bIsDedicated=true?bUsesStats=true?ForceRes pawn=0?bShouldAdvertise=true?PureServer=1?bIsLanMa tch=false?bAllowJoinInProgress=true?AdminName=Skra g?AdminPassword=666666
    Log: GConfig::Find has loaded file: ..\UTGame\Localization/int/UTGameContent.int
    Log: GConfig::Find has loaded file: ..\UTGame\Localization/int/WAR-Serenity.int
    Log: Game class is 'UTOnslaughtGame_Content'
    Init: Sockets: Socket queue 262142 / 262142
    Log: Failed to listen: Sockets: binding to port 7777 failed (99)
    Error: Error initializing network layer.
    Log: Primary PhysX scene will be in software.
    Log: Creating Primary PhysX Scene.
    Log: Novodex Terrain Creation (Terrain_1): 52.253000 ms
    Log: Bringing World WAR-Serenity.TheWorld up for play (0) at 2008.04.29-12.34.52
    ScriptLog: MinNetPlayers: 1
    ScriptLog: Destroying WebServer
    ScriptLog: Activating link setup Default
    Log: Bringing up level for play took: 0.827433
    Log: ########### Finished loading level: 3.906120 seconds
    Init: Game engine initialized
    Log: Initializing Game Engine Completed
    Log: FSTUNClient resolved stunserver.org (192.245.12.229)
    ScriptLog: CustomChar - Load Assets: IRNM
    Log: Begin Async loading packages for Family 'IRNM':
    Log: - CH_IronGuard_Male
    Log: Flushing async loaders.
    Log: Family Asset Package Loaded: CH_IronGuard_Male_SF
    Log: CONSTRUCTIONING: LoadFamilyAsset (IRNM) Took: -50.32 secs
    ScriptLog: CUSTOMCHAR Start: UTOnslaughtPRI_0 Cain VBlue
    Log: StartCustomCharMerge: 0.215111 ms initializing, 0.864889 ms texture streaming
    Error: Can't start an online game that hasn't been created
    ScriptLog: START MATCH
    ScriptLog: TIMEOUT: Streaming Textures for custom char. UTOnslaughtPRI_0
    ScriptLog: CUSTOMCHAR Start: UTOnslaughtPRI_7 Talan VRed
    Log: StartCustomCharMerge: 0.172115 ms initializing, 1.147885 ms texture streaming
    ScriptLog: TIMEOUT: Streaming Textures for custom char. UTOnslaughtPRI_7
    ScriptLog: CustomChar - Load Assets: TWIM
    Log: Begin Async loading packages for Family 'TWIM':
    Log: - CH_RTeam_Male
    Log: Flushing async loaders.
    Log: Family Asset Package Loaded: CH_RTeam_Male_SF
    Log: CONSTRUCTIONING: LoadFamilyAsset (TWIM) Took: -29.82 secs
    ScriptLog: CUSTOMCHAR Start: UTOnslaughtPRI_1 Bishop VRed
    Log: StartCustomCharMerge: 0.199929 ms initializing, 1.306071 ms texture streaming
    Exit: closesocket error (2)
    Exit: UTcpNetDriver shut down
    ScriptLog: TIMEOUT: Streaming Textures for custom char. UTOnslaughtPRI_1
    ScriptLog: CUSTOMCHAR Start: UTOnslaughtPRI_3 Hunter VRed
    Log: StartCustomCharMerge: 0.184977 ms initializing, 0.884023 ms texture streaming
    ScriptLog: TIMEOUT: Streaming Textures for custom char. UTOnslaughtPRI_3
    ScriptLog: CustomChar - Load Assets: TWIF
    Log: Begin Async loading packages for Family 'TWIF':
    Log: - CH_RTeam_Female
    Log: Flushing async loaders.
    Log: Family Asset Package Loaded: CH_RTeam_Female_SF
    Log: CONSTRUCTIONING: LoadFamilyAsset (TWIF) Took: -9.40 secs
    ScriptLog: CUSTOMCHAR Start: UTOnslaughtPRI_2 Jester VBlue
    Log: StartCustomCharMerge: 0.193052 ms initializing, 1.213948 ms texture streaming
    ScriptLog: TIMEOUT: Streaming Textures for custom char. UTOnslaughtPRI_2
    ScriptLog: CustomChar - Load Assets: NECM
    Log: Begin Async loading packages for Family 'NECM':
    Log: - CH_Necris_Male1
    Log: Flushing async loaders.
    Log: Family Asset Package Loaded: CH_Necris_Male1_SF
    Log: CONSTRUCTIONING: LoadFamilyAsset (NECM) Took: 1.03 secs
    ScriptLog: CUSTOMCHAR Start: UTOnslaughtPRI_4 Kragoth VBlue
    Log: StartCustomCharMerge: 0.189983 ms initializing, 1.490017 ms texture streaming
    Signal: SIGSEGV [segmentation fault]
    Aborting.

    Log:
    Developer Backtrace:
    Log: [ 1] ./ut3-bin [0x8d584e2]
    Log: [ 2] [0xb7f68420]
    Log: [ 3] ./ut3-bin [0x81e6be4]
    Log: [ 4] ./ut3-bin [0x809d95c]
    Log: [ 5] ./ut3-bin [0x8cb538c]
    Log: [ 6] ./ut3-bin [0x8cb5b14]
    Log: [ 7] ./ut3-bin [0x8cc334c]
    Log: [ 8] ./ut3-bin [0x8cb2b84]
    Log: [ 9] ./ut3-bin [0x8ca465a]
    Log: [10] ./ut3-bin [0x8cb5833]
    Log: [11] ./ut3-bin [0x8cb5b65]
    Log: [12] ./ut3-bin [0x8cb2b84]
    Log: [13] ./ut3-bin [0x8ca465a]
    Log: [14] ./ut3-bin [0x8cb526d]
    Log: [15] ./ut3-bin [0x853b166]
    Log: [16] ./ut3-bin [0x853c6c5]
    Log: [17] ./ut3-bin [0x853bd73]
    Log: [18] ./ut3-bin [0x8540ea5]
    Log: [19] ./ut3-bin [0x853f29a]
    Log: [20] ./ut3-bin [0x84d0022]
    Log: [21] ./ut3-bin [0x844ed20]
    Log: [22] ./ut3-bin [0x8052a52]
    Log: [23] ./ut3-bin [0x804b772]
    Log: [24] /lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe0) [0xb7dfd450]
    Log: [25] ./ut3-bin [0x804adb1]

    Crash information will be saved to your logfile.
    Exit: Exiting.
    Exit: Name subsystem shutting down


    heres what my hosts file looks like :

    127.0.0.1 localhost
    127.0.1.1 skargath

    # The following lines are desirable for IPv6 capable hosts
    ::1 ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts


    when kizoink says
    Edit your /etc/hosts file (as root) and change your localhost entry to 127.0.0.1 and not 0.0.0.0 (all interfaces) and then specifically add a hosts entry for your server. Here is my example:

    127.0.0.1 localhost.localdomain localhost
    129.11.231.14 myhostname myhostname.mydomain.com
    my servers (well, the router in between the outside world and the server) IP is 216.237.71.218

    im not sure how to set this up...with the right info, or is that hosts bull even whats crashing my server? i have all the ports and all that unblocked on my router also... i know he went over how to make the "startserver.sh" thing but before i get that far i want to get this thing up!

    thanks,
    any help would be greatly appricated!!

    #2
    Don't use your external address for -multihome, use the address assigned to the interface.

    Comment


      #3
      well i have it up and running, but it still doesnt show on the server list, i changed my hosts file so that both localhost and my login have the same ip

      i changed the multihome thing to my specified ip in the hosts file (127.0.0.1), but still doesnt show in the server list. i tried making a new commandline with the servername in it in the ut3 code(long string of numbers) to no avail

      running out of ideas! , i have edited the utgame.ini with the server name and all that (no spaces) so the commandline and the .ini match

      im using "./" in the startup script to run it, should i be using "sh" to start it?

      Comment


        #4
        No, you do not want to use 127.0.0.1 (nor any address starting with 127) for a externally accessible service. The reason is that no packet arriving at your machine will ever be addressed to it.

        Assign the address of eth0 (probably 192.168.*) to -multihome or assign it to your hostname in hosts and don't use -multihome.

        Comment


          #5
          multihome=192.168.something.something
          hosts file should state under
          127.0.0.1 localhost.localhost
          su - | root password | ifconfig eth"whatever" = ip =
          "ifconfig:ethwhatever-IP-here "hostname" "hostname.domainname.local | or whatever"

          Comment


            #6
            do you have a hosts entry for your interface address by the way?

            [lice_@dev3 ~]$ cat /etc/hosts
            127.0.0.1 localhost
            216.98.241.80 dev3.twitchhosting.com dev3 <- like so

            Comment


              #7
              i do now, and thanks you guys for the great help, its up and kicking now few tweaks and it will be gravy

              although some weird **** is happening in games, sometimes it totaly tweaks and both of the scores in WAR read 0, and i have to re-start the map or change maps to fix it, the darkwalker seems laggy more then normal also...

              Comment


                #8
                Such a problem when the server error
                Code:
                unreal3 @ wow: / media/E/Work/unreal/1/data/Binaries $. / Start.sh
                . / Start.sh: Line 1: 18 342 Error segmentation sh ut3 Server DM-Deck?Game=UTGame.UTDeathmatch?Numplay=4?MaxPlayers=32?NumPublicConnections=24?NumPrivateConnections=0?MinNetPlayers=1?BotSkill=6?bIsDedicated=true?bUsesStats=true?ForceRespawn=0?bShouldAdvertise=true?PureServer=1?bIsLanMatch=false?bAllowJoinInProgress=true?AdminName=xxx? -login=xxx -password=xxx -Log=myserver.log -unattended -nohomedir

                Comment


                  #9
                  please tell me where i can find NORMAL manual
                  how to install UT3 server on ubuntu linux??

                  when i install server and titan pack
                  ./UT3-linux-server-12172007.bin
                  ./UT3-linux-server-04292009.bin

                  i got
                  al@wow:/unreal/3/Binaries$ ./ut3-bin
                  segmentation failed

                  chmod and executable rights are normal , server eternity.chg.su no changes hardware or OS

                  i try run in any methods fail

                  home
                  Linux user-desktop 2.6.38-8-generic #42-Ubuntu SMP Mon Apr 11 03:31:24 UTC 2011 x86_64 GNU/Linux
                  server
                  Linux wow 2.6.38-6-generic #34-Ubuntu SMP Tue Mar 8 14:15:57 UTC 2011 x86_64 GNU/Linux

                  three sysadmins cannot run one UT3 server...

                  one or two years later i successfully install ut3 server on linux both home and server
                  but i forgot how i do it !!

                  Comment


                    #10
                    nobody knows????

                    i install linux kernel 3.0.0. but this not helped me


                    i got lot of fun with 4 reinstalls game on 2 machines with ubuntu 10.10 64bit
                    i cant change OS on servers , please help anybody&?

                    ut3-bin: 20: Syntax error: "(" unexpected (expecting ")")
                    unreal3@user-desktop:/media/F/E/Work/unreal/srv/Binaries$ sh ut3-bin Server DM-Deck?game=UTGameContent.UTGame.UTDeathmatch -login=учётка в GameSpy -password=пароль к учётке-multihome=ip-адрес сервера -Port=7777 -QueryPort=6500 -unattended
                    ut3-bin: 5: �4�G
                    4: not found
                    8�ln: 5: �.�_s��Tt��CB�7�=o�8�����& Pe�1�l�'>X��Ml�����V7�l
                    �p���J�HN5�:'4'DV=��~:j� �8��X�4o
                    ���4/ �5j=!v#Lhe��7,N��4iu� v)iBmH�����}lw95Y{k��4 �;���8��SI�*��AO�%?U : not found
                    ut3-bin: 5: ELF:�����a�QE�b���9��>_C��enVj��z
                    =02.HMTF Z6-)JS@+4"7D8 #1/*
                    q;wG{KtPfsm�[WuI�}p~oLl5��N�y�id�!(��c�?��6{�#�8��� F7HO�M�: not found
                    ut3-bin: 6: cannot open �S#��$��d�: No such file
                    ut3-bin: 6: �p���PO�:�IZOG+�O?��D�. �U�ns: not found
                    ut3-bin: 7: 
                    : not found
                    ut3-bin: 8: : not found
                    
                    $0ii
                    : not found
                    ut3-bin: 20: Syntax error: "(" unexpected (expecting ")")
                    unreal3@user-desktop:/media/F/E/Work/unreal/srv/Binaries$ ./ut3-bin
                    Ошибка сегментирования
                    unreal3@user-desktop:/media/F/E/Work/unreal/srv/Binaries$ ./ut3
                    Ошибка сегментирования
                    unreal3@user-desktop:/media/F/E/Work/unreal/srv/Binaries$

                    Comment


                      #11
                      i install server to my home directory and install all maps and characters from Gears of War
                      and copied to new place to server
                      all works

                      what i do wrong i don't know (((

                      where is the guru?

                      thanks for reading me

                      Comment

                      Working...
                      X