Announcement

Collapse
No announcement yet.

Set bot skill?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Set bot skill?

    So I setup my server, in the batch file I have the command botskill=1 but it's obvious when I'm in the server that they are not on 1. This is a windows server with patch 1.2. where are you supposed to set botskill? In an ini somewhere or do you set it with the botskill= in the command line?

    #2
    Try Difficulty=# or in the UTGame.ini, find and edit GameDifficulty=#

    Comment


      #3
      I set it with botskill=x in the command line.

      Comment


        #4
        Originally posted by Elohim View Post
        I set it with botskill=x in the command line.

        Hmmm, thats what I have in my .bat file but when I load the game it does not matter what number I set it to.

        This is what my bat file looks like.

        ne
        C:
        cd \Program Files\Unreal Tournament 3\binaries
        ut3.exe server dm-arsenal?Game=UTGame.UTDeathmatch?GameMode=1?numpla y=5?maxplayers=8?NumPublicConnections=8?NumPrivate Connections=0?NumOpenPublicConnections=8?NumOpenPr ivateConnections=0?bShouldAdvertise=True?bIsDedica ted=True?PureServer=1?timelimit=30?goalscore=41?bo tskill=1?AdminPassword=password-log=server.log -login=myserveryoz -password=password -unattended
        cd \Documents and Settings\[user]\My Documents\My Games\Unreal Tournament 3\UTGame\Logs
        copy server.log server.bak
        goto one


        Originally posted by Slaughter View Post
        Try Difficulty=# or in the UTGame.ini, find and edit GameDifficulty=#
        Thanks man, I can actually change the bots skill using gamedifficulty= in the utgame.ini. I tried difficulty= in the bat file and it gave me an error saying it wanted the botskill variable, however if I removed botskill= alltogether and did not replace it with anything it just used gamedifficulty in the ini without an error.

        Comment


          #5
          Originally posted by Slaughter View Post
          Try Difficulty=# or in the UTGame.ini, find and edit GameDifficulty=#
          Slaughter is absolutely correct... botskill has no effect on how the bots play in game - odd, I know.

          Earlier I posted more detail about this here.

          Comment


            #6
            Originally posted by dirrty[starbuck] View Post
            Slaughter is absolutely correct... botskill has no effect on how the bots play in game - odd, I know.

            Earlier I posted more detail about this here.

            I tried entering Difficulty=5 and when I did it, the server complained there was no botskill command what should my command line look like? Should it look like this?

            ut3.exe server dm-arsenal?Game=UTGame.UTDeathmatch?GameMode=1?numpla y=5?maxplayers=8?NumPublicConnections=8?NumPrivate Connections=0?NumOpenPublicConnections=8?NumOpenPr ivateConnections=0?bShouldAdvertise=True?bIsDedica ted=True?PureServer=1?timelimit=30?goalscore=41?difficulty=6?AdminPassword=password-log=server.log -login=myserveryoz -password=password -unattended
            cd \Documents and Settings\[user]\My Documents\My Games\Unreal Tournament 3\UTGame\Logs
            copy server.log server.bak
            goto one

            Ok, so when I replaced botskill= with difficulty= it did change the botskill but considering botskill does not seems to do anything I find it strange that I get this error.

            "Error: Requested localized string setting BotSkill was not found"

            Ok, one other thing.

            So I set difficulty= and that did seem to change it then I went to webadmin and changed difficulty= there, clicked change game and when it loaded it did not change the botskill at all. Is it possible to change botskill from webadmin?

            Comment


              #7
              Originally posted by btcomm View Post
              "Error: Requested localized string setting BotSkill was not found"

              Ok, one other thing.

              So I set difficulty= and that did seem to change it then I went to webadmin and changed difficulty= there, clicked change game and when it loaded it did not change the botskill at all. Is it possible to change botskill from webadmin?
              Keep BotSkill in your commandline along with Difficulty - Set them both to the same value.

              There is no ini setting for BotSkill which is why there is no place in the WebAdmin to set it permanently. When changing games through the WebAdmin BotSkill is set under Miscellaneous/Additional URL Variables. If your commandline contained ?BotSkill=5, then Additional URL Variables will already contain the BotSkill parameter.

              Comment


                #8
                Originally posted by btcomm View Post
                So I setup my server, in the batch file I have the command botskill=1 but it's obvious when I'm in the server that they are not on 1. This is a windows server with patch 1.2. where are you supposed to set botskill? In an ini somewhere or do you set it with the botskill= in the command line?
                I had the exact same problem. As other folks have said, Botskill does not work. Last night I tried setting the the Difficulty using WebAdmin to 50 just for yucks and that did it! The bots were awesome. I'm not sure what a good number is since the range for the entry is 0 - 9999 but 50 definitely worked.

                Comment


                  #9
                  "Error: Requested localized string setting BotSkill was not found"

                  You can just ignore this.

                  Comment


                    #10
                    I use ?BotSkill=4? This works fine on a Linux server, ver 1.2. I have not used web admin as yet, maybe that has something to do with it.

                    Code:
                    ut3 server vCTF-Containment?Game=UTGameContent.UTVehicleCTFGame_Content?GameMode=3?numplay=8?BotSkill=4?minnetplayers=1?maxplayers=12?PureServer=1?timelimit=30?goalscore=3?ServerName=Server-Name?ServerDescription=054000118000054000032000086000067000084000070000?AdminPassword=Admin-pass?bAllowJoinInProgress=True?bAllowInvites=True?bUsesPresence=True?forcerespawn=1?bIsLanMatch=False?bIsDedicated=True?bShouldAdvertise=True -login=GS-user -password=GS-pass -Port=7777 -unattended

                    Comment


                      #11
                      Originally posted by oldkawman1 View Post
                      I use ?BotSkill=4? This works fine on a Linux server, ver 1.2. I have not used web admin as yet, maybe that has something to do with it.
                      Odds are Icculus just decided to make the parm work on Linux.

                      Comment

                      Working...
                      X