Announcement

Collapse
No announcement yet.

Ingame Dedicated Server not being advertised

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Ingame Dedicated Server not being advertised

    I have been trying to start a server using the dedicated option ingame, and unfortunately the server is not shown in the browser, and you always need to connect manualy using the open ip command.
    The normal one works just fine and people and it is being advertised. Anyone ecountered anything similar?

    This is the log:
    ScriptLog: Cut down URL ?name=UniT8472?team=255?Class=?MaxPlayers=6?MinNet Players=0?NumPublicConnections=6?NumPrivateConnect ions=0?NumOpenPublicConnections=6?NumOpenPrivateCo nnections=0?bShouldAdvertise=True?bIsLanMatch=Fals e?bUsesStats=True?bAllowJoinInProgress=True?bAllow Invites=True?bUsesPresence=True?bAllowJoinViaPrese nce=True?bUsesArbitration=False?bIsDedicated=True? bIsListPlay=False?OwningPlayerName=?PingInMs=0?Ave rageSkillRating=1000.000000?EngineVersion=0?MinNet Version=0?Difficulty=2?PureServer=1?LockedServer=0 ?Campaign=0?ForceRespawn=0?CustomMapName=DM-Sentinel?Custo?GoalScore=30?TimeLimit=15?ServerDes cription=08200007900003200008500008400005100003200 0083000101000114000118000101000114000?NumPlay=3?ga me=UTGame.UTDeathmatch?alias=unit8472

    #2
    From the looks of it you have a really long cmdline w/ lots of unnecessary vars passed in. Could you copy&paste the command you're using to start the server if it's available, or otherwise what you just pasted there, but this time use CODE tags instead of QUOTE tags, so that any syntax/spacing error is more apparent. Also, make sure you've filled out [Engine.GameReplicationInfo] in UTGame\Config\UTGame.ini

    Comment


      #3
      Code:
      ?name=UniT8472?team=255?Class=?MaxPlayers=6?MinNetPlayers=0?NumPublicConnections=6?NumPrivateConnections=0?NumOpenPublicConnections=6?NumOpenPrivateConnections=0?bShouldAdvertise=True?bIsLanMatch=False?bUsesStats=True?bAllowJoinInProgress=True?bAllowInvites=True?bUsesPresence=True?bAllowJoinViaPresence=True?bUsesArbitration=False?bIsDedicated=True?bIsListPlay=False?OwningPlayerName=?PingInMs=0?AverageSkillRating=1000.000000?EngineVersion=0?MinNetVersion=0?Difficulty=2?PureServer=1?LockedServer=0?Campaign=0?ForceRespawn=0?CustomMapName=DM-RisingSun?CustomGameMode=UTGame.UTDeathmatch?GoalScore=20?TimeLimit=20?ServerDescription=085000084000051000032000083000101000114000118000101000114000?NumPlay=1?game=UTGame.UTDeathmatch?alias=unit8472
      it this one good?
      I don't understant why the undedicated server works just fine, and this one, doesn't.
      thanks for the reply.

      Comment


        #4
        solved the problem by using a .batch file with the apropiate commands, who has the same issues gief a pm.

        Comment


          #5
          Originally posted by Unit8472 View Post
          Code:
          ?name=UniT8472?team=255?Class=?MaxPlayers=6?MinNetPlayers=0?NumPublicConnections=6?NumPrivateConnections=0?NumOpenPublicConnections=6?NumOpenPrivateConnections=0?bShouldAdvertise=True?bIsLanMatch=False?bUsesStats=True?bAllowJoinInProgress=True?bAllowInvites=True?bUsesPresence=True?bAllowJoinViaPresence=True?bUsesArbitration=False?bIsDedicated=True?bIsListPlay=False?OwningPlayerName=?PingInMs=0?AverageSkillRating=1000.000000?EngineVersion=0?MinNetVersion=0?Difficulty=2?PureServer=1?LockedServer=0?Campaign=0?ForceRespawn=0?CustomMapName=DM-RisingSun?CustomGameMode=UTGame.UTDeathmatch?GoalScore=20?TimeLimit=20?ServerDescription=085000084000051000032000083000101000114000118000101000114000?NumPlay=1?game=UTGame.UTDeathmatch?alias=unit8472
          it this one good?
          I don't understant why the undedicated server works just fine, and this one, doesn't.
          thanks for the reply.
          There is still alot in that commandline that doesn't need to be here, check this thread http://gearsforums.epicgames.com/sho...d.php?t=591920 Also shouldn't it start with

          UT3.exe Server <mapname>?

          Comment


            #6
            Code:
            ut3.exe server DM-Deck?Game=UTGame.UTDeathmatch?GameMode=0?minnetplayers=0?PureServer=1?timelimit=15?AdminPassword=11111?bPlayersMustBeReady=False?bAllowJoinInProgress=True?bAllowInvites=True?bUsesPresence=True?bIsLanMatch=false?bIsDedicated=True?bShouldAdvertise=True -login=profildeserver -password=server -Port=7777 -QueryPort=12005 -log=../../Binaries/serverlog.txt -nohomedir -unattended
            this is the command i am using now, works like a charm.

            Comment

            Working...
            X