Announcement

Collapse
No announcement yet.

Creating a web admin server

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    I use webadmin v1.1 – 2008-04-06 or v1.0 – 2008-03-24

    unpack it to my ../ut3-dedicated/

    My ../ut3-dedicated/UTGame/Config/UTWeb.ini

    ...
    ListenPort=5190
    MaxConnections=18
    ExpirationSeconds=86400
    bEnabled=True
    ...

    when start server in Log i have

    ...
    ScriptLog: -- MAPVOTE is ENABLED!!!!!
    ScriptLog: Webserver is not enabled. Set bEnabled to True in Advanced Options.
    ScriptLog: Destroying WebServer
    Log: GAME PATH IS UTDeathmatch
    ...

    Why?

    Leave a comment:


  • replied
    that's not a WebAdmin error, you are probably running some other webservice on port 80, either shut down that server or use a different port for the webadmin.

    check the server's log to see if it could bind the configured port

    Leave a comment:


  • replied
    Ok, I follow this and my browser says "You don't have permission to access / on this server.". I know I'm doing something stupid, but I can't figure out what.

    I enter in the address of the computer, http://192.168.1.103:80 and it just kicks back this error. I can't think of what permissions I need to set on the host computers that would allow me to connect.

    If I could just hit the login page, I would feel better about what I might be doing wrong.

    Leave a comment:


  • replied
    Got the webadmin all installed, after I found that it had put the config files in docs and settings.

    However I can not log into it, says "Invalid Credentials"

    Now I have specified a password in teh start up in my batch script and edited the files where apprioate according to the guide.

    Any ideas?

    Kimbie

    Leave a comment:


  • replied
    12. Save the file, restart your UT3 server (making sure ?Adminpassword=X is set)
    hi thanks for the help in setting up my server with this guide, but i ran into an "IO" error concerning step 12.
    at first i thought mabe it's an extra string in some ini file when i run a dedicated server, so i googled it some more and like 90mins later, I realised it refers to the commanline string when starting the dedicated server with a batch file or the command prompt.

    anyway after countless attemts to set my admin password on my retail version i thought maybe they ment that i could also add it to my start-up shortcut from where i run the game, i tried it and it worked.

    the point is could the author of this guide please add it into those steps @ point 12 to avoid confusion for the next poor sap that needs more details than the one line in the guide

    for copy paste ease:
    12.B alternatively you can add the password to the starup shortcut of your retail version, in the target box like so:
    "C:\Program Files\Unreal Tournament 3\Binaries\UT3.exe" ?adminpassword=youradminpassword
    regards
    BioG

    Leave a comment:


  • replied
    I'm w/ gameservers.com and I got webadmin working after using port 9009 & setting bhttpauth to true

    Leave a comment:


  • replied
    Okay I've done all the instructions. I checked my logs and I see this:

    ScriptLog: Web Server Created http://63.209.32.176:8080 Port: 8080 MaxCon 18 ExpirationSecs 86400 Enabled True

    When I open up either FireFox or IE, the webadmin will not pop up.

    Using this http://63.209.32.176:8080/ Also tried http://63.209.32.176:8080/ServerAdmin/ and http://63.209.32.176:8080/UTWebAdmin/

    still nothing pops up.


    I put this in UTWeb.ini

    [UWeb.WebServer]
    bEnabled=true
    ListenPort=8080

    Any suggestions on what I'm doing wrong?


    Oh by the way I'm with Gameservers.com

    I do have the adminpassword line in my start up command line as well.

    Leave a comment:


  • replied
    Originally posted by nDP::Deathmaker View Post
    Put the admin password in your server startup command line ?AdminPassword=mypassword
    What file would that command go into? Are you talking about the shortcut to your ut3.exe file you put that in? Would this apply to windows as well as linux?

    Leave a comment:


  • replied
    Originally posted by nDP::Deathmaker View Post
    Put the admin password in your server startup command line ?AdminPassword=mypassword
    Is it normal that i canĀ“t find that?? Which file then btw?

    Leave a comment:


  • replied
    Put the admin password in your server startup command line ?AdminPassword=mypassword

    Leave a comment:


  • replied
    I dont know where to input the password in the ini files to enter as admin.. Some help please?

    Leave a comment:


  • replied
    Originally posted by Crzyhomer View Post
    11. Make the following changes to the file:
    Code:
        [WebAdmin.WebAdmin]
        bHttpAuth=true
    
        [WebAdmin.BasicWebAdminAuth]
        RequireUsername=Admin
    These changes are absolutely NOT required.
    bHttpAuth will set the form based login to a HTTP Authentication log in. Both are equally (in)secure. But the form based log in will allow you to log out, HTTP Authentication is cached in your browser for as long as the browser is running. Logging out does not always make the browser forget this information (it appears to work in Firefox, but not in MSIE).

    RequireUsername can be anything you like, or empty. When it's empty any name is allowed.

    Leave a comment:


  • replied
    Well - still there is the UTWebAdmin.ini - problem. I have neither UTWebAdmin.ini nor DefaultUTWebAdmin.ini. I am using the linux dedicated server.

    Also the WebAdmin Files seem to be completly missing. have to download them seperately. (http://ut3webadmin.elmuerte.com/)

    And btw: Great having the WebAdmin Tool back ;-)

    Leave a comment:


  • replied
    Yes Finally

    We can really host and play the game like it should have been almost 2 years ago now

    Hope it will start catching on now that it is actually playable!!

    thx for the hard work

    Leave a comment:


  • replied
    Yes, once again, thanks so much for bringing this to UT3. It works fantastic.

    Leave a comment:

Working...
X