Announcement

Collapse
No announcement yet.

How to setup UT3 redirect and clarify it is working!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #46
    What you have in [IpDrv.TcpNetDriver] is fine, Do you have -Unattended in your commandline? and what file does the connection failed error refer to?

    Also, if you can use your redirect server from a browser then your redirect is online, your settings for redirect seem fine so it is safe to say your clients are being redirected to it. I have had problems with some files not being redirected due to their name, I'll explain more when I know what file it isn't redirecting.

    Comment


      #47
      I have -Unattended in my commmand line. I don't know what that is for though.

      The file is AdvancedScoreboardV06.u.uz3 and the spelling looks the same in the uncompressed one that's on the game server. Took some mods out and tried to download just a custom map and the problem persists. = /

      Comment


        #48
        Okay did some more checking and now the redirect is working fine. Its just that file advanced scoreboard that wont take off the redirect. Any idea why? The spellings match.

        I'm thinking its the .u file AdvancedScoreboardV06.u.uz3 that the client needs to download

        so that's what I compressed and put on redirect.

        Comment


          #49
          There should also be a UI_Scenes_Scoreboards_AdvancedV06.upk file in Published\CookedPC\UI\. Also all the _LOC_ files on your redirect don't need to be there, they don't get pushed.

          Comment


            #50
            the .upk downloads in lightning speed its the advancedscoreboard.u that's draggin *** = / Well I'm just happy the redirect does indeed work. Thanks for the tip. I appreciate it.

            JC

            Comment


              #51
              I seem to be having trouble with redirect
              [IpDrv.TcpNetDriver]
              AllowDownloads=False
              ConnectionTimeout=60.000000
              InitialConnectTimeout=60.000000
              AckTimeout=1.0
              KeepAliveTime=0.2
              MaxClientRate=15000
              MaxInternetClientRate=10000
              RelevantTimeout=5.0
              SpawnPrioritySeconds=1.0
              ServerTravelPause=4.0
              NetServerMaxTickRate=30
              LanServerMaxTickRate=35
              DownloadManagers=IpDrv.HTTPDownload
              DownloadManagers=Engine.ChannelDownload
              NetConnectionClassName=IpDrv.TcpipConnection
              IdleServerTickRate=30

              [IpDrv.HTTPDownload]
              RedirectToURL=http://tmfcclan.artofwarcentral.com/ut3/
              UseCompression=False

              is this right for aowc redirect

              Comment


                #52
                help

                I seem to be having trouble with redirect
                [IpDrv.TcpNetDriver]
                AllowDownloads=False
                ConnectionTimeout=60.000000
                InitialConnectTimeout=60.000000
                AckTimeout=1.0
                KeepAliveTime=0.2
                MaxClientRate=15000
                MaxInternetClientRate=10000
                RelevantTimeout=5.0
                SpawnPrioritySeconds=1.0
                ServerTravelPause=4.0
                NetServerMaxTickRate=30
                LanServerMaxTickRate=35
                DownloadManagers=IpDrv.HTTPDownload
                DownloadManagers=Engine.ChannelDownload
                NetConnectionClassName=IpDrv.TcpipConnection
                IdleServerTickRate=30

                [IpDrv.HTTPDownload]
                RedirectToURL=http://tmfcclan.artofwarcentral.com/ut3/
                UseCompression=False

                is this right

                Comment


                  #53
                  Try under [IpDrv.TcpNetDriver] changing AllowDownloads=True

                  Comment


                    #54
                    Originally posted by Slaughter View Post
                    Try under [IpDrv.TcpNetDriver] changing AllowDownloads=True
                    That will only make the server push the file not the redirect. You should set this back to true once redirect is found to be working correctly.

                    @ {tmfc}die-all: Your settings seem correct, do you get a error message with them settings ? (like the one in 1st post)

                    Comment


                      #55
                      i did but the sever downloaded the file not the redirect
                      set to false i get connect falied

                      Comment


                        #56
                        reply

                        i did but the sever downloaded the file not the redirect
                        set to false i get connect falied

                        Comment


                          #57
                          aowc fixed the prodlum thanx

                          Comment


                            #58
                            Originally posted by brdempsey69 View Post
                            What about a custom character? Is there a line that I need to add to the UTEngine.ini to make sure any connecting clients can get the custom character .upk file downloaded to them so that they can see that custom character on the server?

                            For example, I have Evil Engine's Xan Kriegor model on both my client main rig and on my server and I can see him just fine when he's in the game.

                            Sorry, I don't mean to hijack this thread or anything. I'm just wondering if anyone's tried the compression and redirect techniques listed in this thread for custom characters. I've verified it does work for maps.
                            Originally posted by AZ-{OVGY} View Post
                            I'm going to check this for you as so far I haven't bothered adding any custom characters to my server so am unsure. I believe they will push though providing they are installed correctly.

                            Anyone know the answer to this? i tried installing the model same as it installs on the client and cant get the models to push to the players... any help appreciated! thx!!

                            Comment


                              #59
                              This is probably a dumb question but... does the folder on the redirect server have to be called "ut3"? I see that's what everyone is using but I'm not and I'm having problems.

                              Here's why I'm asking instead of testing it myself... my client "play" machine is on the same subnet as my redirect server (both in my apartment). But, in the utengine.ini i have my WAN IP as the redirect url. When I test, I download maps very quickly, but my others do not. So, I'm wondering if maybe my router is to blame. I have port 80 forwarded to my redirect server and I can browse it on the internet http://69.126.138.122/~prograham/ut3redirect/.

                              How am I able to download fast while others do not?

                              in my utengine.ini:
                              [IpDrv.TcpNetDriver]
                              AllowDownloads=False (because I'm trying to test redirect)
                              ConnectionTimeout=30.0
                              InitialConnectTimeout=200.0
                              AckTimeout=1.0
                              KeepAliveTime=0.2
                              MaxClientRate=15000
                              MaxInternetClientRate=10000
                              RelevantTimeout=5.0
                              SpawnPrioritySeconds=1.0
                              ServerTravelPause=4.0
                              NetServerMaxTickRate=30
                              LanServerMaxTickRate=35
                              DownloadManagers=IpDrv.HTTPDownload
                              DownloadManagers=Engine.ChannelDownload
                              NetConnectionClassName=IpDrv.TcpipConnection
                              IdleServerTickRate=30

                              and at end of file is....

                              [AppCompat]
                              MeasuredCPUScore=645.342834
                              CompatLevelComposite=0
                              CompatLevelCPU=0
                              CompatLevelGPU=0
                              RedirectToURL=http://69.126.138.122/~prograham/ut3redirect/
                              UseCompression=False

                              [IpDrv.HTTPDownload]
                              RedirectToURL=http://69.126.138.122/~prograham/ut3redirect/
                              UseCompression=False


                              ANY HELP GREATLY APPRECIATED. Oh, and my server (game server, not the redirect) is rented from gameservers.com and my apartment has great upload speed of 2111kbps.

                              Comment


                                #60
                                No, the folder doesn't have to be named UT3.

                                If I click on the link you have provided I cannot browse the folder. While I can't provide a reason why it isn't working other than perhaps your ISP is blocking port 80 (most don't want home users running web servers), you can save your self headaches and just use a public redirect.

                                Comment

                                Working...
                                X