Announcement

Collapse
No announcement yet.

How to setup UT3 redirect and clarify it is working!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #31
    Yes it is there.
    [Engine.Engine]
    NetworkDevice=IpDrv.TcpNetDriver
    ConsoleClassName=UTGame.UTConsole
    GameViewportClientClassName=UTGame.UTGameViewportC lient

    Comment


      #32
      Redirect speeds do vary dependent on how much load is on the redirect server. Less load means faster speeds and heavy load means slower speeds, who is your redirect with?

      Comment


        #33
        Originally posted by Corey View Post
        Thanks.
        I tried out the Cath map which was 24.9 MB not counting the other two files in its folder which are
        DM-Cath_LOC_int.upk
        DM-Cath.ut3
        DM-Cath.ini

        After it compressed it, I ended up with one file called
        DM-Cath.ut3.uz3
        and it is 22.6 MB.

        I take it the program did also include the upk and ini files when it compressed the ut3 one?

        It only saved about 2.3 MB, I thought it would be much more space it saved than that.

        PS, I see there is a drop down box in the compression program, I guess I was suppose to include all the files, not just the .ut3 one?
        The .ini and LOC_int.upk wouldn't be sent down by the redirect anyway so you wouldn't need to compress and upload those. Note: You should compress other types of .upk files though.

        The reason you only saved 2.3MB is because 'cooked' maps are already sort-of compressed and because the UT3 compression code isn't super efficient like a WinZip or rar program would compress them into those formats.

        Comment


          #34
          Originally posted by AZ-{OVGY} View Post
          Redirect speeds do vary dependent on how much load is on the redirect server. Less load means faster speeds and heavy load means slower speeds, who is your redirect with?
          www.gamemaps.nl
          But I think the problem is that when I set the allowdownloads=False and I remove all my files from the redirect server the download still starts.
          I should get a error when things work fine. And I restart the server after every change made.

          Comment


            #35
            Yes, you are quite right. Do you have -unattended in your commandline, are your config files getting reverted to defaults? I ask this because someone else in another thread who had your problem found that their config files where being overwritten with default values. -unattended stops this from happening. Other than that I am a bit unsure as to why your gameserver is deciding to completely ignore the values in [IpDrv.TcpNetDriver] section of your .ini

            Comment


              #36
              I asked the server provider if he used it in the command line. But I think we got something here. Thanks very much and I will let you know his answer

              Comment


                #37
                I wouldn't recommend using compression for the redirect at this time. The bandwith savings are minimal and according to my server logs the majority of clients are still asking for the wrong file (mapname.ut3.uz2 instead of mapname.ut3.uz3).

                Comment


                  #38
                  Originally posted by SirTobi View Post
                  I wouldn't recommend using compression for the redirect at this time. The bandwith savings are minimal and according to my server logs the majority of clients are still asking for the wrong file (mapname.ut3.uz2 instead of mapname.ut3.uz3).
                  I have also had this, I believe it is older client versions that are doing this for some reason, unfortunately the user agents in my logs are always the same for all versions of ut3 so it is hard to pinpoint which versions. What I can say is that everyone who uses my server (with compressed files) that is patched to 1.2 has no problems with redirect. The bandwidth savings too are small, however they are still usefull. Especially when you consider that if you save 2-4 MB on each map and you play twenty maps a night you will be saving 40-80MB of downloading, which to some can be alot.

                  Comment


                    #39
                    Originally posted by AZ-{OVGY} View Post
                    What I can say is that everyone who uses my server (with compressed files) that is patched to 1.2 has no problems with redirect. The bandwidth savings too are small, however they are still usefull. Especially when you consider that if you save 2-4 MB on each map and you play twenty maps a night you will be saving 40-80MB of downloading, which to some can be alot.
                    Sure, 1.2 works fine, but lots of people don't seem to have this patch yet, so I decided to turn compression off. I'd rather waste some bandwith if this allows more people to join the game.

                    Comment


                      #40
                      AZ-{OVGY} Thanks for the tip. The redirect is working great now. The customMaps are placed in UTGame\CookedPC\CustomMaps. Mutators go in UTGame\CookedPC\Script and the ini files in /UTGame/Config. Thank you very much. O and I use compression as well

                      Comment


                        #41
                        If you have specified a port in RedirectToURL and redirect is not working, then see: http://forums.epicgames.com/showthread.php?t=605665

                        Comment


                          #42
                          I'm having similar problems with redirect. The only thing is when I set it to AllowDownloads=false I do get connection failed. So that's telling me the redirect isn't working but at least the server is directing clients to look elsewhere for the files and not downloading from game server. Here is the link to my redirect http://www.osp-team.com/ut3redirect/

                          It works fine in browser and when I download from browser it allows me and is very fast.

                          So what is the problem? Here's some of my .ini

                          [IpDrv.HTTPDownload]
                          RedirectToURL=http://www.osp-team.com/ut3redirect/
                          ProxyServerPort=
                          ProxyServerHost=
                          UseCompression=True

                          [Engine.Engine]
                          NetworkDevice=IpDrv.TcpNetDriver
                          ConsoleClassName=UTGame.UTConsole
                          GameViewportClientClassName=UTGame.UTGameViewportC lient
                          LocalPlayerClassName=Engine.LocalPlayer

                          Is it a port problem? I also tried gameserver redirect and same problem.

                          This is my servers startup command line btw

                          server CTF-Coret?Mutator=BiaVote.BiaVoteMutator,ABTv1_3.ABTMu tator,ABTv1_3.ZPInstagib,UTGame.UTMutator_NoTransl ocator,AdvancedScoreBoardV06.AdvancedScoreboardMut ator?bEnableDodging=true?AdminPassword=<>?maxplayers=12? -multihome=63.209.32.176 -port 7777 -unattended -login=OSPclan -password=<> -log=GameServers.log -nohomedir

                          Comment


                            #43
                            If you've set AllowDownloads=false, that means that the file will not be sent down from the gameserver if it can't be found on the redirect (or there's a problem with the redirect).

                            Try ProxyServerPort=3128 (yours is blank), as that is the default.

                            Comment


                              #44
                              Originally posted by Slaughter View Post
                              Try ProxyServerPort=3128 (yours is blank), as that is the default.
                              That isn't needed to get redirect working.

                              @ jcantu20 Can you make sure that,

                              [IpDrv.TcpNetDriver]
                              DownloadManagers=IpDrv.HTTPDownload

                              is set in UTEngine.ini

                              Comment


                                #45
                                [IpDrv.TcpNetDriver]
                                DownloadManagers=IpDrv.HTTPDownload

                                ..is set on the UTEngine.ini

                                [IpDrv.TcpNetDriver]
                                AllowDownloads=False
                                ConnectionTimeout=30.0
                                InitialConnectTimeout=200.0
                                AckTimeout=1.0
                                KeepAliveTime=0.2
                                MaxClientRate=15000
                                MaxInternetClientRate=10000
                                RelevantTimeout=5.0
                                SpawnPrioritySeconds=1.0
                                ServerTravelPause=4.0
                                NetServerMaxTickRate=30
                                LanServerMaxTickRate=35
                                DownloadManagers=IpDrv.HTTPDownload
                                DownloadManagers=Engine.ChannelDownload
                                NetConnectionClassName=IpDrv.TcpipConnection
                                IdleServerTickRate=30

                                There's a whole bunch of other stuff with that though. Am I suppose to have only DownloadManagers=IpDrv.HTTPDownload under [IpDrv.TcpNetDriver] or as long as its in there?



                                I set Allowdownloads=False to test redirect only.

                                I just can't figure why the game server isn't directing clients to the redirect or is it? And perhaps can't read the files in my webserver? Its hard to tell cause with Allowdownloads=False , I don't know for sure if its sending clients to redirect before it decides to reject clients.

                                Comment

                                Working...
                                X