Announcement

Collapse
No announcement yet.

REDIRECT STILL = Won't Work!!!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    REDIRECT STILL = Won't Work!!!

    Why is this so difficult? Can someone help me!!!! Please...

    Server IP address = 8.12.69.86

    My Redirect http link = http://MYredirect.clanservers.com/

    UTEngine.ini =

    [IpDrv.TcpNetDriver]
    AllowDownloads=False (If =TRUE you DL from the Game Server always Yes? And I tried both ways T & F)
    ConnectionTimeout=30.0
    InitialConnectTimeout=200.0
    AckTimeout=1.0
    KeepAliveTime=0.2
    MaxClientRate=20000
    MaxInternetClientRate=25000
    RelevantTimeout=5.0
    SpawnPrioritySeconds=1.0
    ServerTravelPause=4.0
    NetServerMaxTickRate=40
    LanServerMaxTickRate=45
    DownloadManagers=IpDrv.HTTPDownload
    DownloadManagers=Engine.ChannelDownload
    NetConnectionClassName=IpDrv.TcpipConnection

    [IpDrv.HTTPDownload]
    RedirectToURL=http://MYredirect.clanservers.com/ (You can go here, click on any file and it will DL to your PC=So it's working Yes?)
    ProxyServerHost=
    ProxyServerPort=
    UseCompression=False

    So why is my redirect still not working for custom maps & mutators!

    UPDATED::: I AM RUNNING THE V1.1 ON MY SERVER! DO I NEED THE BETA2 PATCH TO GET THE REDIRECT WORKING? IF SO THAT'S MY PROBLEM.....

    #2
    Which folder you have all the custom maps in? I couldnt get my redirect to work for a couple days a well and I know how it can get flustrated when you think its all set up right but still wont work.

    Here is the location of my custom maps

    C:\.....................\My Documents\My Games\Unreal Tournament 3\UTGame\Published\CookedPC\CustomMaps

    This is my ini

    [IpDrv.TcpNetDriver]
    AllowDownloads=True
    ConnectionTimeout=30.0
    InitialConnectTimeout=200.0
    AckTimeout=1.0
    KeepAliveTime=0.2
    MaxClientRate=15000
    MaxInternetClientRate=10000
    RelevantTimeout=5.0
    SpawnPrioritySeconds=1.0
    ServerTravelPause=4.0
    NetServerMaxTickRate=30
    LanServerMaxTickRate=35
    DownloadManagers=IpDrv.HTTPDownload
    DownloadManagers=Engine.ChannelDownload
    NetConnectionClassName=IpDrv.TcpipConnection
    IdleServerTickRate=30

    [IpDrv.HTTPDownload]
    RedirectToURL=http://mydomain.com/
    UseCompression=False
    ProxyServerPort=
    ProxyServerHost=

    Hope it helps!!

    www.x-cade.com

    Comment


      #3
      Originally posted here http://gearsforums.epicgames.com/sho...=596807&page=4

      If you're having problems with redirect 1st of all clarify your redirect server is working, do this by adding this to UTEngine.ini

      [IpDrv.TcpNetDriver]
      AllowDownloads=False

      (This will stop the server pushing the file itself so if it can't find it on redirect you'll get an error. If set to true it will check redirect and if it can't find file there for whatever reason it will push file from the server. You don't want it to do this as you are checking your redirect is actually working.) Then add this (again UTEngine.ini)



      [IpDrv.HTTPDownload]
      RedirectToURL=http://pathtoredirect/
      UseCompression=False (if using official patch 1.1) or True (if using patch 2 beta 1 and are using compressed files)

      If you get an error when trying to download the map (it won't even start downloading, the error will come straight away) then your redirect isn't working for some reason (maybe redirect server offline or your settings are wrong somewhere). If you don't get an error and download starts and is slow then the problem is your redirect and there is nothing you can do about that other than change it.

      Once you have checked this and your redirect is working (but slowly) change AllowDownloads=False back to true and look for a better redirect.

      Hope this helps.

      Originally posted by clark kent View Post
      [IpDrv.TcpNetDriver]
      AllowDownloads=False (If =TRUE you DL from the Game Server always Yes? And I tried both ways T & F)
      Wrong, if set to true server will redirect clients first, if file cannot be found on redirect (maybe not been uploaded or redirect server offline) then UT3 server will send file itself. False means it will only use redirect server, if file cannot be found you will get an error saying this.

      Comment


        #4
        Yes I forgot , you need to have at least the pach 1.1 in order to make it work, Client and server. What kind of error you getting or what happened when you trying to get on the server?

        Comment


          #5
          I've made a thread about setting up redirect and checking it works, go here http://gearsforums.epicgames.com/sho...d.php?t=603110 I have added a little more detail.

          Comment


            #6
            Click on this link http://myredirect.clanservers.com/, then click on any file and they zoom down to your desktop so the redirect is working fine. I run V1.1 on my UT3 server and when I select a map that is NOT on my local system nothing happens, it just seems to time out. My settings are listed above but I will go back and check a few things now... Thx

            I don't need to have the www in there do I? I don't think I do... Hmm... Let me VERIFY that my Server Host has upgraded to V1.1 on the server for sure! That's the only thing it can be!

            Comment


              #7
              Next thing I would check where your custom maps folder is located.

              Comment


                #8
                Add maps to \Unreal Tournament 3 (Dedicated Server)\UTGame\Published\CookedPC\CustomMaps

                Comment


                  #9
                  And remember if your redirect server is Linux-based the file names are case sensitive. E.G. if you have DM-DeckROCKS on the game server and in your map list; and the file is named DM-DeckRocks on the redirect then they are not considered to be the same.

                  Comment


                    #10
                    good point on the linux part. I've had to check my var/log/httpd/error_log file until I got things correct. It'll show u misspelled maps, case issues, or file you forgot to upload.

                    Comment


                      #11
                      A bit of advice to you guys posting your redirect links on forums. You dont want to do that, not if you dont want it to become a public redirect for other servers and so on, and yes people will do it. Just some advice, take it for what its worth.

                      Comment


                        #12
                        Good point, not that I would really mind anyway, changed.....

                        Comment


                          #13
                          Originally posted by clark kent View Post
                          Good point, not that I would really mind anyway, changed.....
                          You will when your redirect speed gets slower and slower. You've also forgotten to change one of the links you posted in this thread (1st page post 6).

                          Comment


                            #14
                            Originally posted by clark kent View Post
                            Good point, not that I would really mind anyway, changed.....
                            Originally posted by AZ-{OVGY} View Post
                            You will when your redirect speed gets slower and slower.
                            And, when your hosting service charges you for excess (or excessive) bandwidth usage.

                            Comment


                              #15
                              I was just told that the redirect on UT3 Patch v1.1 does not work and that I need the Beta2 patch at least. Is that true?

                              If so that's my problem! The thing is I will need to rebuild my server again if I put the Beta 2 patch on there so I think I will just wait it out...

                              IF THAT IS ACCURATE ABOUT NEEDING THE LATEST BETA2 PATCH. CAN SOMEONE CONFIRM THAT FOR ME PLEASE?

                              Comment

                              Working...
                              X