Announcement

Collapse
No announcement yet.

Detected negative delta time crash - Linux - Intel CPU (Fixed)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Detected negative delta time crash - Linux - Intel CPU (Fixed)

    Hi All,

    My Linux dedicated server keeps crashing (even with no players on) with 'Detected negative delta time - on AMD systems please install http://www.amd.com/us-en/Processors/..._13118,00.html'.
    Sometimes the server also runs for a few maps before crashing.

    I have installed the test binary (it also crashed with the other binary) and have rebooted since installation.

    Here is a log extract:

    Code:
    Log: Bringing World vCTF-Sandstorm.TheWorld up for play (30) at 2008.01.29-22.15
    .48^M
    ScriptLog: -- MAPVOTE is ENABLED!!!!!^M
    Log: Bringing up level for play took: 1.848954^M
    Log: ########### Finished loading level: 11.049113 seconds^M
    Init: Game engine initialized^M
    Log: Initializing Game Engine Completed^M
    Log: FSTUNClient resolved stunserver.org (192.245.12.229)^M
    Log: GAME PATH IS UTVehicleCTFGame_Content^M
    ^M
    appError called: ^M
    Detected negative delta time - on AMD systems please install http://www.amd.com/
    us-en/Processors/TechnicalResources/0,,30_182_871_13118,00.html^M
    Critical: appError called:^M
    Critical: Detected negative delta time - on AMD systems please install http://ww
    w.amd.com/us-en/Processors/TechnicalResources/0,,30_182_871_13118,00.html^M
    Detected negative delta time - on AMD systems please install http://www.amd.com/
    us-en/Processors/TechnicalResources/0,,30_182_871_13118,00.html^M^M
    ^M^M
    ^M
    ^M
    Exiting due to error^M
    Exit: Executing UObject::StaticShutdownAfterError^M
    Detected negative delta time - on AMD systems please install http://www.amd.com/
    us-en/Processors/TechnicalResources/0,,30_182_871_13118,00.html^M
    ^M
    Success - 0 error(s), 0 warning(s)^M
    ^M
    Execution of commandlet took:  911.73 seconds^M
    Log: 128337 objects as part of root set at end of initial load.^M
    Log: 0 out of 0 bytes used by permanent object pool.^M
    Log: Initializing Engine...^M
    Init: UEngine initialized^M
    Log: Looking for DLC...^M
    Log: Object size..............: 60^M
    Log: Actor size...............: 436^M
    Log: ActorComponent size......: 88^M
    Log: PrimitiveComponent size..: 448^M
    Log: Performing DNS lookup for stunserver.org^M
    Log: Browse: VCTF-Sandstorm?Name=Player?team=255?AdminName=xxxx?AdminPassword=xxxx?numplay=8?botskill=3?maxplayers=16^M
    Log: LoadMap: VCTF-Sandstorm?Name=Player?team=255?AdminName=xxxx?AdminPassword=xxxx?numplay=8?botskill=3?maxplayers=16^M
    Log: ClearAllAnimSetLinkupCaches - Took 13.98ms^M
    Init: Sockets: Socket queue 262142 / 262142^M
    Log: NetMode is now 1^M
    Log: Primary PhysX scene will be in software.^M
    Log: Creating Primary PhysX Scene.^M
    Log: Novodex Terrain Creation (Terrain_0): 0.330000 ms^M
    Log: Bringing up level for play took: 0.089268^M
    Log: ########### Finished loading level: 9.021705 seconds^M
    Init: Game engine initialized^M
    Log: Initializing Engine Completed^M
    Log: ^M
    Developer Backtrace:^M
    Log: [ 1]  ./ut3-bin [0x8d44a62]^M
    Log: [ 2]  /lib/libpthread.so.0 [0x40049825]^M
    Log: [ 3]  [0x40017420]^M
    Log: [ 4]  ./ut3-bin [0x804bf08]^M
    Log: [ 5]  /lib/libc.so.6(__libc_start_main+0xc6) [0x400a7e36]^M
    Log: [ 6]  ./ut3-bin [0x804adc1]^M
    Exit: Exiting.^M
    Exit: Name subsystem shutting down^M
    This is running on an Intel CPU, so I dont think I should install the patch! Can anyone help?

    #2
    ive got
    Code:
    Log:     licensee Unreal Engine 3 Licensee
    Log:     project  Unreal Engine 3 Project
    Log: GConfig::Find has loaded file:  ..\Engine\Localization/int/Core.int
    Log: GConfig::Find has loaded file:  ..\Engine\Localization/int/Engine.int
    Log: Loaded shader cache RefShaderCache-PC-D3D-SM3.CacheObject: 24748 shaders(5 legacy, 0 redundant), 2548 materials
    Log: GConfig::Find has loaded file:  ..\Engine\Localization/int/UnrealScriptTest.int
    Log: GConfig::Find has loaded file:  ..\UTGame\Localization/int/UTGame.int
    Log: GConfig::LoadFile has loaded file:  ../UTGame/Config/UTWeapon.ini
    Log: GConfig::LoadFile has loaded file:  ../UTGame/Config/UTCustomChar.ini
    Log: GConfig::LoadFile associated file:  ../UTGame/Config/UTMap.ini
    Uninitialized: appRequestExit(0)
    Uninitialized: 
    Developer Backtrace:
    Uninitialized: [ 1]  ./ut3-bin [0x8d44a12]
    Uninitialized: [ 2]  /lib/obsolete/linuxthreads/libpthread.so.0 [0x29055706]
    Uninitialized: [ 3]  [0xbfbfffbf]
    Uninitialized: [ 4]  /lib/obsolete/linuxthreads/libpthread.so.0 [0x290508e9]
    Uninitialized: [ 5]  /lib/obsolete/linuxthreads/libpthread.so.0(pthread_cond_wait+0x15f) [0x2904e26f]
    Uninitialized: [ 6]  ./ut3-bin [0x8d42e98]
    Uninitialized: [ 7]  ./ut3-bin [0x8d429fa]
    Uninitialized: [ 8]  ./ut3-bin [0x8d42a6d]
    Uninitialized: [ 9]  /lib/obsolete/linuxthreads/libpthread.so.0 [0x2904eb8a]
    Uninitialized: [10]  /lib/obsolete/linuxthreads/libc.so.6(__clone+0x5a) [0x29161e5a]
    Uninitialized: Exiting.
    Uninitialized: Name subsystem shutting down
    Uninitialized: Log file closed,
    no matter what gametype,no mater if someplay,server die everyday and no fix for it
    tho i dont have any AMD messages in log

    Comment


      #3
      I've seen this solution before, here is what was tried with success:

      Try this:

      Code: echo 1 > /proc/sys/xen/independent_wallclock

      Then running ntpd. If there's clock instability on the host, this should avoid it. Note that you must enable the independent wallclock option before ntpd starts on boot. This may entail creating additional init.d scripts, or just adding it to /etc/init.d/ntp-server or whatever the file may by on your distro.

      Comment


        #4
        Did it work? Do you need more explicit instructions about setting up ntpd?

        Comment


          #5
          I dont have root on my box, but I have sent the instructions to the administrator. I'll let you know the outcome as soon as I can. Thanks for your help.

          Comment


            #6
            My administrator has now implemented the fix as you recommended. And it has fixed the problem! Thank you!

            Comment

            Working...
            X