Announcement

Collapse
No announcement yet.

Starting A Dedicated Server?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Starting A Dedicated Server?

    First id like to say hello to all and i love this game. well im 43 years old and i feel stupid here! i have no touble at all starting dedies in other games but this one has me stumped. If im playing on my own rig and hosting while playin people can join and all is well,but when i try to host a dedicated server on my other core 2 extreme machine i dont see it. My router is set correctly the host pc is set to dmz and ive tried this with 2 different kinds of routers. I have succesfully set up a dedicated lan game thou, so i think im just missing something small. Some coaching will be great i can even call who ever to help me in the us just email me tell and i will call you my email is dale_mcconnell@verizon.net also my conection is 15 megs up and 15 megs down on fiber, i now its something stupid that im not doing correcty, also i downloaded the dedicated server program and after it starts it gets errors and they are as follows well to many to menton , it just tries to start and wam crashes. im running xp pro 64 bit should i run 32bit? ALSO THANKS IN ADVANCE FOR ANY HELP GIVEN TO ME AT ALL IT IS GREATLY APPRICIATED!

    #2
    if it runs a LAN dedicated map fine then I'd assume it would be able to do a WAN one just fine. Perhaps you could post up the line you are using to start the server? Might be something you missed, (P.S. remember to remove Gamespy and Admin password before actually posting it up).

    quick edit: Oh I just had a thought, you are using seperate Gamespy logins for your server to your client right?

    Comment


      #3
      OK what im doing is starting the game and making the setting and clicking dedicated in the game and then hitting start the game shuts off and the server screen starts. im not actually sure what you talking about when you say post the line that starts the server? the dedicated server program crashes on me ,so i start it from the game itself. is this why the dedicated program is crashing because the line isnt right? how do i check this line? ohh buy the way im here monitoring this post for the next 3 hrs

      Comment


        #4
        Sorry, I thought you were using the dedicated server package for the seperate machine, the method you are using it will generate a working server command and options for you so you should have no problem.

        But let me check, are you using the same gamespy ID for the server and client? because even in this method I am sure that won't work, you can make a new profile for free and get a new gamespy ID for your server that easily. If you have already done this then I will think of other things it may be.

        Comment


          #5
          OK i did what you said and created another account and started server with game. for some reason im doin somthing wrong with the ded program cause it start with the logo and then goes to a black sreen and crashes. but here is my server log that still isnt showing up.

          Init: Version: 3521
          Init: Epic Internal: 0
          Init: Compiled: Dec 7 2007 15:04:52
          Init: Command line: DM-Arsenal?MaxPlayers=32?MinNetPlayers=0?NumPublicCon nections=32?NumPrivateConnections=0?NumOpenPublicC onnections=32?NumOpenPrivateConnecti
          ons=0?bShouldAdvertise=True?bIsLanMatch=False?bUse sStats=True?bAllowJoinInProgress=True?bAllowInvite s=True?bUsesPresence=True?bAllowJoinViaPresence=Tr ue?bUsesAr
          bitration=False?bIsDedicated=True?bIsListPlay=Fals e?OwningPlayerName=?PingInMs=0?AverageSkillRating= 1000.000000?GameMode=0?Difficulty=3?PureServer=1?L ockedServe
          r=0?Campaign=0?ForceRespawn=0?CustomMapName=DM-Arsenal?CustomGameMode=UTGame.UTDeathmatch?GoalSco re=50?TimeLimit=20?ServerDescription=0660000730000 6500004500007
          10000650000770000690000820000830000460000670000790 00077000?NumPlay=11?game=UTGame.UTDeathmatch?name= BIA-GAMERS.COM -log=DedicatedServer.log -Login=
          M -Password=
          Init: Base directory: C:\Program Files (x86)\Unreal Tournament 3\Binaries\
          Init: Character set: Unicode
          Log: Executing Class Engine.ServerCommandlet
          Log: Initializing Game Engine...
          Log: GConfig::Find has loaded file: ..\Engine\Localization\int\Editor.int
          Log: GConfig::Find has loaded file: ..\UTGame\Localization\int\UTEditor.int
          Init: UEngine initialized
          Log: Looking for DLC...
          Log: Object size..............: 60
          Log: Actor size...............: 436
          Log: ActorComponent size......: 88
          Log: PrimitiveComponent size..: 448
          Log: GConfig::Find has loaded file: ..\UTGame\Config\UTUIDataStore_Registry_0.ini
          Log: Performing DNS lookup for stunserver.org
          Log: Browse: DM-Arsenal?name=BIA-GAMERS.COM?team=255?MaxPlayers=32?MinNetPlayers=0? NumPublicConnections=32?NumPrivateConnections=0?Nu mOpenPublicConnections=32?N
          umOpenPrivateConnections=0?bShouldAdvertise=True?b IsLanMatch=False?bUsesStats=True?bAllowJoinInProgr ess=True?bAllowInvites=True?bUsesPresence=True?bAl lowJoinVia
          Presence=True?bUsesArbitration=False?bIsDedicated= True?bIsListPlay=False?OwningPlayerName=?PingInMs= 0?AverageSkillRating=1000.000000?GameMode=0?Diffic ulty=3?Pur
          eServer=1?LockedServer=0?Campaign=0?ForceRespawn=0 ?CustomMapName=DM-Arsenal?CustomGameMode=UTGame.UTDeathmatch?GoalSco re=50?TimeLimit=20?ServerDescription=06600
          00730000650000450000710000650000770000690000820000 83000046000067000079000077000?NumPlay=11?game=UTGa me.UTDeathmatch
          Log: LoadMap: DM-Arsenal?name=BIA-GAMERS.COM?team=255?MaxPlayers=32?MinNetPlayers=0? NumPublicConnections=32?NumPrivateConnections=0?Nu mOpenPublicConnections=32?
          NumOpenPrivateConnections=0?bShouldAdvertise=True? bIsLanMatch=False?bUsesStats=True?bAllowJoinInProg ress=True?bAllowInvites=True?bUsesPresence=True?bA llowJoinVi
          aPresence=True?bUsesArbitration=False?bIsDedicated =True?bIsListPlay=False?OwningPlayerName=?PingInMs =0?AverageSkillRating=1000.000000?GameMode=0?Diffi culty=3?Pu
          reServer=1?LockedServer=0?Campaign=0?ForceRespawn= 0?CustomMapName=DM-Arsenal?CustomGameMode=UTGame.UTDeathmatch?GoalSco re=50?TimeLimit=20?ServerDescription=0660
          00073000065000045000071000065000077000069000082000 083000046000067000079000077000?NumPlay=11?game=UTG ame.UTDeathmatch
          Log: Virtual memory allocation size: 134.20 MByte (140713984 Bytes)
          Log: Physical memory allocation size: 0.00 MByte (0 Bytes)
          Log: GConfig::Find has loaded file: ..\UTGame\Localization\int\UTGameContent.int
          Log: Game class is 'UTDeathmatch'
          Init: WinSock: Socket queue 131072 / 131072
          Log: NetMode is now 1
          Log: Primary PhysX scene will be in software.
          Log: Creating Primary PhysX Scene.
          PerfWarning: InstanceGeom: 8.551043 ms - 1276 Convex, Terrain 0.000000 ms, PerTriSM 0.713632 ms, InitArticulated 0.000000 ms, BodyInst Alloc 2.199400 ms, InitBo
          dy 16.322091 ms
          PerfWarning: NxActor Creation: 15.124977 ms
          Log: Bringing World DM-Arsenal.TheWorld up for play (30) at 2008.01.20-13.43.25
          ScriptLog: MinNetPlayers: 0
          Log: Bringing up level for play took: 0.826213
          Log: ########### Finished loading level: 2.946203 seconds
          Init: Game engine initialized
          Log: Initializing Game Engine Completed
          Log: FSTUNClient resolved stunserver.org (192.245.12.229)
          Error: Requested localized string setting BotSkill was not found
          Log: GAME PATH IS UTDeathmatch
          Error: Requested localized string setting BotSkill was not found


          im still lost hehehehehe

          server name is BIA-GAMERS.COM and it is still up so can anyone else see it?

          Comment


            #6
            I see [BIA]DarthMushak Test Server!

            Was able to join get the mutators and play with bots in there!

            Only issue is slow upload to clients for the small mutators but not that bad!

            Wen compression redirect gets fixed if it does then you should be fine!

            Comment


              #7
              I am not at home so I can not test this, but do you know the IP of the server? since then we cna do F10 > "Open ip" to know for sure if it's your server. Unless that seems right to you?

              Else wise it doesn't look like anything has gone wrong other then bot skill setting what should just default to average anyway so it should be running fine.

              Comment


                #8
                Originally posted by ANick View Post
                I see [BIA]DarthMushak Test Server!

                Was able to join get the mutators and play with bots in there!

                Only issue is slow upload to clients for the small mutators but not that bad!

                Wen compression redirect gets fixed if it does then you should be fine!
                thats not mine so its not showing up then

                Comment


                  #9
                  OK, first things first. Since your behind a router firewall, best to turn off your windows firewall on the server. Double check you have the correct ports forwarded to the correct IP. Go to your start menu, then all All Programs, then Accessories, then command line to get a c:\ prompt. Type ipconfig to see your IP address. That is the address to forward the ports to on your router.

                  Ok, so much for that. If that fixed it we are done. If not, then check how you are starting it, your command line. Here is a good command like for a CTF server.

                  ut3.exe server CTF-Hydrosis?Game=UTGameContent.UTCTFGame_Content?Game Mode=1?numplay=4?BotSkill=3?minnetplayers=1?maxpla yers=8?PureServer=1?timelimit=20?goalscore=5?Serve rDescription=0560000320001120001080000970001210001 01000114000032000067000084000070000?AdminPassword= admin-pass?bPlayersMustBeReady=False?bAllowJoinInProgres s=True?bAllowInvites=True?bUsesPresence=True?force respawn=1?bIsLanMatch=False?bIsDedicated=True?bSho uldAdvertise=True -login=GS-login -password=GS-pass -Port=7777 -unattended

                  That should work if your service provider network is compatible. You have a good connection, but, not a direct one to the internet. Your connected to the internal network of your service provider. You still have to pass through that connection to the internet. Do, you have a fiber optic or FIOS connection?

                  Comment


                    #10
                    Originally posted by oldkawman1 View Post
                    OK, first things first. Since your behind a router firewall, best to turn off your windows firewall on the server. Double check you have the correct ports forwarded to the correct IP. Go to your start menu, then all All Programs, then Accessories, then command line to get a c:\ prompt. Type ipconfig to see your IP address. That is the address to forward the ports to on your router.

                    Ok, so much for that. If that fixed it we are done. If not, then check how you are starting it, your command line. Here is a good command like for a CTF server.

                    ut3.exe server CTF-Hydrosis?Game=UTGameContent.UTCTFGame_Content?Game Mode=1?numplay=4?BotSkill=3?minnetplayers=1?maxpla yers=8?PureServer=1?timelimit=20?goalscore=5?Serve rDescription=0560000320001120001080000970001210001 01000114000032000067000084000070000?AdminPassword= admin-pass?bPlayersMustBeReady=False?bAllowJoinInProgres s=True?bAllowInvites=True?bUsesPresence=True?force respawn=1?bIsLanMatch=False?bIsDedicated=True?bSho uldAdvertise=True -login=GS-login -password=GS-pass -Port=7777 -unattended

                    That should work if your service provider network is compatible. You have a good connection, but, not a direct one to the internet. Your connected to the internal network of your service provider. You still have to pass through that connection to the internet. Do, you have a fiber optic or FIOS connection?
                    ok first off that pc is set to dmz so it is wide open. next i really dont understand this f10 thing i now what my external ip is but i have never had to do anything special like this line thing to any other game and i run 4 other game servers fine? where is this line we are talking about and how do i set it. im a quik learn so help me out here.

                    and finally can anyone tell me why i cant just run the dedicated server program it keeps crashing right after start up
                    .

                    Comment


                      #11
                      I FOUND A COMMAND LINE GENERATOR now where do i install the command line?

                      Comment


                        #12
                        You need the actual Windows Dedicated Server application to run the CLI and I am not sure that is apart of game client, could be wrong tho... if it is you should just be able to put it in to a Command prompt. like cmd, anyway the F10 thing... if you hit F10 in game you get a console, with that you do "open <ip>". <ip> replaced with the actual server IP.

                        Comment


                          #13
                          RESISTANCE I REALLY APPRECIATE YOUR HELP. I did however figure out how to paste the command line in THE DEDICATED SERVER APP and it started but i still dont see it on line. anyway we are getting closer,i am not giving up though. so in the command line do i have to put my external ip?
                          and if so what id the string?

                          I DO HAVE A TEAMSPEAK SERVER IF YOU HAVE IT WE COULD TALK? FOR ANYONE WHO WANT TO HELP US IT IS
                          Server:
                          BROTHERS IN ARMS

                          Server IP:
                          66.29.87.133:8577
                          (66.29.87.133:8577)

                          Comment


                            #14
                            in command prompt, "Start > (all) Programs > Accessories > Command Prompt". Is where you'd traditionally start a dedicated server via a ut3.exe command... but also here you can do "ipconfig" if you have more then one external IP (ip's such as 127.0.0.1 or 127.0.x.x are internal so are 192.168.x.x). If you have more then one external ip then you can do -multihome <ip> but if you do not have more then you don't need to worry about it ^^;.

                            It maybe easier to download the Windows Server from the sticky then rely on the one related to the game client, however I dunno, I don't really use window servers ^^;;.

                            Anyways I am currently at work, (at 2am, yes). So things like teamspeak are a no no at the second ^^;;.

                            Comment


                              #15
                              Originally posted by BIA-HOTROD View Post
                              ok first off that pc is set to dmz so it is wide open. next i really dont understand this f10 thing i now what my external ip is but i have never had to do anything special like this line thing to any other game and i run 4 other game servers fine? where is this line we are talking about and how do i set it. im a quik learn so help me out here.

                              and finally can anyone tell me why i cant just run the dedicated server program it keeps crashing right after start up
                              .
                              F10 is the console.

                              There are 3 connections coming in. All they see is your external IP. With port forwarding, these connections are forwarded to the correct computer connected to the router. You should not need DMZ. The router assigns, if your using DHCP, (or you need to manually assign) a different address to each box connected to it. Say the router IP you see is 192.168.10.1, then it assigns 192.168.10.101 to your game box, 192.168.10.103 to your workstation, and 192.168.10.102 to the server. These are internal numbers, those outside your network see only the IP number assigned to your cable modem or broadband converter. The router is then set up to forward the correct ports to the proper internal IP, in this case, the ports 7777, 6500, and 13000 are forwarded to 192.168.10.102, which is the internal address of the server.

                              Login to the router via the standard browser with the router address. http://192.168.10.1 for some, but find the one your router uses in the manual, different ones use different numbers. Then go to the router setup, usually advanced setup or settings, port forwarding. Many different router setup pages and no two are the same. You need to list the 3 ports to forward, UDP, assign to the address the router assigned to your UT3 server, say, 192.168.10.101 for example. To find out this address for windows, get a command line and type ipconfig. It will be the same as your router except for the numbers after the last period.

                              I can only help on generic stuff. I cannot help with details on Windows server operations. I do Linux servers only.

                              Comment

                              Working...
                              X