Announcement

Collapse
No announcement yet.

Linux Server disconnecting all Players

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Linux Server disconnecting all Players

    This is the same problem many have been having. This started happening last night on my server. Probably not coincidently whenever 5 players were in the match. Finally, as more people play, then the server has problems.The server connections from everyone time out. The server remains in the browser but no one can connect to it until I kill and restart it. This does not seem to happen when there are fewer than 5 players. Not much to go by in the logs. Here is what I have;

    Log: Bringing World WAR-Avalanche.TheWorld up for play (30) at 2008.01.06-22.39.04
    ScriptLog: MinNetPlayers: 1
    ScriptLog: -- MAPVOTE is ENABLED!!!!!
    ScriptLog: Activating link setup Default
    Log: GAME PATH IS UTOnslaughtGame_Content
    Log: Bringing up level for play took: 0.237217
    SeamlessTravel: >> GameInfo::HandleSeamlessTravelPlayer: UTPlayerController_11
    ScriptWarning: UTOnslaughtGame_Content WAR-Avalanche.TheWorld:PersistentLevel.UTOnslaughtGame _Content_2 (Function UTGame.UTOnslaughtGame:ChoosePlayerStart:00EB) Accessed array 'UTOnslaughtGame_Content_2.PowerCore' out of bounds (255/2)
    ScriptWarning: UTOnslaughtGame_Content WAR-Avalanche.TheWorld:PersistentLevel.UTOnslaughtGame _Content_2 (Function UTGame.UTOnslaughtGame:ShouldPrioritizeNodeWithFla g:0095) Accessed array 'UTOnslaughtGame_Content_2.PowerCore' out of bounds (254/2)
    ScriptWarning: UTOnslaughtGame_Content WAR-Avalanche.TheWorld:PersistentLevel.UTOnslaughtGame _Content_2 (Function UTGame.UTOnslaughtGame:ChoosePlayerStart:043A) Accessed array 'UTOnslaughtGame_Content_2.PowerCore' out of bounds (255/2)
    SeamlessTravel: << GameInfo::HandleSeamlessTravelPlayer: UTPlayerController_11
    SeamlessTravel: >> GameInfo::HandleSeamlessTravelPlayer: UTPlayerController_10
    SeamlessTravel: << GameInfo::HandleSeamlessTravelPlayer: UTPlayerController_10
    SeamlessTravel: >> GameInfo::HandleSeamlessTravelPlayer: UTPlayerController_9
    SeamlessTravel: << GameInfo::HandleSeamlessTravelPlayer: UTPlayerController_9
    SeamlessTravel: >> GameInfo::HandleSeamlessTravelPlayer: UTBot_16
    SeamlessTravel: << GameInfo::HandleSeamlessTravelPlayer: UTBot_16
    SeamlessTravel: >> GameInfo::HandleSeamlessTravelPlayer: UTBot_15
    SeamlessTravel: << GameInfo::HandleSeamlessTravelPlayer: UTBot_15
    SeamlessTravel: >> GameInfo::HandleSeamlessTravelPlayer: UTBot_14
    SeamlessTravel: << GameInfo::HandleSeamlessTravelPlayer: UTBot_14
    SeamlessTravel: >> GameInfo::HandleSeamlessTravelPlayer: UTBot_13
    SeamlessTravel: << GameInfo::HandleSeamlessTravelPlayer: UTBot_13
    SeamlessTravel: >> GameInfo::HandleSeamlessTravelPlayer: UTBot_12
    SeamlessTravel: << GameInfo::HandleSeamlessTravelPlayer: UTBot_12
    SeamlessTravel: >> GameInfo::HandleSeamlessTravelPlayer: UTPlayerController_8
    SeamlessTravel: << GameInfo::HandleSeamlessTravelPlayer: UTPlayerController_8
    Log: GAME PATH IS UTOnslaughtGame_Content
    ScriptLog: UTPlayerController_11::ServerRegisterPlayerRanking NewPlayerRanking:'1669' was PlayerReplicationInfo.PlayerRanking:'0'
    Log: UOnlineGameInterfaceGameSpy::Recalculating Skill Rating for 4 players
    ScriptLog: UTPlayerController_8::ServerRegisterPlayerRanking NewPlayerRanking:'1211' was PlayerReplicationInfo.PlayerRanking:'0'
    Log: UOnlineGameInterfaceGameSpy::Recalculating Skill Rating for 4 players
    ScriptLog: UTPlayerController_9::ServerRegisterPlayerRanking NewPlayerRanking:'1145' was PlayerReplicationInfo.PlayerRanking:'0'
    Log: UOnlineGameInterfaceGameSpy::Recalculating Skill Rating for 4 players
    NetComeGo: Close TcpipConnection_6 76.29.95.7:3063
    ScriptLog: WARNING - Spectator only player leaving spectating state to go to None
    Log: UOnlineGameInterfaceGameSpy::Recalculating Skill Rating for 3 players
    NetComeGo: Open TheWorld 76.29.95.7:3063
    ScriptLog: START MATCH
    ScriptLog: Num Matches Played: 0
    NetComeGo: Open TheWorld 66.31.94.1:50102
    Log: Client netspeed is 10000
    Log: UTPlayerController_12 got player TcpipConnection_8
    Log: UOnlineGameInterfaceGameSpy::Recalculating Skill Rating for 4 players
    ScriptLog: UTPlayerController_12::ServerRegisterPlayerRanking NewPlayerRanking:'979' was PlayerReplicationInfo.PlayerRanking:'0'
    Log: UOnlineGameInterfaceGameSpy::Recalculating Skill Rating for 4 players
    NetComeGo: Open TheWorld 69.133.98.225:2324
    Log: Client netspeed is 10000
    ScriptLog: UTBot_17 WhatToDoNext while RoundEnded
    NetComeGo: Close TcpipConnection_7 76.29.95.7:3063
    Log: UTPlayerController_13 got player TcpipConnection_9
    Log: UOnlineGameInterfaceGameSpy::Recalculating Skill Rating for 5 players
    ScriptLog: UTPlayerController_13::ServerRegisterPlayerRanking NewPlayerRanking:'1800' was PlayerReplicationInfo.PlayerRanking:'0'
    Log: UOnlineGameInterfaceGameSpy::Recalculating Skill Rating for 5 players
    ScriptLog: Reset UTOnslaughtGame_Content_2
    NetComeGo: Close TcpipConnection_8 66.31.94.1:50102
    Log: UOnlineGameInterfaceGameSpy::Recalculating Skill Rating for 4 players
    ScriptWarning: UTWeap_Enforcer WAR-Avalanche.TheWorld:PersistentLevel.UTWeap_Enforcer _121 (Function UTGame.UTWeapon:WeaponPuttingDown.BeginState:0051) Accessed None 'Instigator'
    ScriptWarning: UTWeap_Enforcer WAR-Avalanche.TheWorld:PersistentLevel.UTWeap_Enforcer _121 (Function UTGame.UTWeapon:TimeWeaponPutDown:0009) Accessed None 'Instigator'
    ScriptWarning: UTVehicle_Nemesis WAR-Avalanche.TheWorld:PersistentLevel.UTVehicle_Nemes is_2 (Function UTGameContent.UTVehicle_Nemesis:ApplyTurretHeight: 02E5) Accessed None 'EffectRef'
    NetComeGo: Close TcpipConnection_9 69.133.98.225:2324
    Log: UOnlineGameInterfaceGameSpy::Recalculating Skill Rating for 3 players
    NetComeGo: Open TheWorld 69.133.98.225:2324
    Log: UDP recvfrom error: 111 () from 0.0.0.0:0
    NetComeGo: Close TcpipConnection_5 24.17.69.15:2373
    Log: UOnlineGameInterfaceGameSpy::Recalculating Skill Rating for 2 players
    NetComeGo: Close TcpipConnection_0 70.177.196.130:60948
    Log: UOnlineGameInterfaceGameSpy::Recalculating Skill Rating for 1 players
    NetComeGo: Close TcpipConnection_4 24.11.179.227:9518
    Log: UOnlineGameInterfaceGameSpy::Recalculating Skill Rating for 0 players
    NetComeGo: Close TcpipConnection_10 69.133.98.225:2324
    Log: CTRL-C has been pressed.

    Is there any way to collect more info? Any way to collect the console logs?

    #2
    Did you already use the UT3-bin test binary ?
    I had it uploaded today and (fingers cross) my server is still running now.

    Comment


      #3
      OK, I have replaced the bin file with the new one. It it running with the new bin. Hope to test it tonight if enough players show up.

      Comment


        #4
        . . . i have the same problem!!, the server run perfectly about for 3 maps, and then it seems to be ok in the query, but nobody can be connected

        Please Help Us !! ='(

        Comment


          #5
          Ok little update, this morning i was checking the servers and gues what the are still running and accesable to players.
          So far so good on this moment

          Pelantaru you have to subscribe to a mailinglist here.
          There you get more answers as on this whole forum you get also a download link for that test ut3-bin file over there.

          Good luck

          Comment


            #6
            hi i've just joined the list, any way to get the binary to test? I have the EXACT SAME problem with my server too

            Comment


              #7
              Same problem.....

              Same problem here as well.. VERY FRUSTRATING.

              I'm running FC4, and have never had problems hosting my UT2004 server on there. It's got P4 3.2 GHz w/ 1.5 gig RAM. I feel like I've tried everything.

              It seems to be triggered by the same error everytime:

              Log: UDP recvfrom error: 111 () from 0.0.0.0:0

              This is the exact same error I see in my logs.... It's very sporadic too... sometimes I can get through a whole game with 2-3 people, but sometimes it kicks us out within 5 minutes (or sooner)....

              Comment


                #8
                Linux dedicated test ut3-bin

                Originally posted by StoneCold View Post
                hi i've just joined the list, any way to get the binary to test? I have the EXACT SAME problem with my server too
                Hope this saves someone some time:
                http://treefort.icculus.org/ut3/ut3-bin-test.tar.bz2

                Comment


                  #9
                  Yes, this looks like it's fixed.

                  Yes, this looks like it's totally fixed. No problems since using the new bin. MOST Excellent!

                  Comment


                    #10
                    Originally posted by oldkawman1 View Post
                    Yes, this looks like it's totally fixed. No problems since using the new bin. MOST Excellent!
                    Glad to hear it also works for you, since i have it running with the new bin its all ok.
                    Dont have any problems anymore

                    Btw i dont think it was the intention to put the download link here Aquariusrick ?

                    Comment


                      #11
                      nope!

                      I test this binary since release and only my DM server run without problems!


                      My warfare server crash after 4 or 5 mapvotes ... (like ut3 demo)

                      Comment

                      Working...
                      X