Announcement

Collapse

The Infinity Blade Forums Have Moved

We've launched brand new Infinity Blade forums with improved features and revamped layout. We've also included a complete archive of the previous posts. Come check out the new Infinity Blade forums.
See more
See less

Unable to host with patch 1.1

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Unable to host with patch 1.1

    After I installed the 1.1 patch (public final release), I'm no longer able to host a server. I get the message...

    ERROR: Your network configuration is not compatible with hosting matches. Please check your router’s manual for instructions on setting up ‘Port Forwarding’ or a ‘DMZ server’

    My PC has a static IP. All UT3 ports are forwarded to it correctly and I have uPnP enabled in my router. I'm not running any anti-virus software (just AVG) or anything that might act as a 3rd party software firewall. As such, I've turned of the Windows firewall for troubleshooting purposes. I haven't put my PC behind the DMZ yet as that would defeat the purpose of using my router as a SPI firewall.

    I'm using a D-Link DGL-4300 gamefuel router with firmware rev 1.8. Doing a google search has reported at least two other users having trouble after the patch with the same router. Is it just a quencidence, or does anyone else have the same issue here?

  • #2
    post deleted

    Comment


    • #3
      I am having this exact same issue.

      Dubious, I noticed that you're using the dedicated server. I get this error message when I try to host through the UT3 GUI.

      Comment


      • #4
        Yeah this is a bug i guess. I got it to, the only way to go through is setting DMZ but it is just a (dangerous) workaround.

        Epic did a very bad job on network code i think.

        Comment


        • #5
          Have same router, DGL-4300 and we too are unable to host a server via in-game menu. :/

          Comment


          • #6
            EPIC must be aware of the problem.

            I have had the same problem/error message with all beta patches and the final patch as well.
            If I launch a LAN match, I get the error message but if I click "OK", it allows me to proceed and create the LAN match. Others can join.
            For some reason the option of selecting Internet or LAN is not selectable. It's stuck on LAN and I can't change it.
            I shouldn't have to go into my router settings and change something that worked fine without the patch installed. There is too much risk of me messing something up.
            I have posted this problem several times in these foroms. EPIC must be aware of the problem.

            Comment


            • #7
              This is most likely due to the master server checking if your source port is randomized when connecting. That is one of two checks (the other one being that the gameport is reachable from the master) that triggers this message.
              It is a counterproductive check in my opinion since it screws most owners of SOHO class routers (which do not have an option to turn randomization on/off) and also it has absolutely no bearing on the ability of the server to function.

              This is exactly the same problem that UT2k* had with NAT and this was reported to Epic over 4 years ago. Let's see if they address it this time around...

              Comment


              • #8
                same for me:
                can not host UT3 games, too ("your network configuration is not compatible with hosting matches").
                But I can
                * host warcraft 3 games without any problems (portforward 6612)
                * host UT3 games when I activate DMZ in my router
                * host a UT3 server with a start.bat

                I have tryed following portforwards (controlled used ports with TCP-View):
                2299 listening port
                3478
                6500
                13000
                27900

                and also tryed different combinations with UDP/TCP or both and with some of the list above. No success. So I assume, that my router blocks something other routers don't block. But I have no idea, what it could be. It has to be something very special in ut3. Because I have no problems to host other games (warcraft 3; CS; etc.)

                My system:
                UT3 1.1
                router linksys wrt54gl with Firmware: DD-WRT v23
                win xp pro, no local firewall activated

                So no idea what is wrong?
                Only workaround for friends game:
                what you have to do:
                1. forward port 7777 in your router to your LAN-IP (something like 192.168.1.xxx)
                2. open a LAN-Game

                what your friends have to do:
                1. open console in ut3 by pressing TAB or F10
                2. than they have to type open and your (the HOST) WAN-IP (http://www.whatismyip.de/) and add :7777 (e.g. open 85.178.xxx.xxx:7777)

                Greetings,
                Jesko.

                Comment


                • #9
                  Originally posted by NakedApe View Post
                  This is most likely due to the master server checking if your source port is randomized when connecting.
                  What does that even mean? In almost all network applications, the source port is chosen by the operating system from a certain port range when the connection is initiated. On top of that, when using NAT with a single external IP address (which almost all home users will have), the source port on the router will most likely not match the source port on the PC.

                  It would be pure insanity for any network application to insist on a static source port.


                  This is exactly the same problem that UT2k* had with NAT and this was reported to Epic over 4 years ago. Let's see if they address it this time around...
                  This is not a problem that UT has ever had before. I've run servers since UT and never had this issue. I have a friend who has both UT2k4 and UT3 installed _right now_ and can host a 2k4 server just fine, but not a UT3 server.

                  From what I can see, this really seems to be a problem specific to launching a server from the in game UI. Otherwise, we'd be seeing a lot more server admins complaining about it since some of the people in here are having problems with very common routers.

                  Comment


                  • #10
                    I get that ERROR: Your network configuration is not compatible with hosting matches. Please check your router’s manual for instructions on setting up ‘Port Forwarding’ or a ‘DMZ server’ if when I try to go into MP from the retail version. With no changes to my network config or router though I'm still able succesfully host internet games with the dedicated version from the same machine.

                    Comment


                    • #11
                      Originally posted by agentq_71 View Post
                      I am having this exact same issue.

                      Dubious, I noticed that you're using the dedicated server. I get this error message when I try to host through the UT3 GUI.
                      I also have no problems starting a game using retail GUI on this same computer. I just checked it to be sure.

                      I dont know what you people using DLink DGL-4300 routers are doing, but I just showed you exactly how mine is setup and it works without any problem. Some of you say "I have the same router and also have this problem" but you make no mention if you set your router up to match what I have, and didnt post any screen shots of your config either. There is no way to even troubleshoot it if you just say "it doesnt work."

                      Comment


                      • #12
                        Originally posted by MasterB View Post
                        I shouldn't have to go into my router settings and change something that worked fine without the patch installed. There is too much risk of me messing something up.
                        Well, yes, you may have to change settings in some cases, because there were changes made to the way UT3 fundamentally handles NAT transversal. It is naive to think that you shouldn't have to change as well. In some cases, changes may have to be made in order to support this functionality post-patch.

                        If you are concerned with messing something up then you likely do not know enough about networking to understand why this isn't working for you. I don't mean to sound rude when I say that, I'm just trying to put things into perspective.

                        Comment


                        • #13
                          Ok, those of you running D-Link DGL-4300 routers

                          I think I found the magic bullet for you.
                          1. Login to your router's web interface
                          2. Go to Advaced --> Firewall
                          3. Look at the settings for "NAT Endpoint Filtering"
                          - "UDP Endpoint Filtering" needs to be set to "Endpoint Independent"

                          If you have this set to anything other than "Endpoint Independent" then the UT3 GUI will give the error message and not allow you to host an Internet server.

                          I do not know if this setting also exists on other D-Link routers. I do not know the equivalent setting on Linksys or other brand routers. But, here is the D-Link description of this setting:
                          Originally posted by D-Link Manual
                          NAT Endpoint Filtering

                          The NAT Endpoint Filtering options control how the router's NAT manages incoming connection requests to ports that are already being used.

                          Endpoint Independent
                          Once a LAN-side application has created a connection through a specific port, the NAT will forward any incoming connection requests with the same port to the LAN-side application regardless of their origin. This is the least restrictive option, giving the best connectivity and allowing some applications (P2P applications in particular) to behave almost as if they are directly connected to the Internet.

                          Comment


                          • #14
                            Originally posted by agentq_71 View Post
                            What does that even mean? In almost all network applications, the source port is chosen by the operating system from a certain port range when the connection is initiated. On top of that, when using NAT with a single external IP address (which almost all home users will have), the source port on the router will most likely not match the source port on the PC.

                            It would be pure insanity for any network application to insist on a static source port.
                            Some NAT routers will change the external port even when they don't need to. ie if port 7777 is available on the public ip the router should attempt to use that first, though some will change it anyway. Your problem may be the "unsolicited connection" check.

                            One of the devs posted this:

                            There are 2 checks that determine whether or not your router is "strict".
                            The first is it checks to see if the outgoing port is randomized. The game
                            communicates on 7777, but some routers may map that to a completely
                            different port. This would need to be disabled in order to host a server.

                            The other check is whether or not an unsolicited connection request will be
                            accepted by your router. Most will accept responses, but if there wasn't an
                            outgoing request first, some servers will just blanket reject the incoming
                            request. Again, this would need to be disabled in order to host a server.

                            Whether or not your server has 1 or both of these issues, I don't know, but
                            either would trigger the strict nat warning and disable internet hosting.

                            Hope that helps!

                            Jeff


                            Though I'm not sure why it works with the dedicated server for some but not a listen server. Could be a bug. For those who had it work with with the dedicated server but not a listen server: where you able to actually have people connect and play ok also?

                            Comment


                            • #15
                              Originally posted by Str1der View Post
                              .........For those who had it work with with the dedicated server but not a listen server: where you able to actually have people connect and play ok also?
                              Yes, I can connect to my dedicated box using serverbehindNAT (Linksys Router). I've tested connections both internally on my 192 subnet and externally from other computers. No DMZ or anything odd, just straight what one would expect to do to make it work. After the STUN option was added my server just started working.

                              Comment

                              Working...
                              X