Announcement

Collapse
No announcement yet.

Redirect is it working now?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    Originally posted by WickeD View Post
    I don't think its working right. I am trying to set up CustomUT for redirect. the files are in a folder myhost/files/server/UTgame/config and cookedpc ect. and have this codeset is in my engine.ini

    [IpDrv.HTTPDownload]
    RedirectToURL=http://myhost/files/servers/
    UseCompression=False
    ProxyServerPort=
    ProxyServerHost=
    If your files are stored on a web server in the path http://Mydomain.com/files/server/UTgame/config/ then your UTEngine.ini config should be:

    [IpDrv.HTTPDownload]
    RedirectToURL=http://Mydomain.com/files/server/UTgame/config/
    UseCompression=False
    ProxyServerPort=
    ProxyServerHost=

    You need to use the same URL in the UTGame.ini file as you would in a browser.

    Comment


      #17
      Originally posted by Dubious View Post
      If your files are stored on a web server in the path http://Mydomain.com/files/server/UTgame/config/ then your UTGame.ini config should be:

      [IpDrv.HTTPDownload]
      RedirectToURL=http://Mydomain.com/files/server/UTgame/config/
      UseCompression=False
      ProxyServerPort=
      ProxyServerHost=

      You need to use the same URL in the UTGame.ini file as you would in a browser.
      But it also has files for the mod in http://Mydomain.com/files/server/UTg...thing/cookedpc folders.

      Thats why i have been asking. with a mod do i need to just take all the filels from the folders you would normal install them in and just have ALL the files in http://Mydomain.com/files/server/ folder

      Also you said UTgame.ini you mean UTengine.ini right?

      Comment


        #18
        Dubious, I tried what you said their and it's still not working for me.

        Comment


          #19
          Originally posted by WickeD View Post
          I don't think its working right. I am trying to set up CustomUT for redirect. the files are in a folder myhost/files/server/UTgame/config and cookedpc ect. and have this codeset is in my engine.ini

          [IpDrv.HTTPDownload]
          RedirectToURL=http://myhost/files/servers/
          UseCompression=False
          ProxyServerPort=
          ProxyServerHost=


          am i missing something? I know 2k4 had an additional part of code in the ini that said AllowserverDL=false or something?

          Edit: It took about 1:30 to download a 931kb file connecting to the server. I know my http host sends to me a whole lot faster than that. but does that mean its not working? i read posts from you all that say it makes a good bit of difference. When i DL'd the same Mut from a OGL server (prepatch) it took me about 5 mins for less than 2 megs of files.
          Few things to check: make sure you are editing the correct UTEngine.ini (in regards with using -configsubdir & -nohomedir cmd line params). Try pointing your browser to your redirect url (for example http://myhosts/files/server/CustomUTv1.u). If that doesn't work it's a webserver problem (if using IIS check if required extensions are added to allowed list).

          Comment


            #20
            Thats why i have been asking. with a mod do i need to just take all the filels from the folders you would normal install them in and just have ALL the files in http://Mydomain.com/files/server/ folder

            Also you said UTgame.ini you mean UTengine.ini right?
            Ok I think some people are confused as to how this works.

            On the web server you create ONE folder, and dump EVERYTHING in that ONE folder. You can make the path be anything that you want. http://MyDomain.com/redirect/ is a perfectly acceptable path. In that folder you need to put all maps, all texture files, all sound files, all files of any type that clients will need. And yes, I meant UTEngine.ini sorry about that.

            Comment


              #21
              Two questions:

              Does the redirect support compressed archives?
              Can I use the ucc from UT2004 (and UZtool) to compress my UT3 archives for the redirect?

              Comment


                #22
                Compression isn't implemented yet.

                Comment


                  #23
                  Thanx dubious. i kinda guessed all files should be in the dir (without sub dirs) after your post. I did try just putting all the ini,textures, what not in the http://dir/ and i think its working now.

                  If any one wants to test for me and does not have CustomUT installed plz do!
                  -=Monsterkill Madhouse=-
                  -=Duel Asylum=-

                  Comment


                    #24
                    Dubious, I am still having trouble getting this to work. Do you mind if I PM you my redirect settings?

                    Comment


                      #25
                      Originally posted by AZ-{OVGY} View Post
                      Compression isn't implemented yet.
                      I know that you can't compress using the binary, but is it already built in to handle compressed files was more what I was getting at. Just like zip and unzip are two different applications based on compression, I was trying to see if perhaps "unzip" was in there but "zip" was not. If that's the case and they are using the same algorithm as UT2k4, we would have a work around until "compress" was implemented.

                      That was the basis of the question.

                      Comment


                        #26
                        Originally posted by headfog View Post
                        I know that you can't compress using the binary, but is it already built in to handle compressed files was more what I was getting at. Just like zip and unzip are two different applications based on compression, I was trying to see if perhaps "unzip" was in there but "zip" was not. If that's the case and they are using the same algorithm as UT2k4, we would have a work around until "compress" was implemented.

                        That was the basis of the question.
                        Compression AND decompression are not yet built into the binaries.

                        Comment


                          #27
                          Well I tested the redirect and it does work for me

                          but there is still the "invalid URL" bug that disconnect you from the server if you try to download a custom map through the vote system. the good news is if you reconnect then the redirect kicks in.

                          Is there any way around this bug that makes the redirect, well..., kinda pointless? as most people wont magically understand they have to reconnect to the server to download the map.

                          Comment


                            #28
                            I don't think there is a fix other than reconnect. Epic does know this.

                            Comment


                              #29
                              i tried high and low everything posted in this thread, and still no buano. i've even set "AllowDownloads=False" and notting. im truely starting to get frustrated!grrrrr.....

                              Comment


                                #30
                                Originally posted by WoLvErInE View Post
                                i tried high and low everything posted in this thread, and still no buano. i've even set "AllowDownloads=False" and notting. im truely starting to get frustrated!grrrrr.....
                                You should probably look at your web server setup at this point rather than your UT3 config. Can you get the file just by using your web browser to go to http://MyDomain.com/MyRedirectFolder/Filename.ut3 ? If not then the problem is with your web server.

                                Comment

                                Working...
                                X