Announcement

Collapse
No announcement yet.

Custom maps do not show in votelist

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Custom maps do not show in votelist

    Hi all, I upped some custom maps to our server, I altered the .ini like this

    Code:
    GameSpecificMapCycles=(GameClassName="UTDeathmatch",Maps=("DM-Arsenal","DM-Sanctuary","DM-Deck","DM-Defiance","DM-Deimos","DM-Diesel","DM-Gateway","DM-HeatRay","DM-RisingSun","DM-Sentinel","DM-ShangriLa","DM-Fearless","DM-Biohazard","DM-CarbonFire","DM-Bowl","DM-LongestYard"))
    It now has all maps + two custom maps. The voting works perfectly except that it doesnt let show the custom maps. Now on my own machine I had to add a 'Published' path and they would show up in my instant action game list. But since the server is -nohomedir I cannot figure out where to put them. They are now in ut3/UTGame/CookedPC/Maps/ this is how we rented the server. Should I make my own path somewhere?

    If I use the AdminChangeMap command it does work...

    Any thoughts ?

    -Slokop

    #2
    where exactly in your servers file structure did you put the maps?
    i used:
    UTGame/Published/CookedPC/CustomMaps/

    the map i uploaded had an .ini file, a ut3 file, and a .upk file. all 3 go in the custom map folder. also, i had to create the CustomMaps folder manually.

    Comment


      #3
      Originally posted by hawkwind View Post
      where exactly in your servers file structure did you put the maps?
      i used:
      UTGame/Published/CookedPC/CustomMaps/

      the map i uploaded had an .ini file, a ut3 file, and a .upk file. all 3 go in the custom map folder. also, i had to create the CustomMaps folder manually.
      Ok it is what I suspected, I will try and make a new folder tree and test it, Ill get back in here

      Comment


        #4
        Well made a new path: ut3/UTGame/Published/CookedPC/CustomMaps/ I did not bring me succes, also when I vote for DM-Biohazard I get an error: Invalid URL: DM-Biohazard... and the map is where it is supposed to be argh argh argh running a server is not easy for UT3 atm.

        It does not seem to matter where I put my custom maps, I deleted them everywhere else and put them only in my newly created folder tree, and I could run them with the AdminChangeMap command.... I want them in my votelist *cry* and *sob*

        Comment


          #5
          Anyone have an idea yet ? or is it a known bug ?

          Comment


            #6
            i am also trying to get this to work.

            i have the custom map loading from the cmd line fine but cannot get it to show up in the vote menu.

            Comment


              #7
              You can put any name in the map vote list it should show up don't need the file to be anywhere for it to show up, however to make it switch properly you need to put the map file and the map embedded stuff file (_LOC_int.upk) in /UTGame/CookedPC/CustomMaps, you will need to create that folder it is not there by default. As far as I know other custom packages goes in Environments

              Comment


                #8
                Well i found the problem. There was two mapcycle lists for deathmatch. I think somehow an additional one got created automatically. I could be wrong though...maybe I mucked it up again.

                Does anyone else mysteriously have 2 lists?

                Comment


                  #9
                  to get them into your map list for voting you need to add them in the gametype section where the rest of your maps are now you will see all the default maps there now in the game.ini...you add all these maps in order to get map rotation working that is where you add your custom maps to get them to show up...

                  Comment


                    #10
                    yeah, that was the list i was refering to in my post directly above.
                    I identified the problem and noted it there also.

                    Comment


                      #11
                      there is a mapvotelist in :

                      \UTGame\Config\UTgame.ini
                      and in the same folder
                      DefaultGame.ini

                      match those maplists im testing now

                      Ok after ive done that i got invalit url on voting the map
                      The server loads the map but the dloader gets invalid url

                      Comment


                        #12
                        You dont want to change the one in defaultgame.ini. Only the ones in utgame.ini.

                        The invalid url error is a known bug. It will happen when anyone downloads the map for the first time. re-join the server and it works

                        Comment

                        Working...
                        X