Announcement

Collapse
No announcement yet.

Theres got to be away of running a server behind NAT

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Right we cant upgeade our ROUTER so that is out of the question... But we have got the server to show up in the browser either as a listen or dedicated although as a deicated it only shows up until someone tries to connect but when they dont get on the server it disappears we tried to run as a listen and the server stayed in the browser even though I could not connect. Does it matter what Operating syste you run because we are runnig vista 32 ultimate and just incase you need to know the make of our router this is it...NETGEAR WGR614 the only way we can get it to show up in the browser is by using DMZ which is risky but its the only way we know of for now even if people cant connect we really need hel on this so please get back to me thanks you so much for all that help

    Leave a comment:


  • replied
    Thanks for the replies guys but do any of you play on your own servers because thats what we want do i will try that firmware update thing and see what happens hopefully it will work thanks for all your he...
    will report back if it works or doesnt

    Leave a comment:


  • replied
    I've been having the same trouble but finally had some success tonight.

    Setup:
    WinXP SP2
    cable modem
    Linksys WRT54GS v1.0
    PC connected via ethernet cable

    Like you, I've been hosting UT99/UT2004 and TeamSpeak servers for years without problems. VPN to work and using VoIP phone service without problems. Network admin at work so I know what I'm doing.

    I've been able to host and see the game on the server list, but couldn't connect. The first thing I tried when it wouldn't work was turning off Windows firewall and searching the forum for ports to forward. Still didn't work, so I installed the beta patch. That just made it worse, because I now get a message about port forwarding/DMZ when trying to host. I reluctantly tried DMZ and it still didn't work. I then upgraded my router firmware but initially still had no luck.

    However, the new firmware has an option "Filter Internet NAT redirection" which was enabled by default. I turned it off, and now I can connect to the server.

    My problem now is this stupid port forwarding/DMZ error message. What I've found is that I can enable DMZ just long enough to get the game hosted, then turn off DMZ, and the game continues fine and people can still connect. The message is just a bug in the beta patch. Also, running Windows firewall does not prevent me from hosting a game and being able to connect... even before I added UT3 to the list of exceptions.

    I think I will live with the bug... toggling DMZ on/off at the start of hosting, and then when the official patch is released I will uninstall/reinstall and see how it goes.

    So my recommendation is to upgrade your router firmware and make sure filter NAT redirection is turned off. I also have uPnP enabled just to be sure, and am probably forwarding more ports than I really need. Once things settle down after the first patch I'll go back and start eliminating ports until I only have open what I need.

    Leave a comment:


  • replied
    BS, It might work for you but not for me!

    I been running servers for Unreal engine games since Unreal 1 and never had a problem until now.

    I have the same server setup now as I do for UT2003/4 ect ect.

    Clients CANNOT connect to my server beta patch or not client side or server side ect ect in UT3. I have an actiontek modem/router 1000 kbps upload and run all other servers with it no problem so dont be telling people this beta patch fixes anything because it dont.

    Should work just like UT2004 as long as the proper ports are forward and firewall exceptions are made. It could be just your region or particular modem works behind the NAT but NOT ALL!!

    Leave a comment:


  • replied
    All i did was add ALL ports to my firewall and update to patch 101 and now i have 5 servers online all running great

    Leave a comment:


  • replied
    Originally posted by bn_avit View Post
    P.S we dont want to do command line because it is unsafe...
    I honestly don't mean to be a douche, but ... unsafe? This entire forum basically consists of information about running a server from a commandline.

    UT3 works just fine from behind a router with NAT. Please search this forum for examples, or start with the FAQ up top.

    Also, there is a new patch on the horizon which we hope will solve some people's problems. Please stay tuned.

    Leave a comment:


  • started a topic Theres got to be away of running a server behind NAT

    Theres got to be away of running a server behind NAT

    THE NITWITTS server has been running now for years with no problems with router hosting but then UT3 comes along and has no NAT capabilites which is really bad considering that more and more people are getting routers, no offence to Epic becasue they have given us one of the best games i have ever played but I would of thought they would of included this feature but who am I to judge... We have the beta patch and all is good apart from we get the error 'consult your router manual for the correct port forwarding codes and DMZ' but we dont have a manual it did not come with one grrrrrr.Can someone that knows these codes and what DMZ is (I have no idea lol) please report back as quick as possible because all our regulars want to play but we cant get the server up grrrrrrr and if anyone has had any luck in runnig a server behind a NAT also respond would like to know how you got it to work ...
    P.S we dont want to do command line because it is unsafe...
    Thanks so much to all that reply
Working...
X