Announcement

Collapse

The Infinity Blade Forums Have Moved

We've launched brand new Infinity Blade forums with improved features and revamped layout. We've also included a complete archive of the previous posts. Come check out the new Infinity Blade forums.
See more
See less

Win32 Server Issue HELP!

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Win32 Server Issue HELP!

    Okay, The server is running, and running FAN-F*&Cking-Tastic other than 1 really big problem... No one outside of my internal Network can join it!

    At home I try to connect to the server and it shows up in the internet games list but when trying to connect it just sits there and looks at me wondering (uh am I supposed to be doing something?)


    Here is my server at the moment startup command line - see any thing I've done wrong in here?

    Server vCTF-Suspense?MaxPlayers=24?MinNetPlayers=0?NumPublicCo nnections=24?NumPrivateConnections=0?NumOpenPublic Connections=24?NumOpenPrivateConnections=0?bShould Advertise=True?bIsLanMatch=False?bUsesStats=True?b AllowJoinInProgress=True?bAllowInvites=True?bUsesP resence=True?bAllowJoinViaPresence=True?bUsesArbit ration=False?bIsDedicated=True?bIsListPlay=False?O wningPlayerName=?PingInMs=0?AverageSkillRating=0.0 00000?GameMode=3?Difficulty=3?PureServer=1?LockedS erver=0?Campaign=0?ForceRespawn=0?CustomMapName=vC TF-Suspense?CustomGameMode=UTGameContent.UTVehicleCTF Game_Content?GoalScore=5?TimeLimit=20?ServerDescri ption=?NumPlay=9?game=UTGameContent.UTVehicleCTFGa me_Content?port=7777?AdminPassword=myth?name=Haunt edBox?alias=HauntedBox -log=DedicatedServer.log -Login=Servername -Password=mypass -unattended

  • #2
    Before someone ask!

    Dlink Router (I know they suck) I do have a ton of suggested ports some doing both TCP and UDP and 57900 and 7777 UDP only fowarded to my internal IP and I'm assuming that it's working due to the fact that the server is showing up in the Internet game section on connections outside my servers local network. I've run many servers in the past from Quake 1 & 2 to Counter-Strike and this is a new one on me... Please help train an old dog this new trick!

    Comment


    • #3
      many servers seem to have this issue, there's a beta patch that can probly be found by googling ut3 patch, or u might want to wait for the official patch to come out.

      is your server behind a nat'd router? are u running any firewall on the server? Did u create your gamespy id from within the ut3 client?

      also try adding udp 27900, udp 27500, udp 13000, and udp 6500

      Comment


      • #4
        make these UDP only?
        yes behind NAT router
        No, all firewalls are disabled.
        Gamespy login was created within' the game the server is strong enough to actually run the game outside of the dos box if I needed it to
        I think I may already have that beta patch wasn't it included in the 1.33GB server download? or is this a patch in it self?

        Comment


        • #5
          patch is seperate, fixed my nat servers though being beta id say run at own risk.

          Comment


          • #6
            no dice ;(

            Installed the patch, didn't do anything far as I can tell other than eat up another 200mb

            secret setting in router that needs to be on/off?

            Comment


            • #7
              no secret settings other then port forwarding... hmmm... anything show in the dedicatedserver.log that might point us towards something?

              Comment


              • #8
                try wireshark

                my only other thought here might be for you to try a packer sniffer and see if u can pick up anything... my guess is perhaps something with gamespy? I added a how-to with specific screenshots for lookin at the gamespyid transaction between your server and gamespy. At the very least you can use to see what happens if someone tries to connect using the ip method..

                http://www.hlkclan.net/forums/viewto...?p=18733#18733

                Comment


                • #9
                  you dont seem to have the multihome switch in that command line? I might be wrong but isnt that needed other wise its advertising the internal IP to the master server list and not the exteranal one? I'm no Guru but it struck me that that might be the problem, I also think the port switch is not a ? argument but a - one at the end like the G-spy login

                  Comment


                  • #10
                    multihome switch is not needed if the servers patched w/beta patch. running 2 servers on nat'd private ip's w/o using multihome switch. Multihome should be used if u have multiple nic's though. At least thats my understanding of it.

                    and yes good pickup on the port it should be
                    -port=7777 though by using the default port of 7777 u really dont need to specify it with a -port= command in the 1st place.

                    Comment


                    • #11
                      Log

                      Here is my dedicatedserver.log file see anything wrong in it?

                      I've tried taking the multihome and port commands out still no luck. I may try and use your exact cut and paste setup from the other post you made on these forums to see if that works. Oh... the 1 error I do seem to keep getting is the botskill not found. Other than that it says everything is fine and works great on the LAN though it shows up in the internet browser.


                      Server Logs:
                      Log: Log file open, 11/26/07 18:17:14
                      Init: Version: 3487
                      Init: Epic Internal: 0
                      Init: Compiled: Nov 12 2007 16:13:38
                      Init: Command line: Server vCTF-Suspense?MaxPlayers=24?MinNetPlayers=0?NumPublicCo nnections=24?NumPrivateConnections=0?NumOpenPublic Connections=24?NumOpenPrivateConnections=0?bShould Advertise=True?bIsLanMatch=False?bUsesStats=True?b AllowJoinInProgress=True?bAllowInvites=True?bUsesP resence=True?bAllowJoinViaPresence=True?bUsesArbit ration=False?bIsDedicated=True?bIsListPlay=False?O wningPlayerName=?PingInMs=0?AverageSkillRating=0.0 00000?GameMode=3?Difficulty=3?PureServer=1?LockedS erver=0?Campaign=0?ForceRespawn=0?CustomMapName=vC TF-Suspense?CustomGameMode=UTGameContent.UTVehicleCTF Game_Content?GoalScore=5?TimeLimit=20?ServerDescri ption=?NumPlay=9?game=UTGameContent.UTVehicleCTFGa me_Content?port=7777?AdminPassword=adminpass?name= HauntedBox?alias=HauntedBox -log=DedicatedServer.log -Login=serverGamespyID -Password=pass -multihome xxx.xxx.xxx.xxx -nohomedir -unattended
                      Init: Base directory: C:\Program Files\Unreal Tournament 3 (Dedicated)\Binaries\
                      Init: Character set: Unicode
                      Log: GConfig::LoadFile has loaded file: ..\UTGame\Config\UTEditor.ini
                      Log: GConfig::LoadFile has loaded file: ..\UTGame\Config\UTEditorUserSettings.ini
                      Log: GConfig::LoadFile has loaded file: ..\UTGame\Config\UTCompat.ini
                      Log: GConfig::LoadFile has loaded file: ..\UTGame\Config\UTEngine.ini
                      Log: GConfig::LoadFile has loaded file: ..\UTGame\Config\UTGame.ini
                      Log: GConfig::LoadFile has loaded file: ..\UTGame\Config\UTInput.ini
                      Log: GConfig::LoadFile has loaded file: ..\UTGame\Config\UTUI.ini
                      Init: Computer: SERVER
                      Init: User: owner
                      Init: CPU Page size=4096, Processors=2
                      Init: High frequency timer resolution =3215.520000 MHz
                      Init: Memory total: Phys=1572332K Pagef=3516960K Virt=2097024K
                      Init: WinSock: version 1.1 (2.2), MaxSocks=32767, MaxUdp=65467
                      Init: WinSock: I am server (192.168.0.31:0)
                      Init: Presizing for 83221 objects not considered by GC, pre-allocating 0 bytes.
                      Init: Object subsystem initialized
                      Init: Startup System Settings:
                      Init: System Settings:
                      Init: StaticDecals=true
                      Init: DynamicDecals=true
                      Init: DynamicLights=true
                      Init: DynamicShadows=true
                      Init: LightEnvironmentShadows=true
                      Init: CompositeDynamicLights=false
                      Init: DirectionalLightmaps=true
                      Init: MotionBlur=true
                      Init: DepthOfField=true
                      Init: Bloom=true
                      Init: QualityBloom=true
                      Init: Distortion=true
                      Init: DropParticleDistortion=false
                      Init: SpeedTreeLeaves=true
                      Init: SpeedTreeFronds=true
                      Init: OnlyStreamInTextures=false
                      Init: LensFlares=true
                      Init: FogVolumes=true
                      Init: FloatingPointRenderTargets=true
                      Init: Trilinear=false
                      Init: OneFrameThreadLag=true
                      Init: UseVsync=false
                      Init: UpscaleScreenPercentage=true
                      Init: Fullscreen=false
                      Init: AllowD3D10=true
                      Init: EnableHighPolyChars=false
                      Init: SkeletalMeshLODBias=0
                      Init: ParticleLODBias=0
                      Init: DetailMode=2
                      Init: ShadowFilterQualityBias=0
                      Init: MaxAnisotropy=4
                      Init: MaxMultisamples=1
                      Init: MinShadowResolution=32
                      Init: MaxShadowResolution=512
                      Init: ResX=800
                      Init: ResY=600
                      Init: ScreenPercentage=100.000
                      Init: SceneCaptureStreamingMultiplier=1.000
                      Init: FoliageDrawRadiusMultiplier=1.000
                      Init: ShadowTexelsPerPixel=2.000
                      Log: TEXTUREGROUP_World: (MinLODSize= 1,MaxLODSize=4096,LODBias=0)
                      Log: TEXTUREGROUP_WorldNormalMap: (MinLODSize= 1,MaxLODSize=4096,LODBias=0)
                      Log: TEXTUREGROUP_WorldSpecular: (MinLODSize= 1,MaxLODSize=4096,LODBias=0)
                      Log: TEXTUREGROUP_Character: (MinLODSize= 1,MaxLODSize=4096,LODBias=0)
                      Log: TEXTUREGROUP_CharacterNormalMap: (MinLODSize= 1,MaxLODSize=4096,LODBias=0)
                      Log: TEXTUREGROUP_CharacterSpecular: (MinLODSize= 1,MaxLODSize=4096,LODBias=0)
                      Log: TEXTUREGROUP_Weapon: (MinLODSize= 1,MaxLODSize=4096,LODBias=0)
                      Log: TEXTUREGROUP_WeaponNormalMap: (MinLODSize= 1,MaxLODSize=4096,LODBias=0)
                      Log: TEXTUREGROUP_WeaponSpecular: (MinLODSize= 1,MaxLODSize=4096,LODBias=0)
                      Log: TEXTUREGROUP_Vehicle: (MinLODSize= 1,MaxLODSize=4096,LODBias=0)
                      Log: TEXTUREGROUP_VehicleNormalMap: (MinLODSize= 1,MaxLODSize=4096,LODBias=0)
                      Log: TEXTUREGROUP_VehicleSpecular: (MinLODSize= 1,MaxLODSize=4096,LODBias=0)
                      Log: TEXTUREGROUP_Effects: (MinLODSize= 1,MaxLODSize=4096,LODBias=0)
                      Log: TEXTUREGROUP_Skybox: (MinLODSize= 1,MaxLODSize=4096,LODBias=0)
                      Log: TEXTUREGROUP_UI: (MinLODSize= 1,MaxLODSize=4096,LODBias=0)
                      Log: TEXTUREGROUP_LightAndShadowMap: (MinLODSize= 1,MaxLODSize=4096,LODBias=0)
                      Log: TEXTUREGROUP_RenderTarget: (MinLODSize= 1,MaxLODSize=4096,LODBias=0)
                      Init: Friendly System Settings:
                      Init: TextureDetail=Custom
                      Init: WorldDetail=Custom
                      Init: bUseVSync=0
                      Init: bUseMSAA=0
                      Init: ScreenPercentage=100
                      Init: UpscaleScreenPercentage=1
                      Init: ResX= 800
                      Init: ResY= 600
                      Init: Fullscreen=0
                      Init: OS stats:
                      Init: Windows XP Service Pack 2
                      Init: RemoteDesktop=0
                      Init: Memory stats:
                      Init: Physical: 1535MB
                      Init: Virtual: 2047MB
                      Init: PageFile: 3434MB
                      Init: CPU stats:
                      Init: MeasuredPerformanceTime: 678.748 (measured now)
                      Init: Hyperthreaded: 1
                      Init: NumProcessorsPerCPU: 2
                      Init: NumLogicalProcessors: 2
                      Init: NumPhysicalProcessors: 1
                      Init: MaxSpeed: 3215
                      Init: CurrentSpeed: 3215
                      Init: CoresPerProcessor: 1
                      Init: IsOnBattery: 0
                      Init: BatteryLevel: -1
                      Init: Manufacturer: Intel
                      Init: CPUName: INTEL Pentium-Extreme Edition
                      Init: L1CacheSize: 16
                      Init: L2CacheSize: 1024
                      Init: Architecture: x86
                      Init: GPU stats:
                      Init: VendorID: 000010DE
                      Init: DeviceID: 00000326
                      Init: DriverVersion: 6.14.11.6375
                      Init: DeviceName: NVIDIA GeForce FX 5500
                      Init: DriverName: nv4_disp.dll
                      Init: PixelShaderVersion: 2
                      Init: VertexShaderVersion: 2
                      Init: VRAMQuantity: 128
                      Init: DedicatedVRAM: 124
                      Init: AdapterCount: 1
                      Init: SupportsHardwareTnL: 1
                      Init: GPU DeviceID found in ini: (1) GeForce FX 5500
                      Init: Machine detected compatibility level: Composite: 1. CPU: 3. GPU: 1.
                      Init: Previous detected compatibility level: Composite: 0. CPU: 0. GPU: 0.
                      Init: System Settings changed using SetFriendlyGraphicsSettings:
                      Init: System Settings:
                      Init: StaticDecals=false
                      Init: DynamicDecals=false
                      Init: DynamicLights=false
                      Init: DynamicShadows=false
                      Init: LightEnvironmentShadows=false
                      Init: CompositeDynamicLights=true
                      Init: DirectionalLightmaps=false
                      Init: MotionBlur=false
                      Init: DepthOfField=false
                      Init: Bloom=false
                      Init: QualityBloom=false
                      Init: Distortion=false
                      Init: DropParticleDistortion=true
                      Init: SpeedTreeLeaves=false
                      Init: SpeedTreeFronds=false
                      Init: OnlyStreamInTextures=false
                      Init: LensFlares=false
                      Init: FogVolumes=true
                      Init: FloatingPointRenderTargets=true
                      Init: Trilinear=false
                      Init: OneFrameThreadLag=true
                      Init: UseVsync=false
                      Init: UpscaleScreenPercentage=true
                      Init: Fullscreen=true
                      Init: AllowD3D10=true
                      Init: EnableHighPolyChars=false
                      Init: SkeletalMeshLODBias=1
                      Init: ParticleLODBias=2147483647
                      Init: DetailMode=0
                      Init: ShadowFilterQualityBias=-1
                      Init: MaxAnisotropy=0
                      Init: MaxMultisamples=1
                      Init: MinShadowResolution=32
                      Init: MaxShadowResolution=512
                      Init: ResX=640
                      Init: ResY=480
                      Init: ScreenPercentage=50.000
                      Init: SceneCaptureStreamingMultiplier=1.000
                      Init: FoliageDrawRadiusMultiplier=0.000
                      Init: ShadowTexelsPerPixel=2.000
                      Log: TEXTUREGROUP_World: (MinLODSize= 256,MaxLODSize= 256,LODBias=0)
                      Log: TEXTUREGROUP_WorldNormalMap: (MinLODSize= 256,MaxLODSize= 256,LODBias=0)
                      Log: TEXTUREGROUP_WorldSpecular: (MinLODSize= 256,MaxLODSize= 256,LODBias=0)
                      Log: TEXTUREGROUP_Character: (MinLODSize= 256,MaxLODSize= 256,LODBias=0)
                      Log: TEXTUREGROUP_CharacterNormalMap: (MinLODSize= 256,MaxLODSize= 256,LODBias=0)
                      Log: TEXTUREGROUP_CharacterSpecular: (MinLODSize= 256,MaxLODSize= 256,LODBias=0)
                      Log: TEXTUREGROUP_Weapon: (MinLODSize= 256,MaxLODSize= 256,LODBias=0)
                      Log: TEXTUREGROUP_WeaponNormalMap: (MinLODSize= 256,MaxLODSize= 256,LODBias=0)
                      Log: TEXTUREGROUP_WeaponSpecular: (MinLODSize= 256,MaxLODSize= 256,LODBias=0)
                      Log: TEXTUREGROUP_Vehicle: (MinLODSize= 256,MaxLODSize= 256,LODBias=0)
                      Log: TEXTUREGROUP_VehicleNormalMap: (MinLODSize= 256,MaxLODSize= 256,LODBias=0)
                      Log: TEXTUREGROUP_VehicleSpecular: (MinLODSize= 256,MaxLODSize= 256,LODBias=0)
                      Log: TEXTUREGROUP_Effects: (MinLODSize= 256,MaxLODSize= 256,LODBias=0)
                      Log: TEXTUREGROUP_Skybox: (MinLODSize= 256,MaxLODSize= 512,LODBias=2)
                      Log: TEXTUREGROUP_UI: (MinLODSize= 256,MaxLODSize=4096,LODBias=0)
                      Log: TEXTUREGROUP_LightAndShadowMap: (MinLODSize= 256,MaxLODSize= 512,LODBias=1)
                      Log: TEXTUREGROUP_RenderTarget: (MinLODSize= 1,MaxLODSize=4096,LODBias=0)
                      Init: Friendly System Settings:
                      Init: TextureDetail=Level1
                      Init: WorldDetail=Level1
                      Init: bUseVSync=0
                      Init: bUseMSAA=0
                      Init: ScreenPercentage= 50
                      Init: UpscaleScreenPercentage=1
                      Init: ResX= 640
                      Init: ResY= 480
                      Init: Fullscreen=1
                      Init: Writing new compatibility level to ini. Composite: 1. CPU: 3. GPU: 1.
                      Log: Initializing FaceFX...
                      Log: FaceFX initialized:
                      Log: version 1.710000
                      Log: licensee Unreal Engine 3 Licensee
                      Log: project Unreal Engine 3 Project
                      Log: GConfig::Find has loaded file: ..\Engine\Localization\int\Core.int
                      Log: GConfig::Find has loaded file: ..\Engine\Localization\int\Engine.int
                      Log: Loaded shader cache RefShaderCache-PC-D3D-SM2.CacheObject: 20451 shaders(0 legacy, 0 redundant), 2371 materials
                      Log: GConfig::Find has loaded file: ..\Engine\Localization\int\UnrealScriptTest.int
                      Log: GConfig::Find has loaded file: ..\UTGame\Localization\int\UTGame.int
                      Log: GConfig::LoadFile has loaded file: ..\UTGame\Config\UTWeapon.ini
                      Log: GConfig::LoadFile has loaded file: ..\UTGame\Config\UTCustomChar.ini
                      Log: GConfig::LoadFile associated file: ..\UTGame\Config\UTMap.ini
                      Log: GConfig::Find has loaded file: ..\Engine\Localization\int\OnlineSubsystemGameSpy. int
                      Init: Version: 3487
                      Init: Epic Internal: 0
                      Init: Compiled: Nov 12 2007 16:14:54
                      Init: Command line: vCTF-Suspense?MaxPlayers=24?MinNetPlayers=0?NumPublicCo nnections=24?NumPrivateConnections=0?NumOpenPublic Connections=24?NumOpenPrivateConnections=0?bShould Advertise=True?bIsLanMatch=False?bUsesStats=True?b AllowJoinInProgress=True?bAllowInvites=True?bUsesP resence=True?bAllowJoinViaPresence=True?bUsesArbit ration=False?bIsDedicated=True?bIsListPlay=False?O wningPlayerName=?PingInMs=0?AverageSkillRating=0.0 00000?GameMode=3?Difficulty=3?PureServer=1?LockedS erver=0?Campaign=0?ForceRespawn=0?CustomMapName=vC TF-Suspense?CustomGameMode=UTGameContent.UTVehicleCTF Game_Content?GoalScore=5?TimeLimit=20?ServerDescri ption=?NumPlay=9?game=UTGameContent.UTVehicleCTFGa me_Content?port=7777?AdminPassword=adminpass?name= HauntedBox?alias=HauntedBox -log=DedicatedServer.log -Login=ServergamespyID -Password=password -multihome xxx.xxx.xxx.xxx -nohomedir -unattended
                      Init: Base directory: C:\Program Files\Unreal Tournament 3 (Dedicated)\Binaries\
                      Init: Character set: Unicode
                      Log: Executing Class Engine.ServerCommandlet
                      Log: Initializing Game Engine...
                      Log: GConfig::Find has loaded file: ..\Engine\Localization\int\Editor.int
                      Log: GConfig::Find has loaded file: ..\UTGame\Localization\int\UTEditor.int
                      Init: UEngine initialized
                      Log: Looking for DLC...
                      Log: Object size..............: 60
                      Log: Actor size...............: 436
                      Log: ActorComponent size......: 88
                      Log: PrimitiveComponent size..: 448
                      Log: Browse: vCTF-Suspense?name=HauntedBox?team=255?MaxPlayers=24?Mi nNetPlayers=0?NumPublicConnections=24?NumPrivateCo nnections=0?NumOpenPublicConnections=24?NumOpenPri vateConnections=0?bShouldAdvertise=True?bIsLanMatc h=False?bUsesStats=True?bAllowJoinInProgress=True? bAllowInvites=True?bUsesPresence=True?bAllowJoinVi aPresence=True?bUsesArbitration=False?bIsDedicated =True?bIsListPlay=False?OwningPlayerName=?PingInMs =0?AverageSkillRating=0.000000?GameMode=3?Difficul ty=3?PureServer=1?LockedServer=0?Campaign=0?ForceR espawn=0?CustomMapName=vCTF-Suspense?CustomGameMode=UTGameContent.UTVehicleCTF Game_Content?GoalScore=5?TimeLimit=20?ServerDescri ption=?NumPlay=9?game=UTGameContent.UTVehicleCTFGa me_Content?port=7777?AdminPassword=adminpass?alias =HauntedBox
                      Log: LoadMap: vCTF-Suspense?name=HauntedBox?team=255?MaxPlayers=24?Mi nNetPlayers=0?NumPublicConnections=24?NumPrivateCo nnections=0?NumOpenPublicConnections=24?NumOpenPri vateConnections=0?bShouldAdvertise=True?bIsLanMatc h=False?bUsesStats=True?bAllowJoinInProgress=True? bAllowInvites=True?bUsesPresence=True?bAllowJoinVi aPresence=True?bUsesArbitration=False?bIsDedicated =True?bIsListPlay=False?OwningPlayerName=?PingInMs =0?AverageSkillRating=0.000000?GameMode=3?Difficul ty=3?PureServer=1?LockedServer=0?Campaign=0?ForceR espawn=0?CustomMapName=vCTF-Suspense?CustomGameMode=UTGameContent.UTVehicleCTF Game_Content?GoalScore=5?TimeLimit=20?ServerDescri ption=?NumPlay=9?game=UTGameContent.UTVehicleCTFGa me_Content?port=7777?AdminPassword=adminpass?alias =HauntedBox
                      Log: Virtual memory allocation size: 114.86 MByte (120442880 Bytes)
                      Log: Physical memory allocation size: 0.00 MByte (0 Bytes)
                      Log: GConfig::Find has loaded file: ..\UTGame\Localization\int\UTGameContent.int
                      Log: Game class is 'UTVehicleCTFGame_Content'
                      Init: WinSock: Socket queue 131072 / 131072
                      Log: NetMode is now 1
                      Log: Primary PhysX scene will be in software.
                      Log: Creating Primary PhysX Scene.
                      Log: Novodex Terrain Creation (Terrain_1): 15.156250 ms
                      PerfWarning: InstanceGeom: 15.186243 ms - 1242 Convex, Terrain 15.123390 ms, PerTriSM 0.000000 ms, InitArticulated 0.000000 ms, BodyInst Alloc 9.233419 ms, InitBody 63.106272 ms
                      PerfWarning: NxActor Creation: 40.867310 ms
                      Log: Bringing World vCTF-Suspense.TheWorld up for play (30) at 2007.11.26-18.17.23
                      ScriptLog: MinNetPlayers: 0
                      ScriptLog: -- MAPVOTE has been disabled due to lack of maps!
                      Log: Bringing up level for play took: 0.952459
                      Log: ########### Finished loading level: 2.993500 seconds
                      Init: Game engine initialized
                      Log: Initializing Game Engine Completed
                      Error: Requested localized string setting BotSkill was not found
                      Log: GAME PATH IS UTVehicleCTFGame_Content
                      Log:
                      Log: Success - 0 error(s), 0 warning(s)
                      Log:
                      Execution of commandlet took: 5.76 seconds
                      Exit: Preparing to exit.
                      Exit: Game engine shut down
                      Exit: closesocket error (0)
                      Exit: UTcpNetDriver shut down
                      Exit: Object subsystem successfully closed.
                      Log: Shutting down FaceFX...
                      Log: FaceFX shutdown.
                      Exit: Exiting.
                      Exit: Name subsystem shutting down
                      Uninitialized: Log file closed, 11/26/07 18:17:30

                      Comment


                      • #12
                        Read this http://forums.epicgames.com/showthre...=587050&page=2

                        Comment


                        • #13
                          With the patch, you do not need the multihome= switch unless your Network Card has more than one IP address bound to it. Also, i noticed some parameters specified without arguments. I would try simplifying your command line and see what changes. Try this:

                          Code:
                          ut3.exe Server vCTF-Suspense?game=UTGameContent.UTVehicleCTFGame_Content?numplay=8?MaxPlayers=24?MinNetPlayers=0?NumPublicConnections=24?NumPrivateConnections=0?NumOpenPublic Connections=24?NumOpenPrivateConnections=0?bShouldAdvertise=True?bUsesStats=True?b AllowJoinInProgress=True?bIsDedicated=True?GameMode=3?Difficulty=3?PureServer=1?ForceRespawn=0?GoalScore=5?TimeLimit=20?port=7777?AdminPassword=XXXXX -log=DedicatedServer.log -Login=YourGameSpyUsername -Password=YourGameSpyPassword -nohomedir -unattended
                          1. Make sure to substitute your own Gamespy username and password where appropriate. Also, make sure you have setup the GameSpy account you plan to use in the client version of the game and that it is different from the account you use to play. Every instance of the game- server or client- needs to have a unique Gamespy account assigned.
                          2. Make sure you substitute your own AdminPassword where appropriate.

                          NOTE: I suggest you edit your log post above to censor your personal information.

                          If you are still having trouble, remove the game and patch. Also remove all your port forwards and follow Dubious' instructions step-by-step. These should work for you fine. From there, you can add more switches as you deem necessary.

                          Good Luck! -WB

                          Comment


                          • #14
                            if ur really stuck, run wireshark, save the results and email to me and ill look at it for you. havoksunreal@hotmail.com

                            Comment


                            • #15
                              hmm well this is confusing (i emailed u back), the packet capture looks fine, i could see his server send to gamespy, and then see the authorization reply.....

                              Comment

                              Working...
                              X