Announcement

Collapse
No announcement yet.

Running a server behind a router -multihome switch doesn't function

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    Originally posted by AZ-{OVGY} View Post
    My router is a DLink DI-524 in DMZ Mode for my internal IP (until I get it working like that), windows firewall disabled, kaspersky disabled. I even added my computer name and external ip in windows hosts file to see if that would do anything. Tried both the retail and dedicated server versions both with Beta patch 101 installed.
    First off, my apologies - I must have had you confused with someone else when I stated that I had the exact same router as you. I do have a DLink though so Im sure its basically the same config. Second, I can tell that you are more knowledgeable than the average Joe who is trying to run a server. Which is both good and bad. Its good because you understand what things mean but bad because its evident that you are trying to do more than just the simple things.

    If I were you and I were trying to get this working, I'd do it EXACTLY the same way as someone else who has the same setup. I wouldnt change the default port, I wouldnt put my server into a DMZ, and I wouldnt modify the commandline to include many different other settings. I wouldnt add entries to my host file, or registry entries.

    I would uninstall my dedicated server and start over with a new copy. I would copy-n-paste the commandline exactly as it was provided to me (other than username/password) even if it meant that my server would be a VCTF server for a few min while I test it out. I would port-forward ONLY the ports listed. And I would get someone who already has the 101 patch installed to test by connecting only through the in-game browser, not using the 'open xxx.xxx.xxx.xxx' command in the console.

    And if you PROMISE that you tried that procedure EXACTLY and THAT doesnt work .... then Im stumped.

    But thats just me. The problem is that I perform network troubleshooting for a living so I'm a stickler about this kinda stuff.

    On a side note, the ports that you see bound to ut3.exe other than 13000, 6500, and (in your case) 3333 are all dynamically-created each time you restart the server so they will always change. They were not needed to be forwarded to my private IP address in order to get my server working.

    Comment


      #17
      I have been trying to do more than the simple things because the simple things didn't work on a pc that I have used to run ut2004 servers for a while. The command line and ports are the final set that I used after building up from the basic of commands which didn't work. I ended up with the bulk of this command because I decided to host the server from in the game and use the log file from that to get a commandline as I was in the hope that if the game generated me one with the basic settings I require then it should work. The port is different because I did use 7777 to start with which didn't work and have been using different ones since to see if that had any affect. I am going to uninstall the game/server and start from scratch to see if I have any better luck although I am not very optimistic. I did create the gamespy id for it in the retail game. The entries in my hosts file and registry have since been removed as I was only testing them as a last resort. I have been trying to get a server going since the beta came out and have hosted many servers before with no where near as much trouble. I also have used some of the claimed working command lines that can be found in this forum and not one of them works, all of this is why I have come to the conclusion that this game clearly isn't capable of communicating properly with all routers, hence my router thread that you posted in. That was another last resort to see if I could gather any more useful info. But anyways like I said, I am going to start everything from scratch and will post back once I have done this. I may even create another game spy id to see if that works.

      Comment


        #18
        I'll keep my fingers crossed for you.

        Comment


          #19
          Look at their Job Openings! :P

          Originally posted by darksky View Post
          Man, probably because Epic outsourced their IT! Outsourcing partners are inept at best in my experience.
          Just Look at their Job Openings!

          Comment


            #20
            DUBIOUS I have done what I said I would and guess what, still no luck. I am now 99% sure this is because UT3 even with the beta patch isn't fully capable of utilising all routers. I am also sure that it is because of port 6500 UDP which is reporting the local ip in kaspersky as my internal ip rather than 0.0.0.0 which pretty much every application I have installed that uses the internet uses. I also updated my router firmware to the latest release and didn't help. I decided to reset my router completely and start one of my ut2k4 servers, as you would expect it didn't work as the ports weren't forwarded so I made one change to the router which was to use DMZ (I wouldn't use DMZ usually, but for the purpose of testing this and proving my point I will). I never bothered forwarding the right ports as what I am trying to prove is that UT3 will not work even if I did. For those who don't allready know what DMZ is i'll tell you, DMZ basically tells the router to treat the computer as though it is on the other side of the router, all ports are open so portforwarding is not needed for this test I have performed (do not use DMZ permanently as it is a security risk but if you cannot get ut3 working it might be an idea to test with this to see if it makes a difference, if it does then you will know you have a port forward problem, if not then your in the same boat as me). Anyways like I said I enabled DMZ and guess what, the server worked, kaspersky showed that the ports used were reporting internal ip 0.0.0.0 which is what is needed for it to work. Then I reset router again and started the UT3 server, again as you would expect it didn't work because of the ports not being forwarded. As I did before I made one change to the router and that was the DMZ, guess what server still didn't work. Kaspersky showed that the ports used for the server were reporting local ip as 0.0.0.0 apart from 6500 UDP which was reporting my internal ip. I am very sure that if this port reported 0.0.0.0 then my setup would work. I am currently hoping that the full beta patch will fix this but for now I am sure that UT3 is incapable of working on my system. Also my command line is working too, I tried using the server without the router to test this and to test wether or not my ISP was blocking any ports as some have suggested, it worked fine.

            (This test was performed with windows firewall disabled and kaspersky disabled, kaspersky was only use to check ports)

            Comment


              #21
              Sigh. Ok, thanks for the update, and good troubleshooting there.

              Comment


                #22
                AZ-{OVGY},
                While not quite the same model I do have a Dlink DI-624 (I think i read somewhere u were using a DI-524) in my office, so I will test with that and try to run a server behind it. Although if it works, being a diff model not sure what it proves, but what the hell, ill give it a go anyway!

                Comment


                  #23
                  Couldn't login to game spy profile this morning, neither my profile nor the server. It allowed me about 10 mins l8er. When I started server after this I got all kinds of new things in it. Devonline was one of them which included things like login ticket, player status.I never had these before, I couldn't see the server in browser so I just connected to ip, and it worked. Since the map changed it keeps saying DevOnline: Failed to register server with error 0x00000005 (No challenge value was received from the master server.)
                  DevOnline: Treating server as private (invite, follow only). Not sure if it worked because there were changes happening with master server but for me to be able to connect just once without making a change to my setup makes me feel that maybe something is actually being done about this.

                  Comment

                  Working...
                  X