Announcement

Collapse
No announcement yet.

Running a server behind a router -multihome switch doesn't function

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Running a server behind a router -multihome switch doesn't function

    I have my PC that I'd like to use as a server behind a router. My understanding is that one needs to use the -multihome=ipaddy switch where "ipaddy" is your external IP address. When I do this, I get the following error and ut3.exe promptly crashes:

    Code:
    ...
    Log: Failed to listen: WinSock: binding to port 7777 failed (10049)
    ...
    Log: === Critical error: ===
    General protection fault!
    
    History: Address = 0x970340   (filename not found) 
    
    Exit: Executing UObject::StaticShutdownAfterError
    Exit: Executing UWindowsClient::ShutdownAfterError
    Log: Shutting down FaceFX...
    Log: FaceFX shutdown.
    Exit: Exiting.
    Exit: Name subsystem shutting down
    Uninitialized: Log file closed, 11/24/07 04:20:12
    I can post the entire log file upon request, but that pretty much sums up the errors.

    Here is my batch file used to launch the server (I replaced my l/p with XXX and as well, I blanked out my real IP addy
    Code:
    ut3.exe server vCTF-Suspense?Game=UTGameContent.UTVehicleCTFGame_Content?GameMode=3?numplay=4?maxplayers=16?NumPublicConnections=16?NumPrivateConnections=0?NumOpenPublicConnections=16?NumOpenPrivateConnections=0?bShouldAdvertise=True?bIsDedicated=True?PureServer=1?timelimit=30?goalscore=5?botskill=3?AdminPassword=XXX? -log=server.log -Login=XXX -Password=XXX -multihome=xxx.xxx.xxx.xxx -nohomedir -unattended
    If I keep everything the same except remove the -multihome=xxx.xxx.xxx.xxx line, the server works.

    #2
    I have had the same problem. I've given up trying to make it work. I keep reading these forums, but I don't see anything from Epic. Even their own stickies aren't being updated.

    Sad. People like us form the technical core of the UT community yet the silence is deafening.

    Comment


      #3
      I have got the same problem...and I am still waiting for the patch to fix this.

      Comment


        #4
        Man, probably because Epic outsourced their IT! Outsourcing partners are inept at best in my experience.

        Comment


          #5
          I am passionate about UT and technical excellence. I have walked into mult-imillion dollar fusterclucks before and turned them around. Politics are harder to solve then technical problems so at this point, I have a theory that it more of an internal non-technical problem then anything else.
          Sad. The silence is still deafening.

          Comment


            #6
            Originally posted by lolli11 View Post
            I have got the same problem...and I am still waiting for the patch to fix this.
            I'm using the beta patch at the minute and that hasnt fixed it, I wouldn't hold your breath.

            Comment


              #7
              You can try to add to the target in properties of your UT3.exe shortcut on the end of the target string in the .exe that you boot the server or game from.

              example looks like:



              Code:
              "C:\Program Files\Unreal Tournament 3\Binaries\UT3.exe" -multihome=xxx.xxx.xxx.xxx

              Comment


                #8
                Try this

                -multihome=xxx.xxx.xxx.xxx -port 7777

                Comment


                  #9
                  Originally posted by sWs»Fish View Post
                  Try this

                  -multihome=xxx.xxx.xxx.xxx -port 7777
                  Allready tried that, doesn't work for me.

                  Comment


                    #10
                    Download and install the patch, dont use the multihome switch. Details are in this thread: http://gearsforums.epicgames.com/sho...d.php?t=587587

                    Comment


                      #11
                      Originally posted by Dubious View Post
                      Download and install the patch, dont use the multihome switch. Details are in this thread: http://gearsforums.epicgames.com/sho...d.php?t=587587
                      Allready tried that, doesn't work.

                      Comment


                        #12
                        Originally posted by AZ-{OVGY} View Post
                        Allready tried that, doesn't work.
                        I don't want to say that you are doing something wrong, but if you and I have the exact same model router, both are running windows, both are using the same default server and patch configurations, and both are using the same batch file then it should work for you just as it does for me.

                        You must be doing something differently. Either you aren't allowing the service through the Windows firewall correctly or you arent forwarding the ports correctly or something similar. Well, either that or your ISP is blocking ports but I would find that impossible since all of the ports in question are considered random high ports (> 1024) and thus blocking these ports could cause problems for general internet services as well.

                        The only way that I can compare your config to my config is if you post screenshots of the port forwarding config on your router, your Windows firewall exceptions, and your exact commandline (minus passwords, of course).

                        Comment


                          #13
                          Originally posted by nomadicus View Post
                          I have had the same problem. I've given up trying to make it work. I keep reading these forums, but I don't see anything from Epic. Even their own stickies aren't being updated.

                          Sad. People like us form the technical core of the UT community yet the silence is deafening.
                          Agreed... until Epic can get their act together and the get the server up and running like it supposed to run with routers, mutators and all I have put my server on the back burner. I tired of being their beta tester and not getting paid for it.

                          Comment


                            #14
                            Originally posted by Dubious View Post
                            I don't want to say that you are doing something wrong, but if you and I have the exact same model router, both are running windows, both are using the same default server and patch configurations, and both are using the same batch file then it should work for you just as it does for me.

                            You must be doing something differently. Either you aren't allowing the service through the Windows firewall correctly or you arent forwarding the ports correctly or something similar. Well, either that or your ISP is blocking ports but I would find that impossible since all of the ports in question are considered random high ports (> 1024) and thus blocking these ports could cause problems for general internet services as well.

                            The only way that I can compare your config to my config is if you post screenshots of the port forwarding config on your router, your Windows firewall exceptions, and your exact commandline (minus passwords, of course).
                            My router is a DLink DI-524 in DMZ Mode for my internal IP (until I get it working like that), windows firewall disabled, kaspersky disabled. I even added my computer name and external ip in windows hosts file to see if that would do anything. Tried both the retail and dedicated server versions both with Beta patch 101 installed.

                            UT3.exe Server DM-Arsenal?MaxPlayers=10?MinNetPlayers=0?NumPublicCon nections=10?NumPrivateConnections=0?NumOpenPublicC onnections=10?NumOpenPrivateConnections=0?bShouldA dvertise=True?bIsLanMatch=False?bUsesStats=True?bA llowJoinInProgress=True?bAllowInvites=True?bUsesPr esence=True?bAllowJoinViaPresence=True?bUsesArbitr ation=False?bIsDedicated=True?bIsListPlay=False?Ow ningPlayerName=?PingInMs=0?AverageSkillRating=0.00 0000?GameMode=0?Difficulty=2?PureServer=1?LockedSe rver=0?Campaign=0?ForceRespawn=1?CustomMapName=DM-Arsenal?CustomGameMode=UTGame.UTDeathmatch?GoalSco re=30?TimeLimit=30?ServerDescription=0850000750000 32000085000084000051000032000068000077000032000083 00010100011400011800010100011400003200004500003200 01190001190001190000460001110001180001030001210000 99000108000097000110000046000099000111000109000?Nu mPlay=6?game=UTGame.UTDeathmatch?name=xxxxx?alias= xxxxx -log=DedicatedServer.log -Login=xxxxx -Password=xxxxx -port 3333 -unattended

                            I've tried all kinds of variations to this command including adding -multihome=xx.xx.xx.xx which resulted in a could not bind error, another thread suggested I give a dns name in router and then edit the registry to correspond to that, didn't work though. I even opened kaspersky whilst server was running to see what ports it was using,

                            13000 UDP
                            1325 UDP
                            3333 UDP
                            1326 TCP
                            1327 TCP
                            1328 UDP
                            6500 UDP

                            I have forwarded all these in router.

                            The one thing that puzzles me is when I start a ut2k4 server on the same machine and check in kaspersky, the ports it uses are all using local ip 0.0.0.0. However when I check the same with the ut3 server all ports are like this except 6500 UDP which is using my internal ip address as the local ip. Difference between the two is the ut2k4 server accepts clients the UT3 doesn't.

                            Comment


                              #15
                              One of the three servers I am hosting is on a nat'd private network (public ip on hardware firewall wan port). I made some simple rules for forwarding the following ports

                              7776 8000 UDP
                              27500 27900 UDP
                              6500 6600 UDP
                              27000 27000 UDP
                              13000 13000 UDP

                              my command line on server (internal ip of 192.168.168.200)

                              D:\Unreal~1\Binaries\UT3.exe server WAR-Avalanche?MaxPlayers=16?MinNetPlayers=0?NumPublicC onnections=16?NumPrivateConnections=0?NumOpenPubli cConnections=16?NumOpenPrivateConnections=0?bShoul dAdvertise=True?bIsLanMatch=False?bUsesStats=True? bAllowJoinInProgress=True?bAllowInvites=True?bUses Presence=True?bAllowJoinViaPresence=True?bUsesArbi tration=False?bIsDedicated=True?bIsListPlay=False? OwningPlayerName=?PingInMs=0?AverageSkillRating=0. 000000?GameMode=2?Difficulty=2?PureServer=1?Locked Server=0?Campaign=0?ForceRespawn=0?CustomMapName=W AR-Avalanche?CustomGameMode=UTGameContent.UTOnslaught Game_Content?GoalScore=5?TimeLimit=30?ServerDescri ption=12300010400007600010700012500003200011400010 10000990001140001170001050001160001050001100001030 00044000032000119000119000119000046000104000108000 10700009900010800009700011000004600011000010100011 6000047000102000111000114000117000109000115000?Num Play=1?game=UTGameContent.UTOnslaughtGame_Content? name=hlk_3?alias=hlk_3?AdminPassword=myadminpwd -log=DedicatedServer.log -Login=mygamespyid -Password=mygamespypwd -nohomedir -unattended


                              I am using the beta patch on server and my client (seperate pc on that same pvt lan).

                              the particular server above is my warfare server
                              you can see it under warfare as {hLk}'s recruiting, www.hlkclan.net

                              what got it working for me was creating the gamespyid for the server from my ut3 retail full game. Once i created it there i simply used the new id/pwd on the server and went back to my old one on the client. I wasnt getting errors prior to this however server could not be seen. Ran a packet sniffer (wireshark) and captured the message from gamespy back to server saying uniqueid invalid. Once I created the gamespyid from within the ut3 client it was then viewable in the browser. hope this helps.

                              edited - noticed when i copied and pasted this forum inserted spaces where there shouldnt be in some parts of the command line so backspace em out if u need to use mine as a template.

                              Comment

                              Working...
                              X