Announcement

Collapse
No announcement yet.

INI performance & graphics tweaks here

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    try the UT3 tweaker in my sig

    8000 downloads since march cant be wrong

    Leave a comment:


  • replied
    Guys my graphics look like ****. Looks like the kinda graphics i had on my nintendo 64, on a game called doom 64.





    Can someone tell me what tweaks i need to do to make it look normal, I have a NVIDIA GeForce 7600 GS. 32 bit

    Leave a comment:


  • replied
    @MTL

    Geforce 8+ doesn't use 16-bit anymore. It's all just a clipped color range, which is why old games look like **** on 16-bit on these cards (and the new Radeons).
    As for the Radeons... they were always the same speed in 16-bit vs 32-bit.

    Nowadays Unreal Engine 3 by default uses 64-bit precision and "turning HDR off" does NOT affect it in any way. You'd be just changing exposure/post-processing settings that way.

    Leave a comment:


  • replied
    Originally posted by [FfFC]_-(MAD)-_ View Post
    I tried to enable 16Bit support. Maybe i will find a solution. Would be cool if Epic enables 16Bit support, so maybe older grafic-cards will run very fast. It will disable HDR and 24Bit Z-Buffer, so it would not look as good as in 32Bit, but it will run very fast. On Nvidia it will increase FPS dramatically, on ATI it is possible to select a higher resolution with the same framerate.

    16Bit textures are fine, too. Little quality loss, but it saves RAM/GPU Ram.
    I cant seem to figure out how to get this to work and would like to try it. Do i just change my display settings on my desktop to 16bit? I tried but didnt notice a visual or performance difference during play. Is there an ini line tweak for this?

    Leave a comment:


  • replied
    when i try to save the BaseEngine.ini file it says "cannot create the C:\Program Files\Unreal Tournament 3\Engine\Config\Base Engine.ini File Make sure the path and file name are correct" whats up

    Leave a comment:


  • replied
    bump some people would still like to refer to some of this here. Any binds yet?

    Leave a comment:


  • replied
    This is interesting: http://www.tweakguides.com/UT3_7.html
    The game engine is capped to a maximum framerate, as determined by the value of the MaxSmoothedFrameRate variable (see below), which is 62FPS by default. This is done by the developers to prevent FPS spikes and thus provide smoother performance. However, by setting this option to True, you can completely remove this FPS cap. Keep in mind though that if you then find your framerate varying a great deal and causing jerkiness, this option is best set back to False. Uncapping your FPS doesn't increase overall performance as such, i.e. if you got 35 FPS in certain areas with the cap, you'll still do so without the cap.


    MinSmoothedFrameRate=22
    MaxSmoothedFrameRate=62


    These settings control the framerate range between which the game engine attempts to smooth frames. As covered under the bSmoothFrameRate setting above, if that setting is set to True, the framerate limit specified by the value of MaxSmoothedFrameRate will be enforced. Although you can disable this FPS cap, ideally if you want smooth FPS but don't want the default 62FPS cap, one thing you can do is to set the MaxSmoothedFrameRate to a higher value, e.g. 85. It's usually best to set your FPS cap to match your Refresh Rate, since even with VSync disabled, any framerates above your monitor's refresh rate will simply be partial frames anyway. There's no reason why uncapping your FPS will necessarily provide you a better gameplay advantage, and in fact it may do the opposite due to greater FPS variability, so experiment to see if simply using a higher framerate cap is actually a better compromise of smoothness and performance.
    http://www.tweakguides.com/UT3_8.html
    CompositeDynamicLights=False. "true" gives more fps


    OneFrameThreadLag=False. "true" may give more fps, because it's set to "False" on WorldDetail 5 and True on all others

    Leave a comment:


  • replied
    I tried to enable 16Bit support. Maybe i will find a solution. Would be cool if Epic enables 16Bit support, so maybe older grafic-cards will run very fast. It will disable HDR and 24Bit Z-Buffer, so it would not look as good as in 32Bit, but it will run very fast. On Nvidia it will increase FPS dramatically, on ATI it is possible to select a higher resolution with the same framerate.

    16Bit textures are fine, too. Little quality loss, but it saves RAM/GPU Ram.

    Leave a comment:


  • replied
    here are the first options in the SystemSettings:

    StaticDecals=False
    DynamicDecals=False
    DynamicLights=True
    DynamicShadows=True
    LightEnvironmentShadows=True
    CompositeDynamicLights=False
    DirectionalLightmaps=False

    with these settings, i keep the shadows and the lights effects on the characters/vehicles/weapons while the lights effects doesn't appear on the map. Yes the textures look a bit less detailled because of this, but it still look good, and i gained a bit more FPS with that tweak).

    tweaking the MaxAnisotropy can be a good idea to gain FPS too, like putting 16 to 8

    what does the DetailMode option do? i didn't see a difference between 2 and 1

    Leave a comment:


  • replied
    Hump de BUMP ~RHCP

    Leave a comment:


  • replied
    i just hope the full version of the game will be even more optimized than the beta demo.

    Leave a comment:


  • replied
    Originally posted by phosphene View Post
    Basically, i have to turn down all quality settings and run at 128x800 in order to get acceptable fps(~100) I leave dynamic lights on so i can judge distance on shock rifle combos. My vid card does not support dx10, so i turn it off.

    All this BS should be accessible in-game. This ini tweaking is soooo 1999. Step it up Epic!

    Documents\My Games\Unreal Tournament 3 Demo\UTGame\Config\UTEngine.ini

    [Engine.GameEngine]
    bSmoothFrameRate=False
    MinSmoothedFrameRate=22
    MaxSmoothedFrameRate=300
    bClearAnimSetLinkupCachesOnLoadMap=TRUE

    [SystemSettings]
    StaticDecals=FALSE
    DynamicDecals=FALSE
    DynamicLights=true
    DynamicShadows=FALSE
    LightEnvironmentShadows=false
    CompositeDynamicLights=False
    DirectionalLightmaps=false
    MotionBlur=FALSE
    DepthOfField=FALSE
    Bloom=FALSE
    QualityBloom=FALSE
    Distortion=FALSE
    DropParticleDistortion=False
    SpeedTreeLeaves=FALSE
    SpeedTreeFronds=FALSE
    OnlyStreamInTextures=True
    LensFlares=FALSE
    FogVolumes=FALSE
    FloatingPointRenderTargets=true
    Trilinear=FALSE
    OneFrameThreadLag=False
    UseVsync=False
    UpscaleScreenPercentage=True
    Fullscreen=True
    AllowD3D10=FALSE
    EnableHighPolyChars=FALSE
    SkeletalMeshLODBias=0
    ParticleLODBias=0
    DetailMode=0
    ShadowFilterQualityBias=1
    MaxAnisotropy=0
    MaxMultisamples=1
    MinShadowResolution=32
    MaxShadowResolution=512
    ResX=1280
    ResY=800
    ScreenPercentage=100.000000
    SceneCaptureStreamingMultiplier=1.000000
    FoliageDrawRadiusMultiplier=1.000000
    ShadowTexelsPerPixel=2.000000

    Or you could run it in winxp and get twice that :P
    seriously, i did it, got same specs only 1950pro

    Leave a comment:


  • replied
    i was impressed how well BioShock was running on my computer, i thought it would drop dramatically in framerate, not at all!

    Leave a comment:


  • replied
    Yeah it's not the greatest system in the world, but it's been good to me.

    I'm upgrading in February to something completely new, but until then this will have to get me by.

    Leave a comment:


  • replied
    Athlon 64 3000+ on Socket 939?

    i like the fact my 3700+ have 1mb of L2 cache.

    Leave a comment:

Working...
X