Announcement

Collapse

The Infinity Blade Forums Have Moved

We've launched brand new Infinity Blade forums with improved features and revamped layout. We've also included a complete archive of the previous posts. Come check out the new Infinity Blade forums.
See more
See less

Kernell32.dll error on startup

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    #61
    Same prob here when intel intro has been.
    crash some times to windows en some restart comp.

    system=
    windows XP home
    P4 3,2 Ghz socket 478
    2 GB ram pc3200
    XFX geforce 7600 GT 580 AGP 8x
    mobo= ASUS p4v800d-x
    tried almost evertything

    Comment


      #62
      Finally got this kind of working.

      Initially, my screen turned off right after the UT3 splash. This was definitely fixed by updating OpenAL32.dll and wrap_oal.dll in the c:\windows\system32 directory. I am using a Creative Audigy 2 ZS and these dll's are NOT at the right level even if you're using the latest Creative driver.

      To fix this, just go to
      http://developer.creative.com/articl...&top=38&aid=46
      and run the oalinst.exe you can download from that web page.

      More posts later as I have time. This will get you past all the logos (Nvidia, Intel, Epic and Midway) ... and then your screen will again turn off!

      To get a little further, you really do need to edit
      c:\program files\unreal tournament 3 demo\engine\config\baseengine.ini
      and change
      bInitializeShadersOnDemand=False to
      bInitializeShadersOnDemand=True

      You MAY need to uninstall AVG Free 7.5 ... the readme says there's a driver resource conflict with Nvidia 7900 cards... I did this but at the moment I'm not certain whether this is really what got me to the Create Profile screen. It's very easy to re-install afterwards, so no big deal. Now that I have things working I'm planning to do just that to see whether the UT3 demo still works with AVG Free Anti-Virus 7.5 active.

      By the way, I have a 6800GS running the 163.71 Nvidia driver. Sorry it's my first post, I'll put all this in my profile.

      If you finally get to attempt to login, I still found my entire system froze after clicking on login ... keyboard and mouse were totally unresponsive. Luckily, I left it alone for a few minutes and a miracle occurred ... the system came back and let me proceed. I have no idea what's going on during this time, but I'm just saying be patient. As long as you get past the issue of your screen turning off, I think you'll get things working.

      What do I mean by 'the screen turns off'? The light on my monitor turns from green to amber, like it does when my screen saver kicks in ... but moving the mouse or using the keyboard doesn't revive it.

      This took a lot of research and patience, and I hope this post helps you. There are no new ideas in here, just a compilation of things that actually worked.

      Comment


        #63
        Originally posted by Zelos View Post
        Idd, Ill just wait for the patch...Im not going to remove my AV :/
        I refuse to believe that in the year of 2007, a company that for years now has been making multiplayer games, all of the sudden can't write a server broswer, or make it so we can play a multiplayer game behind a firewall program like Zonealarm, when I own a huge library of online games that ALL work just fine.

        I understand anti virus programs need to be disabled, those always want to scan everything, which slows your system down, but a firewall program? That's just retarded... That would mean that I own budget title games like DH Nakitomi Plaza, that were made with better net code then UT3? I find that hard to believe

        I would HOPE they will have this patched up soon, and I have faith in them. Epic has always done a great job with patches and mod support. Even if it is a rocky start. But you shouldn't suggest people leave their systems unprotected. This is something that needs to be patched.

        Comment


          #64
          OK, here goes... I will note that my system doesn't actually meet the requirements, though.

          Description of the problem:

          I start the game, the splash screen appears, disappears, then goes to fullscreen mode. After 5-10 seconds, the game crashes with the Kernel_32.dll crash that is being discussed in this thread. After this happens, only 640x480 of my screen area is usable, until I reduce the resolution and bring it back to 1400x1050.

          Video card and driver version: Intel GMA X3100 (I know, I know, below system requirements, but I'm not getting another machine just to play a demo,) driver version 6.14.10.4860
          OS: Windows XP Tablet Edition 2005 (SP2)
          CPU: Core 2 Duo T7500 LV, 1.6GHz (too low clock speed, but it IS dual core...)
          RAM: 2 GiB
          Antivirus: None
          Firewall: Windows firewall

          Attempted fixes:
          Changed bInitializeShadersOnDemand to True, then rebooted. No effect.

          Log files:
          http://bhtooefr.ath.cx/Launch.log
          http://bhtooefr.ath.cx/DxDiag.txt

          Comment


            #65
            for the people who touched their ini files and have this error, well it's your own fault!

            just reinstall and it should be fixed (normally), but when you uninstall don't forget to remove the leftovers like "program files -> unreal tournament 3","my docs -> my games" and in regedit (start -> run -> regedit) search for "midway" and "unreal", delete those too

            next time if you play with your ini files, make sure to backup the original files first and everything should be fine again!

            grtz

            Comment

            Working...
            X