No announcement yet.

Please post hardware compatibility issues here

This is a sticky topic.
  • Filter
  • Time
  • Show
Clear All
new posts

    Hardware Issue Information

    Thanks for the feedback everyone.

    I'm QA at Epic and we are currently setting up a list so you can send your complete dxdiag info to us, but in the meantime continue letting us know your machine specs if you are having issues. Important info to include:
    • Operating System
    • Video Card
    • Video Driver Version
    • Display Resolution
    • Processor
    • Memory

    Any other information provided may be useful as well. "My Documents\My Games\Unreal Tournament 3 Demo\UTGame\Logs\Launch.log" may have useful info too.

    Here is how to run dxdiag if you don't already know:
    1. Start Menu -> Run
    2. Type "dxdiag" in the Open prompt and hit OK

    Operating System, Processor, Memory will be in the System tab.
    Video Card and Driver Version will be in the Display tab.



      Originally posted by Paincakes View Post
      What do you mean by good? what is your fps when under heavy fire by multiple opponents?
      On 1024x768 its constantly 60fps with a little drop to like 40-50 fps when theres a real fight going on on screen. With 1280x1024 its around 30-60fps.(Of course there are small corridors and such)

      OS: Vista 32-bit
      Video Card : Radeon 2600XT GDDR4
      Video Driver : 7.10
      Display Resolution : 1280x1024
      Processor : Intel E2160 @ 2.4Ghz
      Memory : 2Gig DDR2-533


        game constantly keeps crashing after irregular periods of time.
        playing all settings maxed on 1680x1050

        MB: Asus P5N32-ESLIPlus
        CPU: Core2Duo 6320
        Vcard: Inno 8800GTS 320Mb (driver 163.71 whql)
        Scard: Soundblaster X-Fi
        Ram: Kingston PC-8500 2x1 Gb
        (no overclocking involved)

        Win XP(32) SP2 +updated

        p.s. I tried to post dxdig in my post, but it is 3x the allowed size of the post


          So i made the game create a log file. At the end this is my error

          Init: Client initialized
          Log: GConfig::Find has loaded file:  ..\Engine\Localization\int\
          Critical: appError called:
          Critical: Device does not support 1x32 FP render target format.
          Critical: Windows GetLastError: The operation completed successfully. (0)
          Heres the whole thing if needed.

          Init: Version: 3464
          Init: Epic Internal: 0
          Init: Compiled: Oct 11 2007 19:21:48
          Init: Command line: -log
          Init: Base directory: C:\UT3 Demo\Binaries\
          Init: Character set: Unicode
          Log: GConfig::LoadFile has loaded file:  ..\UTGame\Config\UTEditor.ini
          Log: GConfig::LoadFile has loaded file:  ..\UTGame\Config\UTEditorUserSettings.ini
          Log: GConfig::LoadFile has loaded file:  ..\UTGame\Config\UTDemoCompat.ini
          Log: GConfig::LoadFile has loaded file:  ..\UTGame\Config\UTEngine.ini
          Log: GConfig::LoadFile has loaded file:  ..\UTGame\Config\UTGame.ini
          Log: GConfig::LoadFile has loaded file:  ..\UTGame\Config\UTInput.ini
          Log: GConfig::LoadFile has loaded file:  ..\UTGame\Config\UTUI.ini
          Init: Computer: LAPTOP
          Init: User: rAMrOD
          Init: CPU Page size=4096, Processors=2
          Init: High frequency timer resolution =3.579545 MHz
          Init: Memory total: Phys=2086956K Pagef=4025036K Virt=2097024K
          Init: WinSock: version 1.1 (2.2), MaxSocks=32767, MaxUdp=65467
          Init: Presizing for 83221 objects not considered by GC, pre-allocating 0 bytes.
          Init: Object subsystem initialized
          Log: DEMOVERSION is defined.
          Init: WinSock: I am laptop (
          Init: Startup System Settings:
          Init: System Settings:
          Init:   StaticDecals=false
          Init:   DynamicDecals=false
          Init:   DynamicLights=false
          Init:   DynamicShadows=false
          Init:   LightEnvironmentShadows=false
          Init:   CompositeDynamicLights=true
          Init:   DirectionalLightmaps=false
          Init:   MotionBlur=false
          Init:   DepthOfField=false
          Init:   Bloom=false
          Init:   QualityBloom=false
          Init:   Distortion=false
          Init:   DropParticleDistortion=false
          Init:   SpeedTreeLeaves=false
          Init:   SpeedTreeFronds=false
          Init:   OnlyStreamInTextures=false
          Init:   LensFlares=false
          Init:   FogVolumes=true
          Init:   FloatingPointRenderTargets=true
          Init:   Trilinear=false
          Init:   OneFrameThreadLag=true
          Init:   UseVsync=false
          Init:   UpscaleScreenPercentage=true
          Init:   Fullscreen=false
          Init:   AllowD3D10=false
          Init:   EnableHighPolyChars=false
          Init:   SkeletalMeshLODBias=1
          Init:   ParticleLODBias=2147483647
          Init:   DetailMode=0
          Init:   ShadowFilterQualityBias=-1
          Init:   MaxAnisotropy=0
          Init:   MaxMultisamples=1
          Init:   MinShadowResolution=32
          Init:   MaxShadowResolution=512
          Init:   ResX=640
          Init:   ResY=480
          Init:   ScreenPercentage=50.000
          Init:   SceneCaptureStreamingMultiplier=1.000
          Init:   FoliageDrawRadiusMultiplier=0.000
          Init:   ShadowTexelsPerPixel=2.000
          Log:    TEXTUREGROUP_World: (MinLODSize= 256,MaxLODSize= 256,LODBias=0)
          Log:    TEXTUREGROUP_WorldNormalMap: (MinLODSize= 256,MaxLODSize= 256,LODBias=0)
          Log:    TEXTUREGROUP_WorldSpecular: (MinLODSize= 256,MaxLODSize= 256,LODBias=0)
          Log:    TEXTUREGROUP_Character: (MinLODSize= 256,MaxLODSize= 256,LODBias=0)
          Log:    TEXTUREGROUP_CharacterNormalMap: (MinLODSize= 256,MaxLODSize= 256,LODBias=0)
          Log:    TEXTUREGROUP_CharacterSpecular: (MinLODSize= 256,MaxLODSize= 256,LODBias=0)
          Log:    TEXTUREGROUP_Weapon: (MinLODSize= 256,MaxLODSize= 256,LODBias=0)
          Log:    TEXTUREGROUP_WeaponNormalMap: (MinLODSize= 256,MaxLODSize= 256,LODBias=0)
          Log:    TEXTUREGROUP_WeaponSpecular: (MinLODSize= 256,MaxLODSize= 256,LODBias=0)
          Log:    TEXTUREGROUP_Vehicle: (MinLODSize= 256,MaxLODSize= 256,LODBias=0)
          Log:    TEXTUREGROUP_VehicleNormalMap: (MinLODSize= 256,MaxLODSize= 256,LODBias=0)
          Log:    TEXTUREGROUP_VehicleSpecular: (MinLODSize= 256,MaxLODSize= 256,LODBias=0)
          Log:    TEXTUREGROUP_Effects: (MinLODSize= 256,MaxLODSize= 256,LODBias=0)
          Log:    TEXTUREGROUP_Skybox: (MinLODSize= 256,MaxLODSize= 512,LODBias=2)
          Log:    TEXTUREGROUP_UI: (MinLODSize= 256,MaxLODSize=4096,LODBias=0)
          Log:    TEXTUREGROUP_LightAndShadowMap: (MinLODSize= 256,MaxLODSize= 512,LODBias=1)
          Log:    TEXTUREGROUP_RenderTarget: (MinLODSize=   1,MaxLODSize=4096,LODBias=0)
          Init: Friendly System Settings:
          Init:   TextureDetail=Level1
          Init:   WorldDetail=Custom
          Init:   bUseVSync=0
          Init:   bUseMSAA=0
          Init:   ScreenPercentage= 50
          Init:   UpscaleScreenPercentage=1
          Init:   ResX= 640
          Init:   ResY= 480
          Init:   Fullscreen=0
          Init: OS stats:
          Init:   Windows XP Service Pack 2
          Init:   RemoteDesktop=0
          Init: Memory stats:
          Init:   Physical: 2038MB
          Init:   Virtual: 2047MB
          Init:   PageFile: 3930MB
          Init: CPU stats:
          Init:   MeasuredPerformanceTime: 732.914 (stored result)
          Init:   Hyperthreaded: 1
          Init:   NumProcessorsPerCPU: 1
          Init:   NumLogicalProcessors: 2
          Init:   NumPhysicalProcessors: 2
          Init:   MaxSpeed: 1828
          Init:   CurrentSpeed: 1828
          Init:   CoresPerProcessor: 2
          Init:   IsOnBattery: 0
          Init:   BatteryLevel: 100
          Init:   Manufacturer: Intel
          Init:   CPUName: Unknown INTEL CPU
          Init:   L1CacheSize: 32
          Init:   L2CacheSize: -1
          Init:   Architecture: x86
          Init: GPU stats:
          Init:   VendorID: 00008086
          Init:   DeviceID: 000027A2
          Init:   DriverVersion:
          Init:   DeviceName: Mobile Intel(R) 945 Express Chipset Family
          Init:   DriverName: igxprd32.dll
          Init:   PixelShaderVersion: 2
          Init:   VertexShaderVersion: 2
          Init:   VRAMQuantity: 128
          Init:   DedicatedVRAM: 117
          Init:   AdapterCount: 1
          Init:   SupportsHardwareTnL: 0
          Init: Machine  detected compatibility level: Composite: 1. CPU: 3. GPU: 1.
          Init: Previous detected compatibility level: Composite: 1. CPU: 3. GPU: 1.
          Log: Initializing FaceFX...
          Log: FaceFX initialized:
          Log:     version  1.710000
          Log:     licensee Unreal Engine 3 Licensee
          Log:     project  Unreal Engine 3 Project
          Log: Preloading (default) startup map UTFrontEnd
          Log: GConfig::Find has loaded file:  ..\Engine\Localization\int\
          Log: GConfig::Find has loaded file:  ..\Engine\Localization\int\
          Log: Loaded shader cache RefShaderCache-PC-D3D-SM2.CacheObject: 14715 shaders(0 legacy, 0 redundant), 2023 materials
          Log: GConfig::Find has loaded file:  ..\Engine\Localization\int\
          Log: GConfig::Find has loaded file:  ..\UTGame\Localization\int\
          Log: GConfig::LoadFile has loaded file:  ..\UTGame\Config\UTWeapon.ini
          Log: GConfig::LoadFile has loaded file:  ..\UTGame\Config\UTCustomChar.ini
          Log: GConfig::LoadFile associated file:  ..\UTGame\Config\UTMap.ini
          Log: GConfig::Find has loaded file:  ..\Engine\Localization\int\
          Log: 87906 objects as part of root set at end of initial load.
          Log: 0 out of 0 bytes used by permanent object pool.
          Log: Initializing Engine...
          Log: GConfig::Find has loaded file:  ..\Engine\Localization\int\
          Log: GConfig::Find has loaded file:  ..\UTGame\Localization\int\
          Init: UEngine initialized
          Log: Looking for PC DLC...
          Log: Object size..............: 60
          Log: Actor size...............: 436
          Log: ActorComponent size......: 88
          Log: PrimitiveComponent size..: 448
          Init: ALAudio device requested : Generic Software
          Init: ALAudio device opened    : Generic Software
          Init: AL_VENDOR      : Creative Labs Inc.
          Init: AL_RENDERER    : Software
          Init: AL_VERSION     : 1.1
          Init: Device supports: ALC_EXT_EFX
          Init: Found EFX extension with 1 effect slots and 1 potential sends
          Init: ...'reverb' supported
          Init: ...'low pass filter' supported
          Init: ALAudioDevice initialized.
          Init: Client initialized
          Log: GConfig::Find has loaded file:  ..\Engine\Localization\int\
          Critical: appError called:
          Critical: Device does not support 1x32 FP render target format.
          Critical: Windows GetLastError: The operation completed successfully. (0)


            I'm not sure if this is a hardware issue (my mouse) but I wanted to post this problem here as well...

            When I try to customize the controls, the game doesn't recognize the difference between my mouse 4 and 5 buttons. It's thinks they both are mouse 4.


              I'm surprised that I can run this on my computer.... Here are my specs:

              CPU: Athlon XP +3000 1.8Ghz
              RAM: 2 GB
              VIDEO: AGP 7800 GS 256 RAM
              HDD: 120GB
              SOUND: SB Audigy 2
              OS: Windows XP SPK2

              I know the bottleneck for my system is the CPU and videocard.... But I don't have the funds to upgrade right now....



                Didn't know where else to post this, but the game doesn't seem to accept any of my email addys. I don't know if it's the game, or a problem w Gamespy's servers. *shrugs*


                  Originally posted by Paincakes View Post
                  According to the windows update yes. It can't fidn any other updates. So my OS is most likely up to date.

                  But after a bit more testing I found out it was another problem.
                  With all settings on lowest details possible... I get average of 40 to 50 fps. Sometimes it can reach to 30ish all of a sudden for a short moment.
                  With all maxed out at 1680x1050 and full details possible. I get 25 to 30 fps and 15 to 25 when under heavy combat.

                  Doesn't this seem a bit weird how the game scales with hardware? This just makes me wonder how people with a Pentium 4 and poor grafix card can play this game on medium settings.

                  I have a Quad Core 6600, 2GB Ram and 8600 gt 512mb (drivers 163.69 up to date.), vista 32 bit home premium. (up to date)

                  I have noticed my game really lags and hitches and plays very choppy even when the fps is on 40 to 50. Not always choppy... but mostly when under heavy fire and multiple opponents on the screen. Like 4 enemies or 6.

                  Its completely unplayable for me.

                  I can do Inhuman instagib mode with UT2k4 and it will be easy for me.
                  But with this game I can't aim! There is something wrong with the framerates.
                  Have you tried lowering your screen resolution? You cannot plat at 1680x1050 with your card. You will also need to keep your quality settings no higher than medium. The 8600 series cards do not do well in games at high resolution and high quality settings. You need an 8800 series card for that.



                    Running an older video card, so I'm not expecting the best looks for this game on this PC.

                    However, I am having issues with the graphics. I have an ATI 9600 Mobility 128 MB RAM vid card on an Alienware laptop. I am using the latest Catalyst mobility drivers (7.10). The game loads fine, and the graphics are at the lowest settings and resolution (640x480). Game runs smooth for a few minutes, but then suddenly the game freezes, blinks and goes black, at about the same time index each game I start. The screen flickers a few times, then I can see icons from my desktop flashing all over the place, through the frozen image of the game. I can click on the game on the flickering image of the taskbar at the bottom of the screen and am taken back into UT3. I can play fine for a few more minutes, then the screen will black again, and I have to use ctrl-alt-del to get out of the game and back to the desktop.

                    The desktop resolution is forced into a change to match the game's resolution. Also, this same desktop resolution issue happens when I enter the game, and quit quickly before the above issues happen.

                    Again, I know this is an older machine (P4 3.2 dual processor, w/ 1 GB RAM), but I thought I would post this issue anyways. If this is too much info, then I apologize, but hopefully its useful.

                    EDIT: running WinXP Pro, SP2
                    if I knew how to add my dxdiag and the UT logfile, I would add it here as files (rather than post the whole amount of text and clog the forum up)


                      According to what I've heard, Intel video cards are not compatible with UT3?


                        Each time (since the very first try) I get a BSOD after all the company splash screens but when I assume the main menu should load. Unfortunately, it's a very generic message saying something to the effect of "run any system diagnostic utilities" and "check memory for faulty or mismatched memory" and "remove any recently installed drivers or devices". I've changed nothing on my PC for a long time, and it's a very clean system without any hardware or software conflicts.

                        This was the only line that had any other specific info from the BSOD:
                        STOP 0x0000007F (0x00000000, 0x00000000, 0x00000000, 0x00000000)

                        I have the newest 163.71 nVidia drivers and the following specs:

                        Dell XPS 400
                        Pentium D Dual Core
                        1GB RAM
                        GeForce 6800 GS
                        Windows XP SP2

                        The computer is a couple years old, but it's always been very solid and speedy. I can't imagine the problem! Any help Epic would be greatly appreciated.



                          I'm having some issues with the demo as well,
                          At first, the demo would not run at all, it just showed the logo splash screen and then quit.
                          After some investigation on these forums I tried to disable the sound by changing the bUseSound parameter to 'False' in the UTEngine.ini file.
                          After that, the game did work, but without sound.
                          As for my sound hardware, I'm using the onboard soundchip of my Asus P5K motherboard (Soundmax driver).
                          I also tried running it with my secondary soundcard, An EMU 1820M Professional soundcard, but that didn't work either.

                          Just some more information of my system:

                          CPU: Intel Core 2 Duo E6850
                          Memory: 2 GB Kingston
                          Graphics: Asus 8800 GTS 320 MB
                          Graphics Driver: Nvidia Forceware 163.71
                          Resolution: 1280x1024
                          Mainboard: Asus P5K Deluxe (P35 Chipset)
                          OS: Windows XP SP2 Dutch 32-Bit


                          Edit: Problem fixed, install the OpenAL driver and sound works fine with sound turned on in UTEngine.ini

                          Link to OpenAL driver:


                            Vista x64 + Audigy 2 ZS, Open AL sound problem

                            Intel Q6600 @ 3.42ghz
                            Abit IP35-Pro
                            8800GTS 640 @ 620x1000
                            2gb Ballistix PC2 8500
                            Audigy 2 ZS, with latest non-beta driver
                            Klipsch ProMedia 5.1 Ultra

                            the game runs great but half way through my second round on the first map my audio went from clear and crisp to a screeching almost midi-sounding continuous stream of corruptedness.. it was sort of catchy and up-beat though, adjusting itself dynamically with the action....initially I thought it might have been a special feature because I was racking up quite a bit of fast kills at the time.. but after a few minutes completely lacking any sign of "normal" game sound that theory was dashed.

                            otherwise I am loving this demo and cant wait for the full game, the controls especially feel very solid


                              Once in a while when switching maps or going back to menu I get a black screen. I have waited 1-2 minutes and nothing. I can not shutdown UT and I have to power down through hardware to resolve the problem. Here is my information.

                              Motherboard: Nvida
                              Intel 2duo core 2.66 E6750 1333MHZ FSB
                              3 GB Ram
                              1.0 terabytes drive space
                              Windows XP SP2 (latest updates)
                              Nvidia 8600 GTS 256MB version: 6.14.0011.0095 (english)
                              DirectX 9


                                Try visiting and log in there with the same credentials.