Announcement

Collapse
No announcement yet.

Map Startup looks for wrong assets

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Map Startup looks for wrong assets

    I have my own mod folder and everything works fine when when I load up my mod shortcut. The problem comes when I simply try to doubleclick one of my maps located in my mod's map directory. It doesn't load and it insists on looking in the ut2k4 default texture directory for my texture pack instead of the texture pack sitting in my mod directory. I have the proper paths pointing to my own mod folders in the ini file so am I missing something in there?

    #2
    You could try a shortcut to the map that has the mod switch. But for some reason I don't think opening maps like that will work. :bulb:

    Comment


      #3
      Yes. The "problem" exists in the windows registry for what action occours when you double click a map. By default, this launches UT2004 to the map you clicked on. The mod structure works by passing UT2004 a parameter (-Mod=MyMod) to the game, which tells it to load this ini up and set a lot of the paths to the ones specified in that ini. In other words, when you double click a map, you're trying to open that map with UT2004, without the mod structure active. Without the mod structure active, UT2004 has no idea where your resources are (unless you add your mod paths to the Ut2004 ini as well). The only way to "fix" this (and break the default UT2004 maps from opening in UT2004) is to modify the registry entry for the .ut2 filetype to add the -mod parameter for your mod.

      Or, just get over it.

      Comment


        #4
        Thanks guys. I thought I was just doing something wrong with my ini file, but that doesn't matter now.

        Comment

        Working...
        X