Announcement

Collapse
No announcement yet.

Defining the Gametype class file.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Defining the Gametype class file.

    I'm having this problem where when I compile my files, no changes are made to the mod. i have a .uc file in my classes directory called testGame. I extended deathmatch and tried to set bquickstart=True in the default properties. I also tried to clear the addBots function. the files do have a successful compile, no errors....but nothing happens. bots are added, and there's a countdown and everything. Is the mod not using that testGame file?

    #2
    Are you playing maps for it through 2k4's menus?

    Comment


      #3
      I have a shortcut to the mod, using the mod switch command. Then I have a custom menu that extends UT2K4GUIPage. when I click Play, its loads my map. Ideally I would also like to get rid of the menu altogether. So when I open the shortcut, it would go to the custom splash, and then directly to loading the map.

      Comment


        #4
        are you sure your stuff is getting loaded? maybe add a log(something); command or 2 to check. Then look a the log.

        Comment


          #5
          Originally posted by yourBestMan
          I have a shortcut to the mod, using the mod switch command. Then I have a custom menu that extends UT2K4GUIPage. when I click Play, its loads my map. Ideally I would also like to get rid of the menu altogether. So when I open the shortcut, it would go to the custom splash, and then directly to loading the map.
          At the end of the splash have a ScriptedTrigger that does a ConsoleCommand:

          open mapname

          Just make sure the map's DefaultGameType is set to your gametype in the default properties if it's your own map.

          Comment


            #6
            hey you were right, i had to set the defaultGameType property. I had never saw that anywhere or read about it, just looked it up at wiki. thanks alot!

            Comment


              #7
              How did you clear the AddBots function?

              Comment


                #8
                override the function without a body, or an empty body.

                Comment

                Working...
                X