No announcement yet.

ConTEXT compiling

  • Filter
  • Time
  • Show
Clear All
new posts

    ConTEXT compiling

    ok so i made some scripts but i dont know how to set up the short cut keys i went to environment options>execute keys>user Keys. what do i do from there, to set it up to compile?

    you can manually compile your scripts by adding your package name to the EditPackages list in the UT2004.ini.

    Then open a Command Promt (run -> "cmd"), go to your UT2004 systemfolder and type (in this order) the following commands
    ucc make
    ucc dumpint PACKAGENAME.u
    ucc exportcache PACKAGENAME.u
    obviously PACKAGE name is to be replaced with the name of your own package. make sure you delete (del PACKAGENAME.*) any older versions of your mod before doing the ucc make.


      Here's what I did: I first made a file named "Make.bat" and put it in my system folder: That file simple contains the following two lines:

      del %1.u
      ucc make -ini=UT2004Context.ini

      Then I made a copy of my ut2004.ini file named "UT2004Context.ini

      Then, in Environment Options -> Execute Keys, under f9, I set execute to make.bat, Start in to C:\UT@004\System, and Set "Save" to "all filed before execution".
      Make sure you also check "capture output to console, or you won't be able to see what errors are present.
      Set "parameter" to the directory of whatever project you are working on, and make sure you add the project name to the editpackages sections of your "UT2004Context.ini"

      I also set F10 to execute UT2004.exe, and start in UT2004/System
      So you can hit F9 to compile, and if all goes well, hit F10 to start the game.

      The reason for making a new UT2004.ini file (UT2004Context.ini) is mainly to keep your origonal INI clean, and will give you the ability to remove a bunch of stuff to make compling and game startup faster, or so I'm told. Either way, if you mess anything up in it, you won't break the game, and you'll only have to make a new UT2004context.ini from the origonal UT2004.ini again.

      Hope that helps.