Announcement

Collapse
No announcement yet.

Help with new MOD arch. folder setup!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Help with new MOD arch. folder setup!

    Hey everyone. I am currently trying to move all my MOD code into the new MOD architecture, and I am having some problems. When I try to compile in WOTgreal, my stuff will compile, but then it will say "Loading... Error Loading !!!" in the dialog window of the compile. My .ucl files are not present in my /MOD/System directory (or anywhere for that matter) and obviously none of my code is working. My two questions are: what is with this "Loading... Error Loading !!!" thing in WOTgreal and why are my .UCL files not getting into my mod's system directory?

    By the way, I have already re-set the CacheRecordPath to be my mod system directory. I think I have followed all the steps to setup the MOD arch correctly, but maybe I missed something?

    Thanks for the help!

    #2
    the error loading bug is actually a bug in ucc, from what i understand. also make sure your mods system folder has a defuser and default ini, and make sure the default ini has the correct system paths (so UT knows where your stuff is).

    Comment


      #3
      i never compiled without the "error loading" warning, and it always worked.

      you can generate your ucls by calling "ucc exportcache -mod=MyMod MyMod.u"
      no extra paths, the -mod= tells it everything

      also for the paths in the default.ini, make sure you ADD them with a "+" in front. otherwise you'll end up with only one path
      (like "+Paths=../MyMod/Textures/*.utx"

      Comment


        #4
        Yeah I have all that setup the way you guys have said. But do you have to go and manually call ucc exportcache every time when you compile with WOTgreal?

        Comment


          #5
          i have no idea why this is

          in the beginning( 5 weeks agot for me) wotgreal certainly did it.
          only when it somehow stopped (no idea why/when exactly), i began to investigate what ucls are about

          but you don't have to call exportcache all the time
          only if you add a new gametype, vehicle, weapon or mutator (not sure what else, but these are the most important), or if you change the basic basic defaultproperties of these (like name or description)

          look at a ucl file in a text editor and you'll see what i mean

          Comment


            #6
            Well the way I have it now setup is it always calls ucc exportcache -mod=DDA DDAMain.u after compiling, since right now I am just using 1 package. You can do this is the compile options section. It just sucks that it will not do it correctly how it does for normal UT stuff.

            J

            Comment

            Working...
            X