Announcement

Collapse
No announcement yet.

CTF Flag Mutator

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    CTF Flag Mutator

    I want to make a mutator for my clan that will change how the flags look to our clan logo.

    Ive seen custom flags on custom maps, but I want my flags to override the default flags on every map.

    I have no idea where to even start with this, accept to make my flags textures.

    Can anyone give me a few pointers to get me headed in the right direction.

    The only other posts ive seen about this are all directed to ut99, I want to do this in ut2004.

    Thx in advance, Fusion.

    #2
    You probably want to focus on a team symbol rather than a flag shader. This method works:
    Changing Team Symbols

    Changing actual flag skins in UT2004 takes a bit of work. If you make them like the stock flags, then that's a 2.7 MB download for anyone who joins the server. I have a mutator coming out soon which does change the flag skins, but I think that's overkill for what you want to do.

    Two new team symbols are only 86KB each and don't require a mutator. Plus team symbols get applied to many things besides flags.

    Here is an example of new team symbols:
    Eat Jello Pudding

    Comment


      #3
      Looks like this will work out good for what I want to do.

      I made it out harder than it was actually going to be.

      Comment


        #4
        Everything worked fine on the first image I tryed. Probally because there wasn't anything transparent. When I tryed to use our clan tag all of the images showed up,accept the one that was suppose to be on the flag. It turned completly white(base and all).

        I had alpha on, and all of the other settings just like it said. I even looked at the TeamSymbols2004, and they were exactly the same as those. Is there anything else I could have done wrong?

        Comment


          #5
          Don't know. It sounds like maybe you have TC_Wrap instead of TC_Clamp on the team symbol texture or the alpha is just screwed up. The flag shaders are already a touchy stack of materials, maybe your symbol is just too complex.

          Also, check the stock flag shaders in UnrealEd in XGameShaders2004. If they don't show up right in UnrealEd, then your original flag shaders are corrupted.

          Comment


            #6
            Bump.

            Has anyone figured out why the flags end up white? I have all the settings the same as the regular team symbols, and I've tried all of the different ways of importing it that I could think of. :bulb:

            Comment


              #7
              Aha! Nevermind, got it fixed.

              I exported a 2k4 symbol, didn't notice anything strange about it in PS. But, when I went to make a new test texture, I noticed that PS's image mode was changed to Greyscale. So, all you need to do is convert your image to greyscale, then back to RGB before exporting. Go figure. :bulb:

              Comment

              Working...
              X