Announcement

Collapse

The Infinity Blade Forums Have Moved

We've launched brand new Infinity Blade forums with improved features and revamped layout. We've also included a complete archive of the previous posts. Come check out the new Infinity Blade forums.
See more
See less

Mod Author Resources

Collapse
This is a sticky topic.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    Originally posted by Harmeister
    I didn't think you were complaining, so no problem. I just wanted to point out that even though there are very few differences now, there will be larger and larger ones down the line.
    Something to help with GUI stuff would be a god send, I have this sheet of paper covered in long hand math trying to place radar circles, aligned and scaled nicely. Overall thankyou for your time and effort in developing this.

    Comment


      #17
      Originally posted by Harmeister
      The folders should be in the UT2004 directory (not the UT2004\scripts3186 directory) because UCC will not be able to pick them up otherwise.

      in other words it looks like this
      Code:
      UT2004
      + Core
      |   + Classes
      |      + A whole bunch of Files
      + Engine
      |  + Classes
      |     + More classes
      
      etc.
      Thanks, much better now. Great program!

      Comment


        #18
        i just reinstalled ut2004 like 2 days ago because of some fing cd key error.

        and how will reinstalling it fix the error with it bringing up the weapons of evil mod??? i am just going to export it and do it my self. umod sucks i has NEVER worked, NEVER. so f it.

        Comment


          #19
          Originally posted by Bigcheeese
          i just reinstalled ut2004 like 2 days ago because of some fing cd key error.

          and how will reinstalling it fix the error with it bringing up the weapons of evil mod??? i am just going to export it and do it my self. umod sucks i has NEVER worked, NEVER. so f it.
          ah, *now* I understand (sorry about that). I thought you were calling the installer evil, not that the ut4mod somehow got associated with that mod's installer.

          to fix the ut2004 installation error make sure that the "HKEY_CLASSES_ROOT\UT2004.Module\shell\open\comman d" key's default value is set to something like 'C:\UT2004\System\Setup.exe "%1"' (w/o the single quotes, with the double quotes).

          Lastly, if the Weapons of Evil mod overwrote setup.exe with their own, then I don't know what to do other than to re-install. Sorry that my post seemed rude, but that really was the only way I know to deal with it if they overwrote setup.exe (which seems more likely than overwriting the registry entry).

          Comment


            #20
            I've also seen installers have this problem when there is **** left behind in your temp directories. (like once, for reason's I could never figure out, every time I tried to launch the NVidia detonator installer it would launch the installer for the new sound card I just put in). InstallShield is particularly flakey sometimes. So the other thing to do is to clean out all your temp directories

            Possible locations include
            C:\Tmp
            C:\Temp
            C:\Windows\Tmp
            C:\Windows\Temp
            C:\Documents and Settings\username\Local Settings\Temp
            C:\WINNT\Profiles\username\Local Settings\Temp
            etc.

            The usual suspects, really.

            Comment


              #21
              thanks but i just got umod extractor and did it my self its ezer that way.

              Comment


                #22
                Originally posted by StevePolge

                We will begin testing a patch for UT2004 in the next few days.
                If you plan to release a patch for UT2004, can you please correct the bug in CTFSquadAI file ? (this bug makes a lot of warning when playing in VCTF, and prevent bots from using vehicle in this gametype) See my post about CTFSquadAI in the Troubleshooting & Technology section for more info (I think the code I give there can fix this bug )

                Thx

                Comment


                  #23
                  Originally posted by Harmeister

                  to fix the ut2004 installation error make sure that the "HKEY_CLASSES_ROOT\UT2004.Module\shell\open\comman d" key's default value is set to something like 'C:\UT2004\System\Setup.exe "%1"' (w/o the single quotes, with the double quotes).
                  more likely than overwriting the registry entry).
                  This is good and all but how the hell do i do it??? cos i got a similar problem with a ut4mod file

                  Comment


                    #24
                    Originally posted by olivehehe_03
                    This is good and all but how the hell do i do it??? cos i got a similar problem with a ut4mod file
                    First thing is to check the setup.exe in your UT2004\System directory. Make sure it's the UT2004 one and not from some other mod (may or may not happen, don't know). If it is not the UT2004 one then you will have to re-install UT2004.

                    If this file *is* the UT2004 one, then follow these steps

                    [NOTE: I claim no responsibility if this messes things up. I've done it on my own system many times, but playing in the registry is not for the weak of heart]

                    open up RegEdit (Start->Run->type in "regedit" w/o the quotes, press enter)
                    browse through the tree till you find HKEY_CLASSES_ROOT\UT2004.Module\shell\open\command
                    if the value of the default key on the right is not pointing to 'C:\UT2004\System\Setup.exe "%1" (where C:\UT2004 is your own installation directory) then change it to be correct. (Double click on the value and it will pop up a dialog where you can change it)
                    Close regedit.

                    Comment


                      #25
                      Originally posted by Harmeister
                      There are two large differences: the UDE will *ONLY* work for UT2004 (not UT, not UT2003, not any other unreal engine game), and it will not receive any significant new features. WOTgreal development is continuing (albeit kind of at a slow pace because of real life contingencies) and you will like the results (like the GUI designer, which the UDE will not receive right now).

                      Dean
                      GUI designer??? <3

                      Comment


                        #26
                        How long until we get some native linux tools for compiling?

                        Comment


                          #27
                          Wow!! UDE is much better than what I've been using for the past year...notepad.

                          Originally posted by muska
                          How long until we get some native linux tools for compiling?
                          muska: Just *maybe* someone out there has already made emacs macros for unrealscript. Or, if you're like me and not down with editors which are over a decade older than I am, take a look on sourceforge.net and see if there's anything out there. As a Linux programmer, I'd make a tool if I had the time, but I most certainly don't.

                          Comment


                            #28
                            Earlier someone said to install the umod file inside the zip. How do you do that? I've read the post a few times and I can't figure it out for the life of me.

                            Comment


                              #29
                              Also, are we supposed to compile the .uc files into the system directory? I'm a complete noob, can someone please explain this to me?

                              Comment


                                #30
                                GUI Designer.. Could you explain More Please

                                If i am not wrong I beleive you mentioned the GUI designer in WOTgreal. Can you elaborate on that... were this is.. or when it is going to be released...

                                cheers

                                Comment

                                Working...
                                X