Announcement

Collapse
No announcement yet.

Vehicle help

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Vehicle help

    i am working on creating a gunship flying vehicle

    i got it working and all but i am having trouble setting the vehicle health, and names

    i found the localization file for the vehicle name string and added my vehicle name/strings but it did not help

    is there something that i am missing

    btw my UCC.exe program is not working

    #2
    The vehicle name is set in the Default properties of the script for it.


    VehicleNameString="Name" Sets the name
    VehiclePositionString="in a Name" is for when you broadcast your position
    HealthMax=500 Is the vehicles max health
    Health=5000 is the vehicles starting health

    Comment


      #3
      ucc.exe has to be started in DOS i believe

      Comment


        #4
        the thing is im running on windows xp so there is no dos

        i have tried to edit the default properties of the script as the .uc but i have no way to recompile it

        i tryed the UMake program but i dont understand what it does to the .uc script - as in where does it go when its done

        one other thing i tried was typecasting those variables from the Pawn class but it didnot work

        Comment


          #5
          XP does not have dos, but it does have a command prompt in which you can use UCC make

          Comment


            #6
            please tell me your not double clicking on UCC.EXE? Are you double clicking on it like your trying to run a normal program? Its a dos based program that only works with command line arguements. In order to use it you will have to click on START->RUN
            in the window type CMD and press ENTER

            a window that resembles the the old DOS windows will pop up.

            now change directories till your in your system folder of your ut2004 folder. eg c:\ut2004\system

            BEFORE you can compile your script you will need to add its package name to your ut2004.ini file
            open it up and look for the first section that has EDITPACKAGES in it. add yours to the end of them. Like this EDITPACKAGES=MYMOD

            dont include the .UC extension in it

            now you can use UCC MAKE in that dos window

            I hope you didnt modify the original exported code. And I hope you copied the script file over to the correct directory structure and renamed it to what your naming your mod. I have had to help a couple of people with this.

            Comment


              #7
              i tryed using run but id didnt work either
              the comand prompt opens and then closes right away

              i got it to work anyway with the UMake program i found

              thanks for the help

              Comment


                #8
                even tho you got it working with the other ima gonna post this any ways....

                You didnt read my post very well about the run command....
                in the run window you put UCC right? dont put UCC
                put CMD....that is the command prompt program for XP
                its the DOS window for xp basically
                and in that window you will use the UCC command

                Comment


                  #9
                  oic...

                  oops

                  thx for clarifying that

                  Comment


                    #10
                    NP thats what I'm here for...help!

                    Comment

                    Working...
                    X