Announcement

Collapse
No announcement yet.

directory structure and ucc UT2004

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    directory structure and ucc UT2004

    http://unreal.epicgames.com/ut2004/t...modsupport.htm

    Using UT2004 new mod project file structure what do I put in my UT2004.ini file to get ucc to compile my script correctly?

    Using there example you'd think it'd be something like:

    [Editor.EditorEngine]
    ...
    ...
    EditPackages=MyMod\MyMod

    However this doesn't fully work. This is taken from ucc.log:

    Code:
    Warning: Failed to load '..\GUIRes\MyMod/MyMod.u': Can't find file '..\GUIRes\MyMod/MyMod.u'
    Warning: Error deleting file 'MyMod/Save.tmp' (0x3)
    Critical: Error opening file
    Exit: Executing UObject::StaticShutdownAfterError
    Critical: UObject::SavePackage
    Critical: UMakeCommandlet::Main
    Exit: Exiting.

    #2
    look at all of the other EditPackages= lines. none of them have a directory in them.

    you want to place a folder in the UT2004 directory, call it "MyMod" and then inside of it a folder named "classes" and thats where your code goes. then EditPackages=MyMod.

    Comment


      #3
      I use a program called umake to compile.
      It works for 2004, this way you don't have to mess with the .ini at all.. A google search should find it.

      Comment


        #4
        How did you get to this tutorial from unreal.epicgames.com?

        There are no links on that page leading to any tutorials about ut2004. What other hidden stuff are there and how do you get to them?

        phong.

        Comment


          #5
          Originally posted by Bonehed316
          look at all of the other EditPackages= lines. none of them have a directory in them.

          you want to place a folder in the UT2004 directory, call it "MyMod" and then inside of it a folder named "classes" and thats where your code goes. then EditPackages=MyMod.
          Yes. Thanks but this only works if you want all your .uc files in the same .u file. Their directory structure alludes to the fact that you can setup the ut2004.ini so it can use the new directory hierarchy.

          I found the page via Google. It appears to be an oversight that Epic doesn't link it via their main page.

          Comment


            #6
            I think I might have the answer!

            The tutorial file posted at the beginning of this thread mentions that UT2004, Unrealed, and most importantly UCC all support the -MOD parameter.

            So maybe you say "ucc make -MOD=yourMod" and it knows to use the right folders to compile provided you have the editPackages listed correctly in the mod's .ini file?

            Can anyone confirm?

            Comment


              #7
              Good guess but 'ucc make' didn't like that flag.

              ucc make -MOD=MyMod

              returned:
              Code:
              BadMod
              and exited.

              Nothing else was reported in ucc.log as well that was useful.

              Comment


                #8
                Maybe MyMod needs to be in quotes?

                Comment


                  #9
                  Scratch the quotes idea. I just tried ucc make -mod=TestMod with the test mod supplied at the end of the tutorial page and it made just fine.

                  Donno what's not working for you sky but I think if you looked over the structure of the testMod things should work out for you.

                  cheers!

                  Comment


                    #10
                    Yep the testmod example worked but mine did not. Thanks. I'm trying to find the difference(s) now.

                    I really like the idea behind this new system of organization.

                    Comment


                      #11
                      Please tell us what was different once you figure it out. Share the wealth man!

                      Comment


                        #12
                        I found the problem.

                        \UT2004\TestMod\UT2K4Mod.ini file needs to be named exactly 'UT2K4Mod.ini'. I had renamed it to my mod's name. Renamed it and it worked like a charm. Thanks for the help. The -MOD= switch was what I was over looking. RTFM! Good eye.

                        Thanks for the help.

                        This new system is great though. It was ugly that one needed to change the base UT files to get a mod compiling and running, etc. Now it appears those days are over. Or at least epic has made an attempt to end those days.

                        Comment

                        Working...
                        X