Announcement

Collapse
No announcement yet.

Mutator wont work online

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Mutator wont work online

    Hey,

    I'm pretty new in UnrealScript and I decided to make a mutator for ut2k4, it's not a very complicated script, didnt edit almost anything, only changed some ammo use per shot, spread and delay.
    The mutator works great offline in instant action, bots dont have any prob using it.
    Though when I tested it online, I opened a server, and someone joined it, I had the weapon, but he didnt have anything.
    When he opened a server with the mutator, he had the weapon but I didnt.
    I dont know whats wrong, any ideas what it could be?

    #2
    You're not replicating the weapon to the client. Anytime the client isn't seeing the fruits of your labour, replication is the problem.

    You'll want to get a hold of some source for a weapon mod that someone else did to see how they did it. It might be something really simple such as setting the new classes to be alwaysreleveant? But I don't know for sure.

    Comment


      #3
      You need to add the mutator to your game's ServerPackages. It's in UT2004.ini under [Engine.GameEngine]. Where you see the list of ServerPackages= lines, add your package to the list.

      There's also a mutator option bAddToServerPackages that's supposed to do that for you if set to true, but unfortunately it doesn't work in the gold version. It will be fixed in the first patch.

      Comment


        #4
        Originally posted by Mysterial
        You need to add the mutator to your game's ServerPackages. It's in UT2004.ini under [Engine.GameEngine]. Where you see the list of ServerPackages= lines, add your package to the list...
        Man... I would kiss you!
        thanks man, it works.

        Comment


          #5
          Originally posted by Mysterial
          You need to add the mutator to your game's ServerPackages. It's in UT2004.ini under [Engine.GameEngine]. Where you see the list of ServerPackages= lines, add your package to the list.

          There's also a mutator option bAddToServerPackages that's supposed to do that for you if set to true, but unfortunately it doesn't work in the gold version. It will be fixed in the first patch.
          About that option - would the serverpackages entry then always be in, or only when the mutator is on, and when it isn't, the serverpackages entry is removed?

          Comment


            #6
            Originally posted by Shuri
            About that option - would the serverpackages entry then always be in, or only when the mutator is on, and when it isn't, the serverpackages entry is removed?
            It doesn't really add an entry to the ServerPackages list, it directly adds the package to the package map. So if you remove the mutator, it won't be downloaded by clients anymore.

            Comment

            Working...
            X