Announcement

Collapse
No announcement yet.

New weapon animations not working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    New weapon animations not working

    Hey all-

    I've been going crazy trying to get my new weapon's animations to work. I've read every tutorial I could find, watched 8 or so VTMs from 3dbuzz, and everything says and looks like it should be working.

    I'm using UT2004, and I can see the skeletal mesh and the animations in unrealed. I've got my .u file compiled and everything works (at least sort of) but the animations for fire, select, and put down do happen in game. The ut2004.txt log indicates that there is no 'fire', 'select' or 'putdown' animation for the mesh 'revolver' but it is there... and I'm pretty sure I didn't spell any of them wrong. (Yes, I did triple check that). The line of code in revolverFire that indicates what animation to use, unless I'm greatly mistaken, is FireAnim=Fire. (I also made sure the case matched, tried both upper and lower.) If anyone can point me in the right direction, your help would be greatly appreciated. Thanks for your time!

    #2
    You may have forgot to assign the default animations for your mesh:
    In Editor on Animations Browser.
    In there select you mesh and animations then go to Edit > Linkup anim and mesh, and then save your animations package.

    Comment


      #3
      WOW. I can't believe it was that simple. Thank you so much for responding, problem 100% solved

      Comment

      Working...
      X